Navigacija
Lista poslednjih: 16, 32, 64, 128 poruka.

instalacija eclipse na fc8

[es] :: Linux :: instalacija eclipse na fc8

[ Pregleda: 2426 | Odgovora: 11 ] > FB > Twit

Postavi temu Odgovori

Autor

Pretraga teme: Traži
Markiranje Štampanje RSS

Alexe
Beograd

Član broj: 172465
Poruke: 37
*.adsl.eunet.rs.



Profil

icon instalacija eclipse na fc829.11.2009. u 17:26 - pre 132 meseci
Pokusavam da instaliram eclipse na FC8 koristeci "yum install eclipse-*" ili "yum install eclipse", medjutim javlja mi missing dependencies:
--> Finished Dependency Resolution
Error: Missing Dependency: jakarta-commons-logging is needed by package jetty
Error: Missing Dependency: ant-commons-logging is needed by package eclipse-platform
Error: Missing Dependency: jsch >= 0.1.31 is needed by package eclipse-platform
Error: Missing Dependency: ant-swing is needed by package eclipse-platform
Error: Missing Dependency: jakarta-commons-dbcp-tomcat5 is needed by package tomcat5
Error: Missing Dependency: icu4j-eclipse >= 3.6.1 is needed by package eclipse-rcp
Error: Missing Dependency: jakarta-commons-modeler >= 2.0 is needed by package tomcat5-server-lib
Error: Missing Dependency: jakarta-commons-launcher >= 0.9 is needed by package tomcat5
Error: Missing Dependency: fedora-usermgmt is needed by package jetty
Error: Missing Dependency: jakarta-commons-el is needed by package jetty
Error: Missing Dependency: mx4j >= 3.0 is needed by package jetty
Error: Missing Dependency: jakarta-commons-launcher is needed by package eclipse-platform
Error: Missing Dependency: ant-jdepend is needed by package eclipse-platform
Error: Missing Dependency: ant-apache-resolver is needed by package eclipse-platform
Error: Missing Dependency: jakarta-commons-collections-tomcat5 is needed by package tomcat5
Error: Missing Dependency: jakarta-commons-fileupload is needed by package eclipse-platform
Error: Missing Dependency: ant-javamail is needed by package eclipse-platform
Error: Missing Dependency: jakarta-commons-io >= 1.2 is needed by package tomcat5
Error: Missing Dependency: lucene-contrib >= 1.9.1 is needed by package eclipse-platform
Error: Missing Dependency: jakarta-commons-pool-tomcat5 >= 1.2 is needed by package tomcat5-common-lib
Error: Missing Dependency: ant >= 1.6 is needed by package jetty
Error: Missing Dependency: ant-antlr is needed by package eclipse-platform
Error: Missing Dependency: jakarta-commons-logging >= 1.0.4-6jpp.3 is needed by package eclipse-platform
Error: Missing Dependency: jakarta-commons-collections-tomcat5 >= 3.1 is needed by package tomcat5-common-lib
Error: Missing Dependency: jakarta-commons-dbcp is needed by package eclipse-platform
Error: Missing Dependency: jakarta-commons-collections is needed by package eclipse-platform
Error: Missing Dependency: junit4 is needed by package eclipse-jdt
Error: Missing Dependency: regexp is needed by package eclipse-platform
Error: Missing Dependency: jakarta-commons-el >= 1.0 is needed by package tomcat5-common-lib
Error: Missing Dependency: ant-apache-regexp is needed by package eclipse-platform
Error: Missing Dependency: jakarta-commons-dbcp-tomcat5 >= 1.2.1 is needed by package tomcat5-common-lib
Error: Missing Dependency: ant-junit is needed by package eclipse-platform
Error: Missing Dependency: jakarta-commons-digester is needed by package eclipse-platform
Error: Missing Dependency: jakarta-commons-pool is needed by package eclipse-platform
Error: Missing Dependency: ant-trax is needed by package eclipse-platform
Error: Missing Dependency: mx4j >= 2.1 is needed by package eclipse-platform
Error: Missing Dependency: lucene >= 1.9.1 is needed by package eclipse-platform
Error: Missing Dependency: jakarta-commons-pool-tomcat5 is needed by package tomcat5
Error: Missing Dependency: ant-jsch is needed by package eclipse-platform
Error: Missing Dependency: junit >= 3.8.1-3jpp is needed by package eclipse-jdt
Error: Missing Dependency: ant-apache-log4j is needed by package eclipse-platform
Error: Missing Dependency: jakarta-commons-beanutils is needed by package eclipse-platform
Error: Missing Dependency: jakarta-commons-daemon >= 1.0.1 is needed by package tomcat5
Error: Missing Dependency: ant-nodeps is needed by package eclipse-platform
Error: Missing Dependency: jakarta-commons-el >= 1.0-8jpp is needed by package eclipse-platform
Error: Missing Dependency: ant-apache-bcel is needed by package eclipse-platform
Error: Missing Dependency: ant-apache-oro is needed by package eclipse-platform
Error: Missing Dependency: jakarta-commons-modeler is needed by package eclipse-platform
[[email protected] ~]#


Kako postaviti da se automatski povuku sve dependencies i instalira eclipse bez manuelnog (i frustrirajuiceg) resolve-ovanja dependencies i instalacije?
Hvala!
 
Odgovor na temu

combuster
Ivan Bulatovic
Kraljevo

Član broj: 151351
Poruke: 4563
93.86.111.*

Sajt: www.linuxsrbija.org


+104 Profil

icon Re: instalacija eclipse na fc829.11.2009. u 18:18 - pre 132 meseci
Pa ili repo nije update-ovan totalno pa da pokusas malo kasnije ili je to jos jedan problem sa dep resolvingom na rpm based distroima.
make love - !war
 
Odgovor na temu

Body Bag
/dev/null

Član broj: 82460
Poruke: 565
93.87.222.*



+4 Profil

icon Re: instalacija eclipse na fc829.11.2009. u 18:23 - pre 132 meseci
Nisam siguran bas ali mislim da je svako izdanje Fedore podrzano kroz update godinu dana-dakle kada izadje Fedora 10(ciklus izbacivanja je 6 meseci)automatski prestaje podrska za release u ovom slucaju 8-mice,mada bi repoi trebali da budu dostupni sa poslednjim(tada)aktuelnim updateovima i softverom
Sve u svemu kucaj yum update kao root i sacekaj da svuce sve i osvezi listu repozitorijuma(imas aktivnu internet konekciju zar ne ;))
Kada zavrsi to probaj onda da instaliras eclipse
Ako nece nista od ovoga,predji lepo na neku noviju verziju Fedore-verzija 12 je izasla pre par nedelje,a ta 8mica koju koristis ti je ioanko dosta matora....

Power of simplicity - http://www.archlinux.org



 
Odgovor na temu

combuster
Ivan Bulatovic
Kraljevo

Član broj: 151351
Poruke: 4563
93.86.111.*

Sajt: www.linuxsrbija.org


+104 Profil

icon Re: instalacija eclipse na fc829.11.2009. u 18:30 - pre 132 meseci
U pravu si ali bi ipak trebalo da dep-ovi u repo-ima ostanu resolve-ovani kako treba iako je support prosao. A to za update repo-a propada kao teorija jer se taj repo kako si rekao nije dirao jos od vremena kada je 10-tka izasla.

U svakom slucaju upgrade (ako je moguc) je preporucljiv...
make love - !war
 
Odgovor na temu

Alexe
Beograd

Član broj: 172465
Poruke: 37
*.adsl.eunet.rs.



Profil

icon Re: instalacija eclipse na fc829.11.2009. u 18:33 - pre 132 meseci
Hm..."yum update" mi daje nove missing dependencies:
Error: Missing Dependency: libsgutils.so.1 is needed by package libgpod
Error: Missing Dependency: python-sexy is needed by package codeina
Error: Missing Dependency: pygpgme is needed by package yum
Error: Missing Dependency: device-mapper-devel >= 1.02.02-3 is needed by package e2fsprogs-devel
Error: Missing Dependency: dnsmasq is needed by package NetworkManager

Probao sam i "rpm --rebuilddb" pa onda ponovo "yum update" i isto... Posto sam pocetnik na linux-u zanima me da li se i prelazak na FC10 moze instalirati kroz "yum" i sta ce biti sa softverom koji vec imam na FC8 (npr imam neki sofverski ruter, za koji ne znam kako ce se ponasati na FC10).
 
Odgovor na temu

combuster
Ivan Bulatovic
Kraljevo

Član broj: 151351
Poruke: 4563
93.86.111.*

Sajt: www.linuxsrbija.org


+104 Profil

icon Re: instalacija eclipse na fc829.11.2009. u 18:38 - pre 132 meseci
Sve zavisi, ako imas neki custom software koji je iskompajliran sa nesto starijim paketima moguce je da nece raditi, ako je u pitanju neka custom skripta onda bi trebalo sve da radi (eventualno se mozda promeni neka putanja u samoj skripti ali sumnjam).

Inace takav upgrade sa 8-mice na 12-ticu preko yum-a ne bih preporucio, najbolje je da odradis clean install. Ako se brines kako ce ti se ponasati taj software mozda bi trebao da probas 12-ticu prvo u virtualnoj masini (instaliraj virtualbox iz repo-a ako ga vec nemas).
make love - !war
 
Odgovor na temu

Alexe
Beograd

Član broj: 172465
Poruke: 37
*.adsl.eunet.rs.



Profil

icon Re: instalacija eclipse na fc829.11.2009. u 19:06 - pre 132 meseci
Citat:
combuster: Sve zavisi, ako imas neki custom software koji je iskompajliran sa nesto starijim paketima moguce je da nece raditi, ako je u pitanju neka custom skripta onda bi trebalo sve da radi (eventualno se mozda promeni neka putanja u samoj skripti ali sumnjam).

Inace takav upgrade sa 8-mice na 12-ticu preko yum-a ne bih preporucio, najbolje je da odradis clean install. Ako se brines kako ce ti se ponasati taj software mozda bi trebao da probas 12-ticu prvo u virtualnoj masini (instaliraj virtualbox iz repo-a ako ga vec nemas).


Da li to znaci da mogu uraditi upgrade sa 8 na 12 pomocu "clean install" pa onda "yum ..." ili ...? Sto se tice softvera, pogledacu release notes, trebalo bi da postoji za svaku distrib. ali ga svejedno moram ponovo kompajlirati na novoj verziji FC, zar ne?
 
Odgovor na temu

Body Bag
/dev/null

Član broj: 82460
Poruke: 565
93.87.222.*



+4 Profil

icon Re: instalacija eclipse na fc829.11.2009. u 19:23 - pre 132 meseci
Probaj yum clean all,zatim yum clean metadata pa yum clean dbcache pa onda odradi yum update
Ako nece ni posle toga,instaliraj lepo neku noviju Fedoru jer je moguce s obzirom da je to izdanje matoro da neki paketi fale sa servera tj mirrora
Power of simplicity - http://www.archlinux.org



 
Odgovor na temu

combuster
Ivan Bulatovic
Kraljevo

Član broj: 151351
Poruke: 4563
93.86.111.*

Sajt: www.linuxsrbija.org


+104 Profil

icon Re: instalacija eclipse na fc829.11.2009. u 19:25 - pre 132 meseci
Ti mozes da upgrade-ujes sa 8 na 12 preko yum-a ili da odradis clean install sa 12-ticom sto ti preporucujem. Kazem ti zeznuto je kompajliranje matorog software-a na novijoj verziji jer je mozda doslo do nekih bump-ova (biblioteka neka se spojila sa drugom, promenila mesto izbacila neku funkciju kao deprecated)... Ako ti je mnogo bitan taj software probaj u virtualnoj masini prvo...
make love - !war
 
Odgovor na temu

Alexe
Beograd

Član broj: 172465
Poruke: 37
*.adsl.eunet.rs.



Profil

icon Re: instalacija eclipse na fc829.11.2009. u 19:45 - pre 132 meseci
Da,da ...shvatam. Pokusao sam i clean all,zatim yum clean metadata pa yum clean dbcache i yum update i opet isto... Pa mogu da zakljucim da sam prakticno u problemu ako zelim da instaliram neki softver (u ovom slucaju eclipse), na staroj verziji Fedore i ako hocu to da uradim sto jednostavnije (pomocu yum-a). Hvala u svakom slucaju!
 
Odgovor na temu

combuster
Ivan Bulatovic
Kraljevo

Član broj: 151351
Poruke: 4563
93.86.111.*

Sajt: www.linuxsrbija.org


+104 Profil

icon Re: instalacija eclipse na fc829.11.2009. u 19:50 - pre 132 meseci
Mislio sam na clean install ne kao komandu nego da skines instalacioni dvd od fedore 12 i da je instaliras odatle a ne da upgrade-ujes sa yum-om sa 8-mice na 12-ticu.
make love - !war
 
Odgovor na temu

Body Bag
/dev/null

Član broj: 82460
Poruke: 565
93.87.222.*



+4 Profil

icon Re: instalacija eclipse na fc829.11.2009. u 21:01 - pre 132 meseci
Nisam sasvim siguran ali mislim da je neka prethodna verzija Fedore imala neki bug oko osvezavanja repoa,ima naravno i workaround ali davno je bilo pa se ne secam dal je to bas verzija 8 bila,ali mislim da nije vredno tog cimanja
Uostalom Eclipse mozes da instaliras i na verziji 12-imas ga u repou isto ;)
Power of simplicity - http://www.archlinux.org



 
Odgovor na temu

[es] :: Linux :: instalacija eclipse na fc8

[ Pregleda: 2426 | Odgovora: 11 ] > FB > Twit

Postavi temu Odgovori

Navigacija
Lista poslednjih: 16, 32, 64, 128 poruka.