Navigacija
Lista poslednjih: 16, 32, 64, 128 poruka.

Kratka pocetnicka pitanja

[es] :: Linux :: Kratka pocetnicka pitanja

Strane: 1 2 3 4 5

[ Pregleda: 12977 | Odgovora: 86 ] > FB > Twit

Postavi temu Odgovori

Autor

Pretraga teme: Traži
Markiranje Štampanje RSS

CoyoteKG

Član broj: 70939
Poruke: 2757



+6813 Profil

icon Kratka pocetnicka pitanja17.08.2015. u 20:15 - pre 60 meseci
Posto cu verovatno da imam 1000 bas pocetnickih pitanja, mozda bolje da bude ovako neka generalna tema, koja moze posluziti jos nekom pocetniku.

Nisam se nikada susretao sa linux-om, mada sam vise puta nameravao.

Instalirao sam Debian Jessie 64 bit. Jessie jer je to savet mog kolege, da cu da se napatim u startu dok sve namestim, ali da je to jedini nacin da naucim.

Juce mi skoro sve glatko islo (ne racunajuci dinamicke particije i problem sa dve graficke), danas evo, sad sedoh i zakucah prvo kod instalacije team viewer-a, a sada i skype.

Upravo na netu nadjoh nesto vezano za skype, pa se nadam da nije bas potpuna istina :)
Citat:
Skype is not supported in Debian. This is why it is not contained in any of the repos (you were wondering, weren't you?).
The Debian Wiki page about Skype strongly encourages you to use one of the FOSS alternatives, like ekiga.
The same page, however, also contains some info on how to install skype on Debian systems. It even contains the following lines about your specific problem.



Pokusao sam po ovom uputstvu, koristeci ove komande:
Code:
sudo dpkg --add-architecture i386
sudo aptitude update
sudo aptitude install libc6:i386 libqt4-dbus:i386 libqt4-network:i386 libqt4-xml:i386 libqtcore4:i386 libqtgui4:i386 libqtwebkit4:i386 libstdc++6:i386 libx11-6:i386 libxext6:i386 libxss1:i386 libxv1:i386 libssl1.0.0:i386 libpulse0:i386 libasound2-plugins:i386
wget -O skype-install.deb http://www.skype.com/go/getskype-linux-deb
sudo dpkg -i skype-install.deb


I nista nisam uradio. Ovo je output tih komandi

Code:

[email protected]:/# dpkg --add-architecture i386

[email protected]:/# aptitude update
E: The method driver /usr/lib/apt/methods/https could not be found.

[email protected]:/# sudo aptitude install libc6:i386 libqt4-dbus:i386 libqt4-network:i386 libqt4-xml:i386 libqtcore4:i386 libqtgui4:i386 libqtwebkit4:i386 libstdc++6:i386 libx11-6:i386 libxext6:i386 libxss1:i386 libxv1:i386 libssl1.0.0:i386 libpulse0:i386 libasound2-plugins:i386
No candidate version found for libc6:i386
Couldn't find any package whose name or description matched "libqt4-dbus:i386"
Couldn't find any package whose name or description matched "libqt4-network:i386"
Couldn't find any package whose name or description matched "libqt4-xml:i386"
Couldn't find any package whose name or description matched "libqtcore4:i386"
Couldn't find any package whose name or description matched "libqtgui4:i386"
Couldn't find any package whose name or description matched "libqtwebkit4:i386"
Couldn't find any package whose name or description matched "libstdc++6:i386"
Couldn't find any package whose name or description matched "libx11-6:i386"
Couldn't find any package whose name or description matched "libxext6:i386"
Couldn't find any package whose name or description matched "libxss1:i386"
Couldn't find any package whose name or description matched "libxv1:i386"
Couldn't find any package whose name or description matched "libssl1.0.0:i386"
Couldn't find any package whose name or description matched "libpulse0:i386"
Couldn't find any package whose name or description matched "libasound2-plugins:i386"
No candidate version found for libc6:i386
Couldn't find any package whose name or description matched "libqt4-dbus:i386"
Couldn't find any package whose name or description matched "libqt4-network:i386"
Couldn't find any package whose name or description matched "libqt4-xml:i386"
Couldn't find any package whose name or description matched "libqtcore4:i386"
Couldn't find any package whose name or description matched "libqtgui4:i386"
Couldn't find any package whose name or description matched "libqtwebkit4:i386"
Couldn't find any package whose name or description matched "libstdc++6:i386"
Couldn't find any package whose name or description matched "libx11-6:i386"
Couldn't find any package whose name or description matched "libxext6:i386"
Couldn't find any package whose name or description matched "libxss1:i386"
Couldn't find any package whose name or description matched "libxv1:i386"
Couldn't find any package whose name or description matched "libssl1.0.0:i386"
Couldn't find any package whose name or description matched "libpulse0:i386"
Couldn't find any package whose name or description matched "libasound2-plugins:i386"
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B of archives. After unpacking 0 B will be used.
                                         
[email protected]:/# wget -O skype-install.deb http://www.skype.com/go/getskype-linux-deb
--2015-08-17 20:33:05--  http://www.skype.com/go/getskype-linux-deb
Resolving www.skype.com (www.skype.com)... 157.56.114.105
Connecting to www.skype.com (www.skype.com)|157.56.114.105|:80... connected.
HTTP request sent, awaiting response... 302 Found
Location: http://www.skype.com/go/getskype-linux-deb-32 [following]
--2015-08-17 20:33:05--  http://www.skype.com/go/getskype-linux-deb-32
Reusing existing connection to www.skype.com:80.
HTTP request sent, awaiting response... 302 Found
Location: http://download.skype.com/linux/skype-debian_4.3.0.37-1_i386.deb [following]
--2015-08-17 20:33:05--  http://download.skype.com/linux/skype-debian_4.3.0.37-1_i386.deb
Resolving download.skype.com (download.skype.com)... 72.247.178.82, 72.247.178.74
Connecting to download.skype.com (download.skype.com)|72.247.178.82|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 20118938 (19M) [application/octet-stream]
Saving to: ‘skype-install.deb’

skype-install.deb   100%[=====================>]  19.19M   619KB/s   in 27s    

2015-08-17 20:33:32 (740 KB/s) - ‘skype-install.deb’ saved [20118938/20118938]

[email protected]:/# dpkg -i skype-install.deb
Selecting previously unselected package skype.
(Reading database ... 109708 files and directories currently installed.)
Preparing to unpack skype-install.deb ...
Unpacking skype (4.3.0.37-1) ...
dpkg: dependency problems prevent configuration of skype:
 skype depends on libc6 (>= 2.3.6-6~).
 skype depends on libc6 (>= 2.7).
 skype depends on libgcc1 (>= 1:4.1.1).
 skype depends on libqt4-dbus (>= 4:4.5.3).
 skype depends on libqt4-network (>= 4:4.8.0).
 skype depends on libqt4-xml (>= 4:4.5.3).
 skype depends on libqtcore4 (>= 4:4.7.0~beta1).
 skype depends on libqtgui4 (>= 4:4.8.0).
 skype depends on libqtwebkit4 (>= 2.1.0~2011week13).
 skype depends on libstdc++6 (>= 4.2.1).
 skype depends on libx11-6.
 skype depends on libxext6.
 skype depends on libxss1.
 skype depends on libxv1.
 skype depends on libssl1.0.0.
 skype depends on libpulse0.
 skype depends on libasound2-plugins.

dpkg: error processing package skype (--install):
 dependency problems - leaving unconfigured
Processing triggers for dbus (1.8.18-0+deb8u1) ...
Processing triggers for mime-support (3.58) ...
Processing triggers for hicolor-icon-theme (0.13-1) ...
Errors were encountered while processing:
 skype


gde gresim :)
 
Odgovor na temu

CoyoteKG

Član broj: 70939
Poruke: 2757



+6813 Profil

icon Re: Kratka pocetnicka pitanja17.08.2015. u 20:22 - pre 60 meseci
Ako skinem .deb fajl sa Skype sajta, koji je u stvari za Debian 7, dvoklikom ga pokrenem, dobijam ovu gresku

Citat:
Error: This package is uninstallable
Dependency is not satisfiable: libc6 (>= 2.3.6-6~)
 
Odgovor na temu

bachi
Vladimir Vučićević
System administrator
Beograd, Srbija

Član broj: 17912
Poruke: 4969

Sajt: www.bachi.in.rs


+2732 Profil

icon Re: Kratka pocetnicka pitanja17.08.2015. u 20:29 - pre 60 meseci
Dobro došao u dependency hell. :D

Ja sam svoj problem na Xubuntu rešio tako što sam pokrenuo skype instalaciju, ona prsla ko tvoja i onda u terminalu otkucao ovo: sudo apt-get -f install

I onda posle ponovo instalacija Skype i radi!

E da, idi na skype.com i idi na download skype, izaberi debian 7.0 multiarch i taj instaliraj, pa onda sudo apt-get -f install i ponovo install..

Ako ne uspe, skini verziju za Ubuntu 12.04, ta meni radi super na Xubuntu-u 15.04.

... Vladimir Vučićević aka. Bachi
~~~ www.bachi.in.rs <<<<>>>> [email protected]
>>> It's nice to be important, but it's more important to be nice...
 
Odgovor na temu

CoyoteKG

Član broj: 70939
Poruke: 2757



+6813 Profil

icon Re: Kratka pocetnicka pitanja17.08.2015. u 20:32 - pre 60 meseci
Probao sam i to, ali zapucava kod iste stvari :)
 
Odgovor na temu

bachi
Vladimir Vučićević
System administrator
Beograd, Srbija

Član broj: 17912
Poruke: 4969

Sajt: www.bachi.in.rs


+2732 Profil

icon Re: Kratka pocetnicka pitanja17.08.2015. u 20:37 - pre 60 meseci
Pazi, sve mora kao sudo mudo. :D


Dakle, ja sam skinuo sa www.skype.com ubuntu 12.04 multiarch i sačuvao u Downloads

Onda sam otvorio terminal i kucao
sudo dpkg --add-architecture i386
sudo apt-get update

i posle toga
sudo dpkg -i /home/username/Download/naziv_skype_paketa.deb

Kukao mi za library,

pokrenuo:

sudo apt-get -f install

On i reko da li hoću toliko libraryja, ja otišao na yes, sačekao da završi i zatim ponovo pokrenuo

sudo dpkg -i /home/username/Download/naziv_skype_paketa.deb

I posle toga proradio Skype ko zmaj. :D
... Vladimir Vučićević aka. Bachi
~~~ www.bachi.in.rs <<<<>>>> [email protected]
>>> It's nice to be important, but it's more important to be nice...
 
Odgovor na temu

CoyoteKG

Član broj: 70939
Poruke: 2757



+6813 Profil

icon Re: Kratka pocetnicka pitanja17.08.2015. u 20:43 - pre 60 meseci
aha, kapirao sam kada radim kao root, da ne moram "sudo".

Evo sada pokusao da instaliram i teamviewer bas na taj nacin kao ti, i zabadam na istim library problemima.


Code:
[email protected]:/home/ceman/Downloads# dpkg -i teamviewer_10.0.41499_amd64.deb
Selecting previously unselected package teamviewer.
(Reading database ... 109602 files and directories currently installed.)
Preparing to unpack teamviewer_10.0.41499_amd64.deb ...
Unpacking teamviewer (10.0.41499) ...
dpkg: dependency problems prevent configuration of teamviewer:
 teamviewer depends on libc6-i386 (>= 2.4); however:
  Package libc6-i386 is not installed.
 teamviewer depends on lib32asound2; however:
  Package lib32asound2 is not installed.
 teamviewer depends on lib32z1; however:
  Package lib32z1 is not installed.
 teamviewer depends on ia32-libs; however:
  Package ia32-libs is not installed.

dpkg: error processing package teamviewer (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 teamviewer
 
Odgovor na temu

CoyoteKG

Član broj: 70939
Poruke: 2757



+6813 Profil

icon Re: Kratka pocetnicka pitanja17.08.2015. u 20:52 - pre 60 meseci
Bar sam uspeo brackets da instaliram, i tu mi falila libgcrypt11_1.5.4-3 biblioteka :)

Sad se secam zasto jos uvek nisam naucio nista na linuxu, par puta pokusavao sa njim, i zabadao na nekim osnovnim stvarima, i brzo se smorio, i zagrlio windows...
Ali sad sam samom sebi doskocio, tako da sad nema Windows-a :)
 
Odgovor na temu

bachi
Vladimir Vučićević
System administrator
Beograd, Srbija

Član broj: 17912
Poruke: 4969

Sajt: www.bachi.in.rs


+2732 Profil

icon Re: Kratka pocetnicka pitanja17.08.2015. u 20:54 - pre 60 meseci
Onda bolje da si stavio Ubuntu...

Ajde ovako:

sudo apt-get install libavcodec-extra
sudo apt-get install gstreamer0.10-plugins-ugly gstreamer0.10-plugins-bad gstreamer0.10-fluendo-mp3 gstreamer0.10-pulseaudio
sudo apt-get install libgstreamer-perl libgstreamer-interfaces-perl

I onda probaj Skype.

Evo, ja skinuo .deb od TeamViewera sa njihovog sajta, klinuo dva puta na to i instalirao se sam kroz ubuntu sofware centar.

Očigledno da Xubuntu dolazi sa preinstaliranim bibliotekama koje fale na DeBilanu. :D
... Vladimir Vučićević aka. Bachi
~~~ www.bachi.in.rs <<<<>>>> [email protected]
>>> It's nice to be important, but it's more important to be nice...
 
Odgovor na temu

CoyoteKG

Član broj: 70939
Poruke: 2757



+6813 Profil

icon Re: Kratka pocetnicka pitanja17.08.2015. u 20:58 - pre 60 meseci
izguglao sam da 64bitne verzije prave problem, bas skajp i teamviewer.

Kolega mi savetovao jessie debian, kaze, tako cu da naucim :D.
Izgleda me sjajno iz-troll-ovao :D

sad cu da probam i to


nisam hteo nista drugo osim debiana, jer imam da cackam dva hetzner servera koja su na debianu. Pa rekoh, ajd da bude nesto slicno :)
 
Odgovor na temu

calexx
Slavoljub Bralović
Niš

SuperModerator
Član broj: 71794
Poruke: 19144
*.149.89.0



+1243 Profil

icon Re: Kratka pocetnicka pitanja17.08.2015. u 21:10 - pre 60 meseci
Bolje da na pišem šta mislim o Debianu, već će neko da se javi. Ja na Arčiju to instaliram kratkim kucanjem
Code:
yaourt -S skype
ili
Code:
yaourt -S teamviewer
i sve što je potrebno bude odrađeno. Kakvo pešačenje, sad ću da tražim šta mu je sve potrebno i šta nema. ;) A može i preko gui ko tako više voli.

Hm, mislim da na kompu imam jedan Debian pa me sad kopka da vidim kakve ću da budem sreće sa instalacijom. ;)

Inače ono
Code:
sudo apt-get -f install
će da opravi napuklu ;) instalaciju i to ne bi trebalo da je redovna procedura. Obično se koristi kad nešto instaliraš i iz bilo kog razloga ne prođe ... kada sledeći put hoćeš nešto slično, pojaviće se poruka da odradiš baš ovako.
 
Odgovor na temu

CoyoteKG

Član broj: 70939
Poruke: 2757



+6813 Profil

icon Re: Kratka pocetnicka pitanja17.08.2015. u 21:13 - pre 60 meseci
da, inace ovaj moj kolega jeste arci zaludjenik :)

I meni sada kad nailazim na ove probleme, govori, "arch to ovako, arch to lagano" :)


Koja ti je verzija Debiana? Nemoj neku full, nego Jessie :). i to 64bit
 
Odgovor na temu

Homer J. Simpson
Zombilend

Član broj: 307921
Poruke: 688



+923 Profil

icon Re: Kratka pocetnicka pitanja17.08.2015. u 21:23 - pre 60 meseci
Ne znam sta ce vam za Skype i sl. uopste konzola , ja tu zalazim samo kad ili treba nesto brze a obimnije da se odradi (kao i u PowerShell) ili kad budzim neke config fajlove ali to je jako retko. Danas Linux (Ubuntu , Mint i sl.) mogu normalno da se koriste bez konzole.
 
Odgovor na temu

calexx
Slavoljub Bralović
Niš

SuperModerator
Član broj: 71794
Poruke: 19144
*.149.89.0



+1243 Profil

icon Re: Kratka pocetnicka pitanja17.08.2015. u 21:27 - pre 60 meseci
Citat:
CoyoteKG:  Koja ti je verzija Debiana? Nemoj neku full, nego Jessie :). i to 64bit
A šta je to full verzija a šta Jessie? ;) Nemam pojma, neka koja se pojavila pre nekoliko meseci a kod Debiana me ne zanimaju oznake, znam da imaju čudan pristup tome. Ajde sad ću da odem do tog kompa da probam.
 
Odgovor na temu

CoyoteKG

Član broj: 70939
Poruke: 2757



+6813 Profil

icon Re: Kratka pocetnicka pitanja17.08.2015. u 21:29 - pre 60 meseci
Jessie kako sam skapirao, je neki najmanji paket. ISO je bio samo 200MB.

Pokusao sam i prostim dvoklikom na .deb fajl, pa nije uspela instalacija nicega od ovog...


Instalirao bih Arch rado, ali ovamo na ovim serverima se vrti Debian, pa ne bih da od pocetka se navikavam na neke druge komande. Eto ta yaourt ili pacman... umesto apt-get i sl... Nemam ni predstavu kolika je razlika u tim osnovnim komandama.
 
Odgovor na temu

Homer J. Simpson
Zombilend

Član broj: 307921
Poruke: 688



+923 Profil

icon Re: Kratka pocetnicka pitanja17.08.2015. u 21:34 - pre 60 meseci
To je minimal/net ISO , zaebo te kolega za medalju
Skini neki od ovih http://cdimage.debian.org/debian-cd/8.1.0-live/amd64/iso-hybrid/
 
Odgovor na temu

CoyoteKG

Član broj: 70939
Poruke: 2757



+6813 Profil

icon Re: Kratka pocetnicka pitanja17.08.2015. u 21:49 - pre 60 meseci
Kolega se najavio da dodje kod mene za vikend, ohladicu pivo, pa da instaliramo ispocetka ponovo nesto.
Mozda bude taj hvaljeni Arch :).

Nadam se samo da komande nisu preterano drugacije od Debian-a, a i ako jesu, kad naucim sta mogu, lako cu da izguglam koja je prava komanda za Debian :)
 
Odgovor na temu

Homer J. Simpson
Zombilend

Član broj: 307921
Poruke: 688



+923 Profil

icon Re: Kratka pocetnicka pitanja17.08.2015. u 21:52 - pre 60 meseci
Moj ti je savet da stavis nesto polu-upotrebljivo/upotrebljivo i onda cackas.
Pa kad tako naucis osnove onda se glupiraj sa minimal instalacijama , kompajliranjem i ostalim ludilom.
Mene su isto savetovali da odma' krenem from scratch i sl. i to mi nista dobro nije donelo , nista vise nisam naucio nego ovako.
 
Odgovor na temu

bachi
Vladimir Vučićević
System administrator
Beograd, Srbija

Član broj: 17912
Poruke: 4969

Sajt: www.bachi.in.rs


+2732 Profil

icon Re: Kratka pocetnicka pitanja17.08.2015. u 21:53 - pre 60 meseci
Au bre Coyote, pa taj Linux od 200MB nema ništa...

Kolega ti je u sado/mazo fazonu. Stavi neku "početničku" distribuciju i koristi Linux ko normalan čovek, kasnije se bakći sa konzolama, kobajama i slično, ali prvo savladaj grafičko okruženje kao user.

Mora neki red da postoji inače ćeš se smoriš i batališ sve.

Ti si ladno stavio ovo: https://www.debian.org/distrib/netinst :D :D :D
... Vladimir Vučićević aka. Bachi
~~~ www.bachi.in.rs <<<<>>>> [email protected]
>>> It's nice to be important, but it's more important to be nice...
 
Odgovor na temu

CoyoteKG

Član broj: 70939
Poruke: 2757



+6813 Profil

icon Re: Kratka pocetnicka pitanja17.08.2015. u 22:02 - pre 60 meseci
E to :D

Fora je sto na sajtu postoje 4 DVDa na koje staje ceo Debian.
Kao, neka osnovna varijanta je valjda 1 DVD, i to sam skinuo.

Na kraju ovako instalirao taj net install od nekih 200MB :)


Ambiciozno? :)
 
Odgovor na temu

Homer J. Simpson
Zombilend

Član broj: 307921
Poruke: 688



+923 Profil

icon Re: Kratka pocetnicka pitanja17.08.2015. u 22:09 - pre 60 meseci
To na 3-4 DVD-a je Debian sa svim repo-ima offline ...
To ti ne treba (kao ni ta verzija od 200MB) vec skini neki od onih Live sto sam okacio
 
Odgovor na temu

[es] :: Linux :: Kratka pocetnicka pitanja

Strane: 1 2 3 4 5

[ Pregleda: 12977 | Odgovora: 86 ] > FB > Twit

Postavi temu Odgovori

Navigacija
Lista poslednjih: 16, 32, 64, 128 poruka.