Navigacija
Lista poslednjih: 16, 32, 64, 128 poruka.

bgp protokol izmedu ripng i ripv2 u packet tracer

[es] :: Enterprise Networking :: bgp protokol izmedu ripng i ripv2 u packet tracer

Strane: 1 2

[ Pregleda: 5908 | Odgovora: 38 ] > FB > Twit

Postavi temu Odgovori

Autor

Pretraga teme: Traži
Markiranje Štampanje RSS

tomislav91

Član broj: 206601
Poruke: 308
*.dynamic.isp.telekom.rs.



+1 Profil

icon bgp protokol izmedu ripng i ripv2 u packet tracer01.07.2014. u 00:06 - pre 74 meseci
Dakle, ono sto ja zelim, jeste da napravim dva autonomna sistema, jedan koji ce raditi sa IPv6 i RIPng, dok drugi sa IPv4 i RIPv2 protokolom, i to da kombinujem sa bgp protokolom.
Zanima me, kada napravim te dve mreze posebno u jedan zadatak, kako dalje, sta raditi, da li bgp za sve rutere, ili samo (ako sam povezao tako) 2 rutera(1 iz jednog, drugi iz drugog sistema) odraditi sa bgp ili sve?
I kako odraditi bgp rutiranje kada je odradjen rip(ng ili v2)? I kako da stavim autonomne sisteme, to mi bas nije jasno? Kako da dobijem te brojeve, ili to sam izmisljam.?

Uploadovao sam jednu mrezu gde je odradjen RIPng i IPv6, lako se doda jos sa IPv4, samo me zanima ovo oko bgp.

life is the one,take care of them!

http://hardware-software.serbianforum.info/
Prikačeni fajlovi
 
Odgovor na temu

B3R1
Berislav Todorovic
NL

Član broj: 224915
Poruke: 366



+185 Profil

icon Re: bgp protokol izmedu ripng i ripv2 u packet tracer02.07.2014. u 10:59 - pre 74 meseci
Ako sam dobro shvatio: u jednoj mrezi imas samo IPv6, u drugoj imas samo IPv4. To je ok. Ali ti sada zelis da te dve mreze nateras da govore jedna s drugom. E pa nece moci ...
Osim protokola rutiranja moraces da resis i prevodjenje jednih adresa na druge, jednim od desetak tranzicionih mehanizama kojih ima - DS-Lite, NAT64, 6to4, 6over4, A+P ...

Sta je uopste ideja zadatka? I mozes li da tu sliku uploadujes u jpg/png formatu, nemamo svi Packet Tracer na svakom laptopu, tabletu, telefonu ... :-)
 
Odgovor na temu

tomislav91

Član broj: 206601
Poruke: 308
*.dynamic.isp.telekom.rs.



+1 Profil

icon Re: bgp protokol izmedu ripng i ripv2 u packet tracer02.07.2014. u 23:36 - pre 74 meseci
Mozda nisam dovoljno jasno napisao.
Dual-stack IPv4+IPv6 mreža koja se sastoji od dva autonomna sistema i povezana BGP protokolom (EGP). Unutar autonomnog sistema jednostavniji protokol, kao što je RIPv2 za IPv4 i RIPng za IPv6.
Ili tako, ili
IPv6 mreža sagrađena od dva autonomna sistema i povezana BGP protokolom. Unutar autonomnih sistema unutrašnji protokol OSPFv3.

Samo me taj BGP brine, gledao sam neke tutorijale i cini se zeznuto.
Samo adresiranje IPv6 i OSPF nije jednostavno toliko, s obzirom da i nisam imao bas nekih dodira sa time..


life is the one,take care of them!

http://hardware-software.serbianforum.info/
 
Odgovor na temu

B3R1
Berislav Todorovic
NL

Član broj: 224915
Poruke: 366



+185 Profil

icon Re: bgp protokol izmedu ripng i ripv2 u packet tracer03.07.2014. u 15:05 - pre 74 meseci
Sada je malo jasnije. Evo ti neko opste uputstvo, ali moraces ipak da proucis te tutorijale.

Pretpostavimo da imas dva AS - jedan ti je AS100, drugi ti je AS200 (AS brojeve za potrebe igranja biras sam, kao i IP adrese).

Unutar AS100 koristis adrese iz opsega 10.100.0.0/16 i 2001:db8:100::/48
Unutar AS200 koristis adrese iz opsega 10.200.0.0/16 i 2001:db8:200::/48

Na granici AS100-AS200 mozes da dodelis /30 (odnosno /64) iz jednog od ta dva bloka - nebitno. Npr. - 10.100.1.0/30, odnosno 2001:db8:100:1::/64

Koju god opciju da odaberes BGP ces morati da konfigurises na ruterima koji povezuju AS100 i AS200. To su ti "granicari" - tzv. ASBR (Autonomous System Border Router).
ASBR ruteri unutar AS100 oglasice ka svojim susednim ASBR u AS200 sumarnu rutu 10.100.0.0/16, odnosno 2001:db8:100::/48
ASBR ruteri unutar AS200 oglasice ka svojim susednim ASBR u AS100 sumarnu rutu 10.200.0.0/16, odnosno 2001:db8:200::/48
Ova oglasavanja najjednostavnije je uraditi redistribucijom staticke rute /16 i /48 u BGP.

Oglasavanje IPv4 i IPv6 adresa mozes da uradis bilo koriscenjem zajednicke BGP sesije ili dve posebne BGP sesije (jednu za IPv4, drugu za IPv6 adrese).
U praksi ljudi vise vole ovu drugu opciju - cistija je i omogucava laksi debugging kada naidju problemi.


ASBR @ AS100 ASBR @ AS200
10.100.1.1/30 <---------------> 10.100.1.2/30
2001:db8:100:1::1/64 <---------------> 2001:db8:100:1::2/64

! - ASBR @ AS100
router bgp 100
neighbor 10.100.1.2 remote-as 200
neighbor 10.100.1.2 version 4
neighbor 2001:db8:100:1::2 remote-as 200
neighbor 2001:db8:100:1::2 version 4
!
address-family ipv4
no sync
no auto-summary
network 10.100.0.0 mask 255.255.0.0
neighbor 10.100.1.2 activate
neighbor 10.100.1.2 prefix-list AS100-IPv4 out
exit-address-family
!
address-family ipv6
no sync
no auto-summary
network 2001:db8:100::/48
neighbor 2001:db8:100:1::2 activate
neighbor 2001:db8:100:1::2 prefix-list AS100-IPv6 out
exit-address-family
!
ip route 10.100.0.0 255.255.0.0 Null0
ipv6 route 2001:db8:100::/48 Null0
!
ip prefix-list AS100-IPv4 permit 10.100.0.0/16
ipv6 prefix-list AS100-IPv6 permit 2001:db8:100::/48


Slicno konfigurises i AS200, samo zamenis brojeve u gornjem primeru. :-)

Nadalje imas dve opcije:

Prva opcija je karakteristicna za ISP okruzenje. BGP se koristi na svim ruterima u oba autonomna sistema (IBGP izmedju rutera unutar AS, EBGP za komunikaciju izmedju AS100 i AS200). Sve ostale rute koje se koriste unutar jednog AS (direktno povezane interfejs-rute, staticke rute itd.) se redistribuiraju u BGP, dok se samo loopback adrese rutera redistribuiraju u IGP (OSPF, RIP, IS-IS itd.). Na svim ruterima se u BGP konfiguraciji koristi "next-hop self" opcija kojom ruter pre oglasavanja ruta BGP-om postavlja njihov next-hop na sopstvenu loopback adresu. Tako ce ruteri unutar AS100 dobijati informaciju o drugim rutama unutar AS100 (npr. 10.100.1.0/24, 10.100.20.24/29 itd.) BGP-om, dok se IGP-om dobijaju samo loopback rute (npr. 10.100.0.1/32, 10.100.0.2/32 itd.). Ruteri unutar AS100 ce takodje imati sumarnu rutu 10.200.0.0/16 iz AS200. Oglasavanje malih specificnijih ruta unutar blokova 10.100.0.0/16 i 10.200.0.0/16 od AS100 ka AS200 i obrnuto se sprecava access listom.

Druga opcija se obicno koristi u korporativnim mrezama, gde se rute unutar AS redistribuiraju u IGP, dok se BGP koristi samo na tzv. ASBR - ruterima koji sluze za komunikaciju s drugim mrezama. Redistribucije izmedju IGP i BGP obicno nema, mada je moguca i takva konfiguracija.

Za pocetak ...
 
Odgovor na temu

tomislav91

Član broj: 206601
Poruke: 308
77.243.16.*



+1 Profil

icon Re: bgp protokol izmedu ripng i ripv2 u packet tracer03.07.2014. u 18:11 - pre 74 meseci
Hvala na mnogo na veoma opsirnom i korisnom odgovoru.
Posto sam pocetnik, ovo mi je sve nekako cudno, i pomalo tesko, ali mislim da se moze savladati. Sustina je, kako sam ja shvatio u IBGP i EBGP, uglavnom nema neke razlike sem sto je remote-as razliciti naravno, jer ako radimo u jednom AS, nije isto nego kada radimo komunikaciju izmedju dva AS.

Cim dobijem konkretan zadatak sa mrezama i svime ostalim, postavicu, a sam cu uraditi bar adresiranje, posto bih najverovatnije pokusao ovu drugu opciju, tj IPV6 sa 2 AS, a unutar AS-ova se koristi OSPFv3.

Pa u vezi BGP ako ne budem razumeo najbolje, postavicu ovde, pa se nadam da ces umeti malo da mi pomognes, kao i ostali clanovi.
life is the one,take care of them!

http://hardware-software.serbianforum.info/
 
Odgovor na temu

tomislav91

Član broj: 206601
Poruke: 308
109.122.107.*



+1 Profil

icon Re: bgp protokol izmedu ripng i ripv2 u packet tracer06.07.2014. u 21:31 - pre 74 meseci

Taj zadatak treba da odradim, Plavim oznacene veze su OSPF, narandzastim iBGP, a crvenim eBGP.
Za pocetak odmah sam zapeo kada sam trebao da odredim broj korisnika, odnosno subnetovanje, kod swithcewa, gde:
Switch 12: 2000
Switch 13: 4000
Switch 14: 2500
Switch 15: 1000

Switch 12=2000 korisnika, itd.
Da li moze mreza ta mreza da bude ako je adresni prostor ipv6 u tom prvom AS-u
ipv6 infrastructure 2001:1b38::/32
ipv6 end-users 2a00:7f00::/32
Zanima me, sta onda koristim, kako dodajem te adrese korisnicima, da li sami ti racunari idu pod mrezom sto pise ipv6 end users, ali kako onda ide to da switch 12 ima 2000 korisnika, gde to da da kazem tako "napisem"? I moze li 2001:1b38::5/43 da bude za taj prvi pc, ali opet ne znam kako to da odredjujem, kada lepo kaze da su to end useri, onda iz te mreze ide, ali kako de to da nadjem switch 12 da 2000 treba, da to ogranicim?



[Ovu poruku je menjao tomislav91 dana 06.07.2014. u 23:38 GMT+1]

[Ovu poruku je menjao pajaja dana 07.07.2014. u 19:56 GMT+1]
life is the one,take care of them!

http://hardware-software.serbianforum.info/
 
Odgovor na temu

zeenmc
Nedeljko Scepanovic
Beograd City

Član broj: 54186
Poruke: 419
*.dynamic.isp.telekom.rs.



+22 Profil

icon Re: bgp protokol izmedu ripng i ripv2 u packet tracer07.07.2014. u 23:45 - pre 74 meseci
Uh brale, pocinjem na vise razlicitih nacin ovo da pisem ali nikako mi neide, bas mi zapelo oko IPv6, zasto, pa kad koristis BGP i IPv6, u tom slucaju ces morati da koristis mBGP, dalje, u IPv6 ne mozes priblizno ograniciti adresni prostor kao u IPv4 npr na 62 host adrese+ broadcast i network, to zaboravi x:)

Ako se ne varam za IPv4 da bi se dobila mreza koja bi zadovoljila 2000 korisnika to bi trebalo da bude 192.1680.0/21, sto daje 2046 host adresa, i jednu broadcast i jednu network adresu, ovako ne funkcionise za ipv6, to zaboravi :)

Ja mislim da bi tebi trebalo prefix /64, ali nisam siguran xD

Inace takodje mislim da ti je ovo bas komplikovan zadatak, barem za pocetnika, ja sam tipa OSPF fino savladao, ali me zato glava boli od BGP-a, prosto treba vremena da se stvari smire xD ::)

[Ovu poruku je menjao zeenmc dana 08.07.2014. u 23:08 GMT+1]
CCNP Security, CCNA R&S, CCNA Security, CCNA Voice
LinuxIsFree
 
Odgovor na temu

tomislav91

Član broj: 206601
Poruke: 308
109.122.107.*



+1 Profil

icon Re: bgp protokol izmedu ripng i ripv2 u packet tracer08.07.2014. u 11:23 - pre 73 meseci
Ako napravim 4 podrmreze /32, dobijem /34, i ako u konfiguraciji rutera prema tom pc pisem tu mrezu ali kroz /48 eui-64 i u pc ukucam ipv6config autoconfig komandu, on mi dodeli
::/0 adresu, zasto to?

life is the one,take care of them!

http://hardware-software.serbianforum.info/
 
Odgovor na temu

B3R1
Berislav Todorovic
NL

Član broj: 224915
Poruke: 366



+185 Profil

icon Re: bgp protokol izmedu ripng i ripv2 u packet tracer08.07.2014. u 11:28 - pre 73 meseci
IPv6 ti je mnogo prostiji za subnetovanje jer je minimalan standardan subnet /64. Teorijski, /65-/127 ce takodje lepo da radi, ali to se u praksi ne preporucuje. Ako te zanima zasto pogledaj RRC5375 i RFC6177. U okviru jednog /64 mozes da smestis 2^64-2 hostova, a to je, priznaces, prilicno velika cifra. :-) Ako tih 2000 korisnika smestas u jedan subnet dovoljan ti je 1x /64. Medjutim, ako ti se mreza vise grana, imas vise subnetova, VLAN-ova itd. trebace ti po jedan /64 za svaki subnet. S druge strane, /48 koji su ranije preporucivali kao univerzalan prefis za krajnje mreze, je ipak preveliki. Neki kompromis je /56, on ti daje do 256x /64, odnosno 256 subnetova.

Znaci, u tvom konkretnom slucaju, ako imas strogo "ravnu" organizaciju mreze sa po jednim subnetom za svaki switch ja bih rekao: svakom switchu za krajnej korisnike dodeli po jedan /64. :-)

Medjutim, imaj u vidu da definicija "end usera" moze da bude i nesto drugacija - npr. moze da podrazumeva da se radi o rezidencijalnim (broadband) korisnicima gde se svakom korisniku dodeljuje po jedan subnet. U tom slucaju umesto PC-eva se na swtichevima verovatno mogu da ocekuju mali broadband ruteri ili nesto slicno, a onda dodeljujes po jedan /64 po end useru. Tu bi ti za 2000 end usera trebalo 2000x /64 = 8x /56 = /53. Ali posto imas na raspolaganju vec /32 mozes komotno da stavis i po jedan /48 po svakom switchu. Sve zavisi kako je zadatak napisan, ali ovo sto si ti nacrtao podrazumeva da je 1 end user == 1 PC. :-)

Dodela IPv6 adresa krajnjim hostovima moze da se odradi na tri nacina: staticki, SLAC ili DHCPv6.

U zadatku su ti data dva adresna bloka: jedan za infrastrukturu, drugi za krajnje korisnike. PC-eve krajnjih korisnika adresiras iz tog drugog bloka (2a00:7f00::/32). Ovaj prvi blok (2001:1b38::/32) ti sluzi za infrastrukturu - veze izmedju switcheva i rutera. Svakom linku, bilo da je point-to-point ili DMZ, dodeljujes po jedan /64 iz tog infrastrukturnog bloka, npr:

R13 - S12 - 2001:1b38:13:1::/64 (R13 ce imati adresu 2001:1b38:13:1::1/64, S12 ce dobiti: 2001:1b38:13:1::2/64 - uobicajena praksa je da se za infrastrukturu koristi staticko adresiranje)
R13 - S13 - 2001:1b38:13:2::/64
R14 - S12 - 2001:1b38:14:1::/64
R14 - S13 - 2001:1b38:14:2::/64
itd.
 
Odgovor na temu

tomislav91

Član broj: 206601
Poruke: 308
109.122.107.*



+1 Profil

icon Re: bgp protokol izmedu ripng i ripv2 u packet tracer08.07.2014. u 11:49 - pre 73 meseci
Da, ali ja sam recimo dobio 4 podmreze od /32 -> /34
2a00:7f00:0000::/34
2a00:7f00:4000::/34
2a00:7f00:8000::/34
2a00:7f00:c000::/34

I to koristim ka end user-ima, kako onda ako koristim eui-64 adresiranje rutera, koju adresu dobija taj prvi ruter prema tom prvom PC?
jer ustvari ove 4 podmreze koristim u ovim 4 end userima(3 pc i 1 server), ako sam ja dobro razumeo taj deo o pravljenju podmreza?

kako onda da stavim da je /64 a da koristim eui64 odnosno da mi sam dodeli adresu?

Da sumiram, mozda je nejasno.

Imam taj adresni prostor ka end userima, podelio sam u podmreze, i dobio 4 (iznad napisane), Veza ka R13-S12, tu je problem, sta da kucam, razumem da treba /64, jer ako budem kucao eui64, i onda ako udjem u cmd u pc i ukucam ipv6config autoconfig da mi ispise adresu /64. dakle taj deo mi nije jasan, vi ste ovde napisali da koristim ovaj drugi adresni prostor, prema infrastrukturi, ali kako onda da odredim end usere, a da koristim to eui64
life is the one,take care of them!

http://hardware-software.serbianforum.info/
 
Odgovor na temu

B3R1
Berislav Todorovic
NL

Član broj: 224915
Poruke: 366



+185 Profil

icon Re: bgp protokol izmedu ripng i ripv2 u packet tracer08.07.2014. u 12:46 - pre 73 meseci
2a00:7f00::/32 se koristi za end usere - na interfejsima koji povezuju PC-eve na switcheve.
2001:1b38::/32 se koristi za infrastrukturu - na interfejsima koji povezuju switcheve (S12-S15) sa ruterima (R13-R16). To su razliciti interrfejsi, zar ne?
Nego, mene nesto drugo zbunjuje ovde: da li se na switchevima koristi po jedan odvojeni /64 za svaki PC? Ili su svi portovi switcha u jednom VLAN-u, a za sve PC-eve se koristi jedan /34?

Kada su switchevi u pitanju stvar moze da se odradi na dva nacina: da se svaki port switcha podesi da bude Layer-3 (rutirani), sto je, ako se na portove povezuje po jedan PC, neefikasno da se radi. Ili se svi portovi stave u jedan VLAN, a rutiranje na switch-u ide preko SVI (Vlan-interface). Ovo sve pod pretpostavkom da se na switchevima radi rutiranje, tj. da je ukljucen L3 switching. Ako se za svaki PC koristi poseban /64, ako sw na switchu podesi:

interface GigabitEthernet x/1
description Veza ka PC-1
ipv6 address 2a00:7f00:0:1::/64 eui-64
!
interface GigabitEthernet x/2
description Veza ka PC-2
ipv6 address 2a00:7f00:0:2:/64 eui-64

switch ce izracunati niza 64 bita te adrese u zavisnosti od MAC adrese svog interfejsa. Na primer, ako su MAC adrese portova 001a.302a.9c40 i 001a.302a.9c41 EUI-64 ce biti: 2001:7F00:0:1:21A:30FF:FE2A:9C40/64 (port x/1), odnosno 2001:7F00:0:2:21A:30FF:FE2A:9C41/64 (port 2) itd. Kada se PC zakaci, ako je na njemu podesen SLAAC tada ce PC izracunati sopstvenu MAC adresu na slican nacin.

U ovom drugom slucaju podesavas slicno, samo sto konfiguracija switcha izgleda malcice drugacije:

interface GigabitEhternet 1/1
description PC-1
switchport access vlan 100
!
interface GigabitEhternet 1/2
description PC-2
switchport access vlan 100
...
interface Vlan 100
description Rutiranje za VLAN 100
ipv6 enable
ipv6 address 2a00:7f00::/34 eui-64

Tada ce svi PC-evi imati isti prefix-length (/34), a svaki za sebe ce racunati svoju EUI-64 adresu.

Na linkovima ka infrastrukturi (veze izmedju switcheva i rutera) nemoj da koristis EUI-64, osim ako neces da se zaista upustis u tezu glavobolju. Takvi linkovi se rade po pravilu staticki.

 
Odgovor na temu

tomislav91

Član broj: 206601
Poruke: 308
109.122.107.*



+1 Profil

icon Re: bgp protokol izmedu ripng i ripv2 u packet tracer08.07.2014. u 12:56 - pre 73 meseci
Da, da, pa u vezi onoga sto ste pitali, ne znam da vam odgovorim posto nisam dobio takve podatke. Ali mislim da ide sve na 1 vlan, cim mi nije drugacije receno.

mene isto jedno buni, one 4 podmreze koje sam dobio, zar ne bi to trebalo da se iskoristi kod end usera, ondosno ova 4 sto imam, da koriste te 4 subnet, odnosno svaki end user da uzme po jednu tu podmrezu?

Da li imate packet tracer?

Problem je sto negde ne moze da se ukljuci ipv6 unicast-routing, ili na nekim to odradi, ali kada kucam ipv6 address i upisem adresu izbaci mi gresku, invalid, kao da nije omoguceno i to samo na nekim interfejsima.

Evo fajla

Code:
http://speedy.sh/GR8kM/dipl.pkt




[Ovu poruku je menjao tomislav91 dana 08.07.2014. u 14:33 GMT+1]
life is the one,take care of them!

http://hardware-software.serbianforum.info/
 
Odgovor na temu

B3R1
Berislav Todorovic
NL

Član broj: 224915
Poruke: 366



+185 Profil

icon Re: bgp protokol izmedu ripng i ripv2 u packet tracer08.07.2014. u 14:50 - pre 73 meseci
Obicno se koristi jedan VLAN za sve + Vlan interface (SVI) za rutiranje.

Sto se tice toga sta koriste end useri to je trebalo da se definise u zadataku. Da li se podrazumeva da 1 end user koristi 1 IPv6 adresu ili vise (npr. 1 end user = 1x /64)? Sta je end user? Jedan PC? Jedan cable modem / DSL ruter? Nesto trece? To ujedno daje i odgovor na pitanje.

Packet Tracer nemam, moguce je da je neki bug u toj verziji i da neke komande ne rade. To bi mogao bolje da odgovori neko ko je radio s tim.

Imas li tacnu formulaciju zadatka, odnosno tekst? Ovako mi sve izgleda u stilu moz' da bine, al' ne mora da znaci ...
 
Odgovor na temu

tomislav91

Član broj: 206601
Poruke: 308
109.122.107.*



+1 Profil

icon Re: bgp protokol izmedu ripng i ripv2 u packet tracer08.07.2014. u 15:56 - pre 73 meseci
Nemojte koristiti local link adrese.
Objasnjenja uz crtez koji je u prilogu:
ipv6 infrastructure adresni prostori su namenjeni vezama izmedju rutera.
Plavim oznacene veze su OSPF, narandzastim iBGP, a crvenim eBGP.
Adresni prostor:
AS64600
ipv6 infrastructure 2001:1b38::/32
ipv6 end-users 2a00:7f00::/32
Broj korisnika
Switch 12: 2000
Switch 13: 4000
Switch 14: 2500
Switch 15: 1000

AS65200
ipv6 infrastructure 2001:4c28::/32
ipv6 end-users 2a01:6aa0::/32
Broj korisnika
Switch 21: 2000
Switch 22: 2000
Switch 23: 5000
Switch 24: 5000


To je ceo tekst.
Evo i neke napomene

Podmreze za korisnike pravite od end-users prostora, a podmreze koje povezuju medjusobno rutere pravite od infrastructure adresnog prostora. Kod ipv6 jedan end-user je /64. 64 bita se koristi za interface ID.

I pokusao sam da upisem te mreze sto si mi napisao tamo, i uspelo je za rutere, ali tamo a switch sto si rekao, nijedna nece da se odradi, tj ipv6 uopste ne funkcionise, tj izbaci kao unrecognize. Kada pristupim interfejsu, ove komande samo mogu da se upisu:
cdp Global CDP configuration subcommands
channel-group Etherchannel/port bundling configuration
channel-protocol Select the channel protocol (LACP, PAgP)
description Interface specific description
duplex Configure duplex operation.
exit Exit from interface configuration mode
mac-address Manually set interface MAC address
mls mls interface commands
no Negate a command or set its defaults
shutdown Shutdown the selected interface
spanning-tree Spanning Tree Subsystem
speed Configure speed operation.
storm-control storm configuration
switchport Set switching mode characteristics
tx-ring-limit Configure PA level transmit ring limit

Ne mogu tu adrese da dodeljujem, kao sto si mi bio napisao tamo ranije

I sto se tice ovog dela
Citat:
R13 - S12 - 2001:1b38:13:1::/64 (R13 ce imati adresu 2001:1b38:13:1::1/64, S12 ce dobiti: 2001:1b38:13:1::2/64 - uobicajena praksa je da se za infrastrukturu koristi staticko adresiranje)
R13 - S13 - 2001:1b38:13:2::/64
R14 - S12 - 2001:1b38:14:1::/64
R14 - S13 - 2001:1b38:14:2::/64


Naravno ruterima sam uspeo adrese da dodelim, npr R13-2001:1b38:13:1::1/64, ali kako ce tu switch da dobije adresu ::2? I posto ne mogu da dodelim switch portu prema racunaru ipv6, ne mogu da odradim ni da pc dobije adresu .


[Ovu poruku je menjao tomislav91 dana 08.07.2014. u 19:43 GMT+1]

[Ovu poruku je menjao tomislav91 dana 08.07.2014. u 20:00 GMT+1]
life is the one,take care of them!

http://hardware-software.serbianforum.info/
 
Odgovor na temu

B3R1
Berislav Todorovic
NL

Član broj: 224915
Poruke: 366



+185 Profil

icon Re: bgp protokol izmedu ripng i ripv2 u packet tracer08.07.2014. u 19:28 - pre 73 meseci
Hvala puno, sada je sve jasnije, samo treba pazljivije citati tekst.
Citat:
Kod ipv6 jedan end-user je /64. 64 bita se koristi za interface ID.

Ja to tumacim ovako: svaki korisnik (end-user) dobija po jedan zaseban /64, sto je tipican slucaj u ISP mrezama. Korisnici se povezuju na switcheve (12-15, 21-24). Teorijski moguce je svakome od njih dodeliti poseban prefiks, pri cemu bi se ::1 usvojio kao adresa switcha, a ostatak bi bio na raspolaganju korisniku - npr:

! - Switch12
interface GigabitEthernet 1/125
descriptoin End-user #125
ipv6 address 2a00:7f00:0000:01fd::1/64
!
interface GigabitEthernet 1/126
descriptoin End-user #125
ipv6 address 2a00:7f00:0000:01fe::1/64
...

Korisnik na svojoj strani moze da konfigurise svoj ruter/pc/sta-vec bilo koristeci SLAAC (autoconfig), bilo staticki (npr. uzme ::2, ::3 itd.). Koliko vidim u zadatku nije nista pomenuto vezano za SLAAC/EUI-64. Takodje, imaj u vidu da kada koristis EUI-64 nema smisla koristiti subnet veci od /64, jer EUI-64 modifikuje samo donja 64 bita, a gornja 64 ne dira. Zato se i zove EUI-64. :-) Tako da ako konfigurises npr. ip address 2a00:7f00::/34 eui-64 bitovi 35-64 ce ti uvek biti 0, a bitovi 65-128 ce se menjati. Samim tim si bacio ogroman prostor adresa.

Na interfejsima switcha ka korisnicima aktiviraj RA, kako bi se na strani korisnika automatski instalirala default ruta (::/0). Na Cisco ruterima i switchevima ovo je po defaultu aktivirano, osim ako ga eksplicitno ne iskljucis (supress-ra).

Citat:
I pokusao sam da upisem te mreze sto si mi napisao tamo, i uspelo je za rutere, ali tamo a switch sto si rekao, nijedna nece da se odradi,

Hmmm ... da nisi zaboravio ipv6 unicast-routing (u globalnoj konfiguraciji switcha) ??? Mada, rekao si da si to negde ukljucio, a negde nece da prihvati. Cudno ...

Vezano za ovo gore, smatraj taj zadatak cisto skolskom vezbom. U praksi se kod tako velikog broja korisnickih mreza dodela adresa vrsi automatski najcesce nekim RADIUS serverom, a korisnici se terminiraju na centralnom broadband gateway-u. Tu se koristi PPPoE. Primer kako se to radi imas ovde. Ali to je vec za mnogo napredniji kurs. :-)

Adresne opsege si podelio dobro - svaki switch dobija po jedan /34 blok. Mada, ja bih pre uzeo po jedan /48, a ostatak adresa cuvao za prosirenja mreze, ali to je vec samo detalj. Moze i /34.

Ostaje da konfigurises OSPF(v3). Za to ti je najbolje da na svakom switchu definises /34 blokove kao sumarne rute (summary-address) i oglasis ih OSPF-om ka upstream ruterima, kako bi se izbeglo oglasavanje pojedinacnih /64 ruta ka ruterima. Na ruterima povezanim narandzastim linijama konfigurises i BGP. Najlakse je da oba /32 bloka definises kao staticke rute ka Null0 interfejsu i redistribuiras ih u iBGP.

Za veze izmedju switcheva i rutera (S12-R13 itd.) koristi infrastrukturni adresni prostor. Kao sto sam rekao, svakom linku dodelis po jedan /64. Taj deo je laksi. I tu nemoj da koristis SLAAC, vec na jednoj strani link stavi ::1, na drugoj ::2. Zamalo da zaboravim - obavezno rezervisi i opseg adresa za loopback interfejse switcheva i rutera - npr. 2001:1b38:0::/48 za rutere i 2001:1b38:1;:/48 za switcheve, pa onda iz tih opsega dodelis loopbacke po principu 2001:1b38:0::13/128 (ruter 13), 2001:1b38:0::14/128 (ruter 14), 2001:1b38:1::12/128 (switch 12) itd. Loopback interfejsi dobijaju /128. Njih koristis i kao router-id za OSPF i BGP.

I za kraj, na dijagramu se potkrala jedna greska: izmedju rutera 21 i 23 u AS65200 ti takodje treba jedna IBGP sesija. IBGP mora da se konfigurise izmedju svaka dva rutera unutar jednog AS (full mesh) ili da konfigurises route reflektore, ali to drugo ti nije potrebno.

Ja bih inace to uradio totalno drugacije da mogu da biram routing protokole. OSPF bih koristio samo za loopback interfejse switcheva i rutera, a sve ostale rute bih redistribuirao u BGP. Time bih dobio po desetak ruta u OSPF tabeli + point-to-point linkove, sve ostalo bi islo u BGP. Plus next-hop self u BGP. Tako se to inace radi u ISP mrezama Medjutim, zadatak je nazalost drugacije postavljen i to ne mozemo da promenimo ...

[Ovu poruku je menjao B3R1 dana 08.07.2014. u 20:56 GMT+1]
 
Odgovor na temu

B3R1
Berislav Todorovic
NL

Član broj: 224915
Poruke: 366



+185 Profil

icon Re: bgp protokol izmedu ripng i ripv2 u packet tracer08.07.2014. u 20:05 - pre 73 meseci
Nasao sam ove linkove, mozda ce da ti pomognu:

http://www.cisco.com/c/en/us/t...ion/guide/scg_2960/swipv6.html
https://www.nanog.org/meetings...S_Practical_ipv6_61309_N46.pdf

Meni je u oci upalo ovo:

sdm prefer dual-ipv4-and-ipv6 default
(reload iza toga)

Mada mi nije jasno da li je to potrebno uraditi i na simulatoru ili samo na realnom switchu ...
 
Odgovor na temu

tomislav91

Član broj: 206601
Poruke: 308
109.122.107.*



+1 Profil

icon Re: bgp protokol izmedu ripng i ripv2 u packet tracer08.07.2014. u 21:04 - pre 73 meseci
Zaista mnogo cenim vas trud da mi sto bolje pojasnite. Ja sam u simulatoru, ovako obavio povezivanja, nadam se da su OK, s obzirom da ni za to nisam dobio uputstva.




A evo i slike pokusaja ukljucivanja ipv6 na switch



Citat:
Korisnik na svojoj strani moze da konfigurise svoj ruter/pc/sta-vec bilo koristeci SLAAC (autoconfig), bilo staticki (npr. uzme ::2, ::3 itd.). Koliko vidim u zadatku nije nista pomenuto vezano za SLAAC/EUI-64. Takodje, imaj u vidu da kada koristis EUI-64 nema smisla koristiti subnet veci od /64, jer EUI-64 modifikuje samo donja 64 bita, a gornja 64 ne dira. Zato se i zove EUI-64. :-) Tako da ako konfigurises npr. ip address 2a00:7f00::/34 eui-64 bitovi 35-64 ce ti uvek biti 0, a bitovi 65-128 ce se menjati. Samim tim si bacio ogroman prostor adresa.


ovaj deo sto ste napisali, adresu 2a00:7f00::/34 eui-64 bih kucam u switchu, weza prema pc? Da bi preko autoconfig kucao u cmd u PC, da bi mi dodelio IP, ili ne?


OSPF nisam jos razmisljao, jer nisam jos dodelio obicne adrese ove, pa posle toga cu i pisati ako ne budem razumeo OSPF, ali ima nekih tutorijala, pa cu pokusati to da resim.


A sta je sa switchom 10 i 11 koji su vezani na rutere 11 i 12 , a oba ta na ruter 10. Koje adrese tu dodeljujem?


life is the one,take care of them!

http://hardware-software.serbianforum.info/
 
Odgovor na temu

B3R1
Berislav Todorovic
NL

Član broj: 224915
Poruke: 366



+185 Profil

icon Re: bgp protokol izmedu ripng i ripv2 u packet tracer08.07.2014. u 21:44 - pre 73 meseci
Packet Tracer je samo simulator. Moguce je da IOS za 2960 ne podrzava IPv6. Pokusaj ovu "sdm ..." komandu. Ako ne pomogne, verovatno nije podrzana u tom simulatoru. Treba probati i sa nekim drugim tipom switcha - npr. 3560?
Citat:
ovaj deo sto ste napisali, adresu 2a00:7f00::/34 eui-64 bih kucam u switchu, weza prema pc? Da bi preko autoconfig kucao u cmd u PC, da bi mi dodelio IP, ili ne?

Ne, switch ima svoju staticki dodeljnu adresu - 2a00:7f00::1/64, tako da na njemu ne treba raditi autokonfiguraciju, vec samo na PC-u. Autokonfiguracija se odvija lokalno na uredjaju na kome se aktivira.
Citat:
A sta je sa switchom 10 i 11 koji su vezani na rutere 11 i 12 , a oba ta na ruter 10. Koje adrese tu dodeljujem?

Oni su deo infrastrukture, prema tome ...
 
Odgovor na temu

tomislav91

Član broj: 206601
Poruke: 308
109.122.107.*



+1 Profil

icon Re: bgp protokol izmedu ripng i ripv2 u packet tracer08.07.2014. u 22:23 - pre 73 meseci
3560-24ps, na njemu sam uspeo to da uradim...ipv6 unicast-routing prodje, ali kada krenem ipv6 address, to ne moze..

Mozete li mi samo ovako sumirati te adresne prostore.
Ovaj deo sam shvatio

Citat:
R13 - S12 - 2001:1b38:13:1::/64 (R13 ce imati adresu 2001:1b38:13:1::1/64, S12 ce dobiti: 2001:1b38:13:1::2/64 - uobicajena praksa je da se za infrastrukturu koristi staticko adresiranje)
R13 - S13 - 2001:1b38:13:2::/64
R14 - S12 - 2001:1b38:14:1::/64
R14 - S13 - 2001:1b38:14:2::/64




[Ovu poruku je menjao tomislav91 dana 08.07.2014. u 23:35 GMT+1]
life is the one,take care of them!

http://hardware-software.serbianforum.info/
 
Odgovor na temu

B3R1
Berislav Todorovic
NL

Član broj: 224915
Poruke: 366



+185 Profil

icon Re: bgp protokol izmedu ripng i ripv2 u packet tracer09.07.2014. u 09:37 - pre 73 meseci
Na C4948 i C4900M "ipv6 address" prolazi, ali potrebna je jos jedna dodatna komanda, verujem da ce pomoci i za C3560:

interface TenGigabitEthernet3/3
no switchport
no ip address
ipv6 address 2001:DB8::1/64
Citat:
Mozete li mi samo ovako sumirati te adresne prostore.

R13 - S12 - 2001:1b38:13:1::/64 (R13 => 2001:1b38:13:1::1/64, S12 => 2001:1b38:13:1::2/64)
R13 - S13 - 2001:1b38:13:2::/64
R14 - S12 - 2001:1b38:14:1::/64
R14 - S13 - 2001:1b38:14:2::/64
R15 - S14 - 2001:1b38:15:1::/64
R15 - S15 - 2001:1b38:15:2::/64
... (kako dalje? Malo maste i kreativnog razmisljanja nije naodmet ...)

R10 - R20 - 2001:1b38:FFFF::/64 <<< Ovde moze da se uzme adresa iz jednog ILI drugog AS, nema znacaja!
...

R10 Loopback: 2001:1b38:0:10::1/128
R11 Loopback: 2001:1b38:0:11::1/128
S11 Loopback: 2001:1b38:1:11::1/128
R12 Loopback: 2001:1b38:0:12::1/128
S12 Loopback: 2001:1b38:1:12::1/128
...

Ovo je samo primer, dodela je zaista prozivoljna. Neko drugi bi jednostavno krenuo sekvencijalno od nule pa dokle stigne, moze i tako i to je savrseno ok:

2001:1b38:1:0::/64
2001:1b38:1:2::/64
2001:1b38:1:3::/64
...

Jos jedna praksa koju sam vidjao je da uklope IPv4 i IPv6 adrese. Na primer, ako na interfejsu dodeli 192.0.2.5/30, IPv6 adresa za point-to-point link ce biti: 2001:1b38:c000:0204::1/64 i ::2/64 itd. Ili odbaci gornji bajt IPv4 adrese i kaze prosto: 2001:1b38:0:2::5/64 i 2001:1b38:0:2::6/64 itd. Posto IPv6 adresa ima u izobilju ljudi ih razbacuju.
 
Odgovor na temu

[es] :: Enterprise Networking :: bgp protokol izmedu ripng i ripv2 u packet tracer

Strane: 1 2

[ Pregleda: 5908 | Odgovora: 38 ] > FB > Twit

Postavi temu Odgovori

Navigacija
Lista poslednjih: 16, 32, 64, 128 poruka.