Navigacija
Lista poslednjih: 16, 32, 64, 128 poruka.

Podesavanje Mt-a da salje mail

[es] :: Wireless :: Mikrotik :: Podesavanje Mt-a da salje mail

Strane: 1 2

[ Pregleda: 5473 | Odgovora: 27 ] > FB > Twit

Postavi temu Odgovori

Autor

Pretraga teme: Traži
Markiranje Štampanje RSS

MilosOskar
MilosOskar
Student
Beograd

Član broj: 272010
Poruke: 269
*.dynamic.isp.telekom.rs.



+5 Profil

icon Podesavanje Mt-a da salje mail27.11.2011. u 23:06 - pre 120 meseci
Do skoro sam koristio mail server od ortaka ciji server vise nije u funkciji. Samim tim Mikrotik mi vise ne salje mailove. Pokusavao sam da podesim da salje preko hotmail-a ili gmail-a ali mrka kapa, nece pa nece...

Inace, imam dinamicku IP pa mi je ovde neko sa foruma ES poslao skriptu za slanje maila cim se promeni IP, jer imam potrebu da nekad pristupam MT sa udaljene lokacije, pa samim tim mi je i bitna ta javna ip...

Ako neko moze da pomogne, znacilo bi mi.
Preporucite neki drugi mail server koji funkcionise ili mozda imate parametre za navedene (hotmail i gmail) koji rade pa pisite ovde...

Pozdrav!
 
Odgovor na temu

Predrag Supurovic
Pedja YT9TP
Užice

Član broj: 157129
Poruke: 6074

Sajt: pedja.supurovic.net


+1470 Profil

icon Re: Podesavanje Mt-a da salje mail28.11.2011. u 07:21 - pre 120 meseci
Na gmail ne možeš slati direktno je Mikrotik ne podržava SSL. Što ne koristiš SMTP svog provajdera?

 
Odgovor na temu

mckrsta
Nenad Krstic
System Engineer
AT&T Slovakia
Bratislava

Član broj: 44532
Poruke: 219
*.dynamic.isp.telekom.rs.

Sajt: www.bor030.net


+6 Profil

icon Re: Podesavanje Mt-a da salje mail28.11.2011. u 08:43 - pre 120 meseci
mozda da korisits DynDNS... na nekom racunari iza mikrotika... mislim da bi ti posluzio za remote pristup...
 
Odgovor na temu

neca
ERP Consultant
Smederevo

Član broj: 1460
Poruke: 1283

ICQ: 129255214


+92 Profil

icon Re: Podesavanje Mt-a da salje mail28.11.2011. u 09:00 - pre 120 meseci
zasto na računaru iza mikrotika kad može da napravi skriptu za dyndns na samom mikrotiku i da je stavi u scheduler da se izvršava na odredjeno vreme?
ovo dodas u system/scripts
Code:

# Set needed variables
:local username "tvojusername"
:local password "tvojpassword"
:local hostname "hostname koji si registrovao"
:global systemname [/system identity get name]

:if ($systemname  = "Site1" ) do= {
:set hostname "hostname koji si registrovao"
}
:if ($systemname  = "Site2" ) do= {
:set hostname "hostname koji si registrovao"
}
:if ($systemname  = "Site3" ) do= {
:set hostname "hostname koji si registrovao"
}

:global dyndnsForce
:global previousIP

# print some debug info
:log info ("UpdateDynDNS: username = $username")
:log info ("UpdateDynDNS: password = $password")
:log info ("UpdateDynDNS: hostname = $hostname")
:log info ("UpdateDynDNS: previousIP = $previousIP")

# get the current IP address from the internet (in case of double-nat)
/tool fetch mode=http address="checkip.dyndns.org" src-path="/" dst-path="/dyndns.checkip.html"
:local result [/file get dyndns.checkip.html contents]

# parse the current IP result
:local resultLen [:len $result]
:local startLoc [:find $result ": " -1]
:set startLoc ($startLoc + 2)
:local endLoc [:find $result "</body>" -1]
:local currentIP [:pick $result $startLoc $endLoc]
:log info "UpdateDynDNS: currentIP = $currentIP"

# Remove the # on next line to force an update every single time - useful for debugging, but you could end up getting blacklisted by DynDNS!
#:set dyndnsForce true

# Determine if dyndns update is needed
# more dyndns updater request details available at http://www.dyndns.com/developers/specs/syntax.html
:if (($currentIP != $previousIP) || ($dyndnsForce = true)) do={
    :set dyndnsForce false
    :set previousIP $currentIP
    /tool fetch user=$username password=$password mode=http address="members.dyndns.org" src-path="/nic/update?hostname=$hostname&myip=$currentIP" dst-path="/dyndns.txt"
    :local result [/file get dyndns.txt contents]
    :log info ("UpdateDynDNS: Dyndns update needed")
    :log info ("UpdateDynDNS: Dyndns Update Result: ".$result)
    :put ("Dyndns Update Result: ".$result)
} else={
    :log info ("UpdateDynDNS: No dyndns update needed")
}


i napravis u system/scheduler da ti pokreće tu skriptu na svakih recimo 10 minuta.
pozdrav

 
Odgovor na temu

BigFoot
Boban Jovanović
Arilje

Član broj: 1098
Poruke: 991
*.dynamic.sbb.rs.



+35 Profil

icon Re: Podesavanje Mt-a da salje mail28.11.2011. u 10:41 - pre 120 meseci
Ovo je tema o slanju e-maila, a ne o DynDNS-u, o kome je već pisano više puta.

P.S. Pitala učiteljica Pericu da kaže sve što zna o Marku Kraljeviću. Kako nije znao gotovo ništa kaže:
"Marko Kraljević je bio veliki junak, a tek Musa Kesedžija..." i nastavi da priča o Musi...
Two beer or not two beer...
 
Odgovor na temu

NenadS
Nenad Strainovic
Beograd

Član broj: 857
Poruke: 910
*.mediaworksit.net.

Sajt: www.strainovic.com


+7 Profil

icon Re: Podesavanje Mt-a da salje mail28.11.2011. u 10:49 - pre 120 meseci
Jeste ovde rec o slanju email-a ali svrha toga je upravo dobijanje informacije o javnoj IP adresi, tako da ova scripta resava taj problem na mnogo bolji, brzi i elegantniji nacin ;)
Pozdrav, NenadS!
 
Odgovor na temu

neca
ERP Consultant
Smederevo

Član broj: 1460
Poruke: 1283

ICQ: 129255214


+92 Profil

icon Re: Podesavanje Mt-a da salje mail28.11.2011. u 13:36 - pre 120 meseci
pa tom logikom sam se i ja vodio :) aj da kazem nesto iako nema veze sa temom :D tako isto i on :D :D :D
 
Odgovor na temu

mckrsta
Nenad Krstic
System Engineer
AT&T Slovakia
Bratislava

Član broj: 44532
Poruke: 219
*.dynamic.isp.telekom.rs.

Sajt: www.bor030.net


+6 Profil

icon Re: Podesavanje Mt-a da salje mail28.11.2011. u 15:10 - pre 120 meseci
ma ne, nebitno je da pomognes nekome na ovaj ili onaj nacin, ali je mnogo bitno da kazes da je ova tema striktno o tome i tome...
 
Odgovor na temu

BigFoot
Boban Jovanović
Arilje

Član broj: 1098
Poruke: 991
*.dynamic.sbb.rs.



+35 Profil

icon Re: Podesavanje Mt-a da salje mail28.11.2011. u 16:41 - pre 120 meseci
Tako možeš da mu pomažeš telefonom, ili lično, ako je u pitanju cepanje drva. Forum ima temu i treba je se držati.
Citat:
MilosOskar: Preporucite neki drugi mail server koji funkcionise

Funkcioniše npr. mail.ru. SMTP adresa je smtp.mail.ru.

Ovako konfigurišeš e-mail:
Code:
/tool e-mail
set address=94.100.177.1 from="JA <[email protected]>" password=moja_sifra port=25 user=ja

Ovako šalješ e-mail:
Code:
/tool e-mail send to="[email protected]" subject="Ovo je naslov e-maila" body=("Ovo je proba e-maila.")

Sadržaj onoga šta šalješ formiraš sam, taman to bila dinamički dodeljena IP adresa, o kojoj je bilo govora više puta.
Two beer or not two beer...
 
Odgovor na temu

neca
ERP Consultant
Smederevo

Član broj: 1460
Poruke: 1283

ICQ: 129255214


+92 Profil

icon Re: Podesavanje Mt-a da salje mail28.11.2011. u 17:30 - pre 120 meseci
nemoj pogresno da me shvatis, ja sam se salio kada sam pisao drugi post,a sto se tice scripte, mozda decko ne zna,a bitno mu je da ima stalno ip adresu mikrotika i ne zna da postoji laksi nacin (dyndns). ja sam takodje pocetnik i ja mnoge stvari radim na verovatno mnogo tezi nacin i uopste nisam imao nameru da pametujem kad sam dao scriptu vec da pomognem ako je moguce. naravno, jos jednom ja moram da se zahvalim pedji, jer da nije bilo njega i njegovih uputstava ko zna koliko bi se mucio. tako da ako pokretacu znaci moj odgovor neka ga usvoji ako ne javice se neko ko ce pomoci :)
 
Odgovor na temu

Aleksandar Đokić

Član broj: 13478
Poruke: 4793
*.dynamic.isp.telekom.rs.



+638 Profil

icon Re: Podesavanje Mt-a da salje mail28.11.2011. u 18:16 - pre 120 meseci
Milose, zasto mi ne verujes ? :)
 
Odgovor na temu

MilosOskar
MilosOskar
Student
Beograd

Član broj: 272010
Poruke: 269
*.dynamic.isp.telekom.rs.



+5 Profil

icon Re: Podesavanje Mt-a da salje mail28.11.2011. u 19:32 - pre 120 meseci
Postavih temu sinoć i ceo dan nisam stigao da vidim ima li odgovra, sada kada sam stigao kući, imao sam šta i da vidim.
Pre svega hvala što želite da mi pomognete, početnik sam i nemam pojma oko mnogo toga. Čuo sam za dynDNS ali nisam znao čemu služi.

Pa da počnem... :)

@
Citat:
Predrag Supurovic: Na gmail ne možeš slati direktno je Mikrotik ne podržava SSL. Što ne koristiš SMTP svog provajdera?


Iskreno, nisam se toga ni setio. Imam naloge na gmail i hotmail u razbio sam se pokušavajući preko njih i nisam uspeo, to mi je ubilo ostatak volje...

Citat:
mckrsta: mozda da korisits DynDNS... na nekom racunari iza mikrotika... mislim da bi ti posluzio za remote pristup...


dynDNS ne znam ni šta je ni kako se koristi. Sigurno da bi bilo glupo da sad postavim pitanje o dynDNS-u tako da ću večeras pronaći teme o istom i proučiti malo, ako mi negde zapne pitaću nekog od vas.

@Neca: Imam skriptu na Mikrotiku koja se izvršava na svakih 10 min. koja SAMO u slučaju promene javne IP, pošalje mi istu na mail.
Ako ti nije teško, pojasni mi barem čemu ova skripta služi kad si je već postavio, da bih znao. Možda mi može poslužiti za nešto drugo ili je možda bolja od ove moje, pa da je zamenim.

@BigFoot: Hvala za mail server, takođe veliko hvala za detaljno objašnjenje kako podesiti mail na MT.

Citat:
guslac: Milose, zasto mi ne verujes ? :)


Odakle ovo pitanje? Naravno da ti verujem, čini mi se da si mi baš ti i pomogao ovde na forumu oko ove postojeće skripte koju imam za slanje javne IP čim se promeni. :))

E sad ja vama da postavim još jedno pitanje. Sasvim sam zadovoljan vašim odgovorima i hvala vam na dvojenom vremenu koje ste izdvojili da mi pomognete.
Po vama, koje je rešenje "najbolje" za ovo što tražim, dakle da li je to dynDNS ili ovo što već imam (skripta koja mi šalje kada se ip promeni) ?

P.S. Ja znam da je najbolje imati statičku IP, ali za ove moje "uslove" rada posavetujte me šta da uradim...

Veliki pozdrav!
 
Odgovor na temu

Aleksandar Đokić

Član broj: 13478
Poruke: 4793
*.dynamic.isp.telekom.rs.



+638 Profil

icon Re: Podesavanje Mt-a da salje mail28.11.2011. u 20:25 - pre 120 meseci
apsolutno dyndns...
 
Odgovor na temu

MilosOskar
MilosOskar
Student
Beograd

Član broj: 272010
Poruke: 269
*.dynamic.isp.telekom.rs.



+5 Profil

icon Re: Podesavanje Mt-a da salje mail28.11.2011. u 21:07 - pre 120 meseci
Hvala puno.

Sto se dynDNS-a tiče pitaću nekog preko PP.

Pozdrav
 
Odgovor na temu

neca
ERP Consultant
Smederevo

Član broj: 1460
Poruke: 1283

ICQ: 129255214


+92 Profil

icon Re: Podesavanje Mt-a da salje mail28.11.2011. u 22:13 - pre 120 meseci
u tvom slucaju je dyndns servis koji ce tvoje razlicite ip adrese vezivati za jedinstveni hostname. na primer, mozes da odredis hostname mikrotik.dyndns.tv i preko te adrese ces pristupati svom ruteru ma koja ti je javna ip adresa.
potrebno je da odes na dyndns.com, kreiras account i dodas host. u skriptit koju sam iskopirao gore, imas nekoliko polja koja trebas da popunis i to je to. ako treba jos nesto pitaj.
 
Odgovor na temu

Aleksandar Đokić

Član broj: 13478
Poruke: 4793
*.dynamic.isp.telekom.rs.



+638 Profil

icon Re: Podesavanje Mt-a da salje mail28.11.2011. u 22:14 - pre 120 meseci
ja koristim gmx.com dugo vremena, ne za informacije o ip adresi vec na ondown i onup evente, kad neki interfejs postane down ili up, ako vam je bitno vreme za koje ce mail stici do vas onda je najbolje koristiti privatni mail, tj server nekog hosting provajdera
 
Odgovor na temu

MilosOskar
MilosOskar
Student
Beograd

Član broj: 272010
Poruke: 269
*.dynamic.isp.telekom.rs.



+5 Profil

icon Re: Podesavanje Mt-a da salje mail29.11.2011. u 12:48 - pre 120 meseci
Citat:
neca: u tvom slucaju je dyndns servis koji ce tvoje razlicite ip adrese vezivati za jedinstveni hostname. na primer, mozes da odredis hostname mikrotik.dyndns.tv i preko te adrese ces pristupati svom ruteru ma koja ti je javna ip adresa.
potrebno je da odes na dyndns.com, kreiras account i dodas host. u skriptit koju sam iskopirao gore, imas nekoliko polja koja trebas da popunis i to je to. ako treba jos nesto pitaj.


Hvala na pomoći, napravio sam account. Ako stignem, večeras ću pokušati to sve i da završim. Ako zapne negde, pitaću.

 
Odgovor na temu

MilosOskar
MilosOskar
Student
Beograd

Član broj: 272010
Poruke: 269
*.dynamic.isp.telekom.rs.



+5 Profil

icon Re: Podesavanje Mt-a da salje mail01.12.2011. u 13:58 - pre 120 meseci
Nisam stigao da podesim dynDNS, to ću natenane kad uhvatim malo više vremena.

Ali, reših da pokušam kao što Peđa reče, podesio sam smtp i port za Telekom i RADI!! :-)

Hvala svima na nesebično pruženoj pomoći!

Pozz
 
Odgovor na temu

zivanicd
Dejan Zivanic
KLADOVONET ISP
Kladovo

Član broj: 137218
Poruke: 1126
*.CyberCity.KladovoNet.Com.

Sajt: www.kladovo.net


+138 Profil

icon Re: Podesavanje Mt-a da salje mail02.12.2011. u 21:10 - pre 120 meseci
Ajde da ja dodam jos nesto pametno ovde sto ce mozda da vam pomogne...

Kad vec znamo kako se shalje mail ne bi bilo lose da taj mikrotik shalje nesto pametno kao sto je recimo da radi backup i shalje ga mailom svako vece sa svih mikrotikova u slucaju nekog iznenadnog "govanceta".

Evo skripte za bacup export konfiguracije:
:log info "Pocinjemo backup"
:global backupfile ([/system identity get name] . "-" . [/system clock get time])
/export file=$backupfile
:log info "Pauza 10s"
:delay 10s
:log info "Shaljemo Backup"
/tool e-mail send to="[email protected]" subject=([/system identity get name] . \
" Backup") file=$backupfile server=IP_ADRESA_SMTP_SERVERA
:log info "Backup Zavrsen"
:delay 10s
:log info "Brisemo Backup Fajl"
/file remove $backupfile

To je to :)

POz
 
Odgovor na temu

mstevanic
private
Novi Sad

Član broj: 44208
Poruke: 124
*.dynamic.isp.telekom.rs.

Sajt: www.satshop.rs


+1 Profil

icon Re: Podesavanje Mt-a da salje mail25.12.2011. u 17:25 - pre 119 meseci
Ako koristim gmail koja je IP_ADRESA_SMTP_SERVERA ?

Hvala
 
Odgovor na temu

[es] :: Wireless :: Mikrotik :: Podesavanje Mt-a da salje mail

Strane: 1 2

[ Pregleda: 5473 | Odgovora: 27 ] > FB > Twit

Postavi temu Odgovori

Navigacija
Lista poslednjih: 16, 32, 64, 128 poruka.