Navigacija
Lista poslednjih: 16, 32, 64, 128 poruka.

ubuntu server dns problem

[es] :: Linux/UNIX serveri i servisi :: ubuntu server dns problem

[ Pregleda: 925 | Odgovora: 0 ] > FB > Twit

Postavi temu Odgovori

Autor

Pretraga teme: Traži
Markiranje Štampanje RSS

vinko78

Član broj: 250949
Poruke: 23
*.dsl.optinet.hr.



Profil

icon ubuntu server dns problem25.03.2011. u 12:26 - pre 107 meseci
imam dignit ubuntu server sa lusca proxyjem ! e sad sam htjeo dodati jos dns server !trebam pomoc oko postavki!?
moj konf!
mikrotik wan - modem pppoe bridge mode
lan-192.168.10.1/24
wifi-192.168.100.1/24
ubuntu-192.168.3.254/24
link 5 ghz na tik 2
/ip firewall nat
add action=masquerade chain=srcnat comment="MASQUERADE MIKROTIK" disabled=no \
out-interface=Public
add action=dst-nat chain=dstnat comment="TRANSPARENT DNS" disabled=no \
dst-port=53 in-interface=Local protocol=udp to-ports=53
add action=dst-nat chain=dstnat comment="TRANSPARENT DNS" disabled=no \
dst-port=53 in-interface=Local protocol=tcp to-ports=53
add action=dst-nat chain=dstnat comment="DNS UNBOUND" disabled=no \
dst-port=53 in-interface=Local protocol=udp to-addresses=192.168.3.254 \
to-ports=53
add action=dst-nat chain=dstnat comment="DNS UNBOUND" disabled=no \
dst-port=53 in-interface=Local protocol=tcp to-addresses=192.168.3.254 \
to-ports=53
ip dns static zoky.net address-192.168.3.254

proxy radi savresno vec par mjeseci!

unbound.conf

server:
verbosity: 1
statistics-interval: 120
statistics-cumulative: yes
num-threads: 2
interface: 0.0.0.0

outgoing-range: 512
num-queries-per-thread: 1024

msg-cache-size: 64m
rrset-cache-size: 32m

msg-cache-slabs: 4
rrset-cache-slabs: 4

cache-max-ttl: 86400
infra-host-ttl: 60
infra-lame-ttl: 120

infra-cache-numhosts: 10000
infra-cache-lame-size: 10k

do-ip4: yes
do-ip6: no
do-udp: yes
do-tcp: yes
do-daemonize: yes

#access-control: 0.0.0.0/0 allow
access-control: 192.168.0.0/16 allow
access-control: 172.16.0.0/12 allow
access-control: 10.0.0.0/8 allow
access-control: 127.0.0.0/8 allow
access-control: 0.0.0.0/0 refuse

chroot: "/etc/unbound"
username: "unbound"
directory: "/etc/unbound"
#logfile: "/etc/unbound/unbound.log"
#use-syslog: yes
logfile: ""
use-syslog: no
pidfile: "/etc/unbound/unbound.pid"
root-hints: "/etc/unbound/named.cache"

identity: "DNS"
version: "1.4"
hide-identity: yes
hide-version: yes
harden-glue: yes
do-not-query-address: 127.0.0.1/8
do-not-query-localhost: yes
module-config: "iterator"

#zone localhost
local-zone: "localhost." static
local-data: "localhost. 10800 IN NS localhost."
local-data: "localhost. 10800 IN SOA localhost. nobody.invalid. 1 3600 1200 604800 10800"
local-data: "localhost. 10800 IN A 127.0.0.1"

local-zone: "127.in-addr.arpa." static
local-data: "127.in-addr.arpa. 10800 IN NS localhost."
local-data: "127.in-addr.arpa. 10800 IN SOA localhost. nobody.invalid. 2 3600 1200 604800 10800"
local-data: "1.0.0.127.in-addr.arpa. 10800 IN PTR localhost."

#zone zoky.net
local-zone: "zoky.net." static
local-data: "zoky.net. 86400 IN NS ns1.zoky.net."
local-data: "zoky.net. 86400 IN SOA zoky.net. hostmaster.zoky.net. 3 3600 1200 604800 86400"
local-data: "zoky.net. 86400 IN A 192.168.3.254"
local-data: "www.zoky.net. 86400 IN A 192.168.3.254"
local-data: "ns1.zoky.net. 86400 IN A 192.168.3.254"

local-data: "mail.zoky.net. 86400 IN A 192.168.3.254"
local-data: "zoky.net. 86400 IN MX 10 mail.zoky.net."
local-data: "zoky.net. 86400 IN TXT v=spf1 a mx ~all"

local-zone: "3.168.192.in-addr.arpa." static
local-data: "3.168.192.in-addr.arpa. 10800 IN NS zoky.net."
local-data: "3.168.192.in-addr.arpa. 10800 IN SOA zoky.net. hostmaster.zoky.net. 4 3600 1200 604800 864000"
local-data: "254.3.168.192.in-addr.arpa. 10800 IN PTR zoky.net."

forward-zone:
name: "."
forward-addr: 116.254.99.254
forward-addr: 165.21.83.88
forward-addr: 203.34.118.12
forward-addr: 203.34.118.10
forward-addr: 203.142.83.200
forward-addr: 8.8.8.8
forward-addr: 8.8.4.4
forward-addr: 208.67.222.222
forward-addr: 208.67.220.220

remote-control:
control-enable: yes
control-interface: 127.0.0.1
control-port: 953
server-key-file: "/etc/unbound/unbound_server.key"
server-cert-file: "/etc/unbound/unbound_server.pem"
control-key-file: "/etc/unbound/unbound_control.key"
control-cert-file: "/etc/unbound/unbound_control.pem"


#################################################################
ovaj conf radi preko optime dsl modema!
kad spojim preko t -comovog modema sa mikrotikom ne radi,dali mozda ima veze t-com modem thomson? hvala
 
Odgovor na temu

[es] :: Linux/UNIX serveri i servisi :: ubuntu server dns problem

[ Pregleda: 925 | Odgovora: 0 ] > FB > Twit

Postavi temu Odgovori

Navigacija
Lista poslednjih: 16, 32, 64, 128 poruka.