Navigacija
Lista poslednjih: 16, 32, 64, 128 poruka.

Dva gateway-a na cisco 1841

[es] :: Enterprise Networking :: Dva gateway-a na cisco 1841

[ Pregleda: 4174 | Odgovora: 12 ] > FB > Twit

Postavi temu Odgovori

Autor

Pretraga teme: Traži
Markiranje Štampanje RSS

darkopopovic
Popovic Darko

Član broj: 63831
Poruke: 36
91.143.219.*



Profil

icon Dva gateway-a na cisco 184121.07.2008. u 09:40 - pre 169 meseci
Problem je sledeci:

Na cisco 1841 ruteru imam dva fizicka interfejsa, Wan i Lan.
Na Wan int. imam jedan Vlan za internet i tri Vlana ka udaljenim poslovnicam.
Na lanu imam dva Vlana, jedan za lokalnu mrezu i jedan ka Firewallu.
Potrebno je da sve sto treba da dodje ili izadje na Internet sa Vlanova od poslovnica prvo prodje kroz Firewall pa tek onda na inernet .

Sad da je to Mikrotik a ne Cisco ja bih znao:
Postavio bih na Ruteru dva Getweya.
Prvi bi bio Destination 0.0.0.0/0 sa Gatway adresom ka internetu.
Dok kod drugog bih postavijo Destination 0.0.0.0/0 sa Gatway adresom ka Firewollu gde bih se svi paketi prvo obelezavaju sa adrese tih Vlanova (Mangle) a potom bih samo za njih vazio drugi gatwey.
Iposatvi bih staticke rute ka mrezi koja je na Lanu.

Kako ovo da odradim sa Ciso ruterom ?
 
Odgovor na temu

acatheking
Aleksandar Ristić
Beograd/Mirijevo

Član broj: 6769
Poruke: 1133
*.absolutok.com.



+28 Profil

icon Re: Dva gateway-a na cisco 184121.07.2008. u 10:31 - pre 169 meseci
Kreiraš access liste koja če da "hvataju" saobraćaj koji treba preusmeriti na firewall.
Umesto 192.168.0.0 0.0.0.255 stavi opsege koje koristiš na udaljenim lokacijama.
Code:

ip access-list extended vlan-1
 permit ip 192.168.0.0 0.0.0.255 any

ip access-list extended vlan-2
 permit ip 192.168.0.0 0.0.0.255 any

ip access-list extended vlan-3
 permit ip 192.168.0.0 0.0.0.255 any


Kreiraš mapu. Umesto 10.0.0.1 stavi ip adresu firewall-a.
Code:

route-map mapa-1 permit 10
 match ip address vlan-1
 set ip next-hop 10.0.0.1
route-map mapa-1 permit 20
 match ip address vlan-2
 set ip next-hop 10.0.0.1
route-map mapa-1 permit 30
 match ip address vlan-3
 set ip next-hop 10.0.0.1


Na svaki dolazni VLAN intrefejs, dodaj
Code:

ip policy route-map mapa-1



Mislim da sam dobro napisao sve.

Volim da se vozim grackim autobusom.
Gracki autobus jede sitne pare,
gracki autobus zna kad treba stane.
 
Odgovor na temu

markom
Marko Milivojević
Network Engineer
Google
Mountain View

Član broj: 18427
Poruke: 4227
*.rezidencija.rs.

Sajt: https://markom.rs


+16 Profil

icon Re: Dva gateway-a na cisco 184121.07.2008. u 10:56 - pre 169 meseci
... ili koristi VRF-lite :-)

(na žalost, sad nemam vremena da pišem detaljan odgovor, ali ako nađem kasnije danas, napisaću)
 
Odgovor na temu

darkopopovic
Popovic Darko

Član broj: 63831
Poruke: 36
91.143.219.*



Profil

icon Re: Dva gateway-a na cisco 184121.07.2008. u 11:05 - pre 169 meseci
Probacu veceras ,
HVALA !
 
Odgovor na temu

darkopopovic
Popovic Darko

Član broj: 63831
Poruke: 36
91.143.219.*



Profil

icon Re: Dva gateway-a na cisco 184121.07.2008. u 11:25 - pre 169 meseci
Koja je razlika izmedju VRF-lite i route-map ?
 
Odgovor na temu

milelj
Network Engineer
Beograd

Član broj: 189176
Poruke: 6
91.185.125.*



Profil

icon Re: Dva gateway-a na cisco 184128.07.2008. u 18:19 - pre 169 meseci
VRF lite je lokalna MPLS konfiguracija sa L3VPNovima, dok su rut-mape sasvim druga prica...
Long story...
 
Odgovor na temu

anjat
beograd
beograd

Član broj: 183549
Poruke: 23
212.200.132.*



+1 Profil

icon Re: Dva gateway-a na cisco 184129.08.2008. u 15:39 - pre 168 meseci
Pozdrav !
Iscitala sam ovu temu, pa sam se u njoj pronasla...Kod mene je problem, verovatno, jednostavniji ali ipak ne umem da ga resim.Na Ciscu 1841 imam na dva fa mreze 192.168.0.0 i 172.16.0.0, a on je sa dve serijske veze ( 10.1.1.0/30 i 10.1.1.4 su subneti u kojima su serijske veze) vezan na Cisco 7000 i imam s obe strane ospf i to sve lepo radi.Elem, iz određenih razloga zelim da mreza 172.16.0.0 ,,radi" samo kroz jednu serijsku vezu, a 192.168.0.0 kroz drugu. Kreirala sam route-map na sl. nacin:(na Cisco 1841)

(config)#route-map test permit 10
(config-route-map)#route-map anjat permit 10
(config-route-map)#match ip address 1
(config-route-map)#set ip next-hop 10.1.1.1
(config)#access-list 1 permit 172.16.1.1 0.0.255.255
(config)#access-list 1 deny any

i sad ? ,,Okacila" sam route-map na fa na kome mi je mreza 172.16.0.0 , ali to ne radi.Kad radim traceroute (sa source 192.168.1.1) do nekog od lanova na 7000 - vidim da paketi i dalje idu kroz obe serijske veze ... U cemu gresim? Probala sam da route-map okacim i na odgovarajucu serijsku vezu, pa nista...Sta da radim ?







anjat
 
Odgovor na temu

optix
CH

SuperModerator
Član broj: 7009
Poruke: 1866
212.200.241.*



+100 Profil

icon Re: Dva gateway-a na cisco 184129.08.2008. u 16:14 - pre 168 meseci
A sta se desava sa paketima sa 172.16.0.0 mreze?
"99% of your thought process is protecting your self-conceptions,
and 98% of that is wrong."
 
Odgovor na temu

anjat
beograd
beograd

Član broj: 183549
Poruke: 23
212.200.132.*



+1 Profil

icon Re: Dva gateway-a na cisco 184101.09.2008. u 08:20 - pre 168 meseci
Isto - ,,idu" kroz oba serijska linka.
anjat
 
Odgovor na temu

djk494

Član broj: 494
Poruke: 320
83.136.177.*



+39 Profil

icon Re: Dva gateway-a na cisco 184102.09.2008. u 16:04 - pre 168 meseci
Citat:
milelj: VRF lite je lokalna MPLS konfiguracija sa L3VPNovima, dok su rut-mape sasvim druga prica...


http://en.wikipedia.org/wiki/VRF


Citat:
anjat: Pozdrav !
Iscitala sam ovu temu, pa sam se u njoj pronasla...Kod mene je problem, verovatno, jednostavniji ali ipak ne umem da ga resim.Na Ciscu 1841 imam na dva fa mreze 192.168.0.0 i 172.16.0.0, a on je sa dve serijske veze ( 10.1.1.0/30 i 10.1.1.4 su subneti u kojima su serijske veze) vezan na Cisco 7000 i imam s obe strane ospf i to sve lepo radi.Elem, iz određenih razloga zelim da mreza 172.16.0.0 ,,radi" samo kroz jednu serijsku vezu, a 192.168.0.0 kroz drugu.



Evo prost primer konfiguracije sa VRF-ovima, pa ko se snadje, nadam se da nisam nesto izostavio posto nemam vremena da testiram...

_______________________________________________

/*definisanje VRF-a*/

ip vrf prvi

ip vrf drugi

/*pridruzivanje interface-a VRF-u, ip adresa ako postoji na interfaceu bice obrisana posle komande ip vrf forwarding pa je konfigurisite ponovo*/

interface FastEthernet0/0.10
encapsulation dot1Q 10
ip vrf forwarding prvi
ip address 192.168.0.1 255.255.255.0

interface FastEthernet0/0.20
encapsulation dot1Q 20
ip vrf forwarding drugi
ip address 172.16.0.1 255.255.255.0

interface Serial0/0
ip vrf forwarding prvi
ip address 10.1.1.1 255.255.255.252

interface Serial0/1
ip vrf forwarding drugi
ip address 10.1.1.5 255.255.255.252

/*pridruzivanje routing procesa VRF-u, mora da se eksplicitno doda router-id*/

router ospf 10 vrf prvi
router-id 192.168.0.1
network 192.168.0.0 0.0.0.255 area 0
network 10.1.1.0 0.0.0.3 area 0

router ospf 20 vrf drugi
router-id 172.16.0.1
network 172.16.0.0 0.0.0.255 area 0
network 10.1.1.4 0.0.0.3 area 0

_______________________________________________


/*par poznatih komandi u novom ruhu ;) */

show ip route vrf prvi

ping vrf prvi 192.168.0.2

telnet 192.168.0.2 /vrf prvi

ip route vrf prvi 0.0.0.0 0.0.0.0 192.168.0.2

______________________________________________

Poz,
Vedran
 
Odgovor na temu

anjat
beograd
beograd

Član broj: 183549
Poruke: 23
212.200.132.*



+1 Profil

icon Re: Dva gateway-a na cisco 184109.09.2008. u 12:58 - pre 168 meseci
Vedrane, hvala na trudu, ali moj router 7000 ne podrzava VRF-ove.Moram to da resim pomocu mapa kako znam.
Pozdrav!
anjat
 
Odgovor na temu

acatheking
Aleksandar Ristić
Beograd/Mirijevo

Član broj: 6769
Poruke: 1133
*.absolutok.com.



+28 Profil

icon Re: Dva gateway-a na cisco 184109.09.2008. u 13:29 - pre 168 meseci
Ajde probaj da nacrtas mrezu, pojasni malo slikom. Bice lakse za dalju diskusiju.

:)
Volim da se vozim grackim autobusom.
Gracki autobus jede sitne pare,
gracki autobus zna kad treba stane.
 
Odgovor na temu

djk494

Član broj: 494
Poruke: 320
83.136.177.*



+39 Profil

icon Re: Dva gateway-a na cisco 184109.09.2008. u 13:58 - pre 168 meseci
Citat:
anjat: Vedrane, hvala na trudu, ali moj router 7000 ne podrzava VRF-ove.Moram to da resim pomocu mapa kako znam.
Pozdrav!


Iskuckana konfiguracija u tvom slucaju bi trebala da bude na 1841; 7000 bi trebao samo da radi kao i do sada...

Pozdrav.
 
Odgovor na temu

[es] :: Enterprise Networking :: Dva gateway-a na cisco 1841

[ Pregleda: 4174 | Odgovora: 12 ] > FB > Twit

Postavi temu Odgovori

Navigacija
Lista poslednjih: 16, 32, 64, 128 poruka.