Navigacija
Lista poslednjih: 16, 32, 64, 128 poruka.

changeip + mikrotik

[es] :: Wireless :: Mikrotik :: changeip + mikrotik

[ Pregleda: 4213 | Odgovora: 5 ] > FB > Twit

Postavi temu Odgovori

Autor

Pretraga teme: Traži
Markiranje Štampanje RSS

Kolins Balaban
Kolins Balaban
Srednja bosna

Član broj: 4847
Poruke: 1318
77.74.231.*

ICQ: 166070540


+8 Profil

icon changeip + mikrotik20.09.2007. u 22:00 - pre 173 meseci
imam problem sa skriptom koja mi updatuje javnu ip adresu na changeip.com. skripta nekad radi, nekad ne radi, a ja ne vidim nekog pravila, kad hoce da updatuje ip, a kad nece. skriptu sam podesio prema uputstvu sa wikipedie:
http://wiki.mikrotik.com/wiki/...Update_Script_for_ChangeIP.com

pokusavao sam mijenjati ovaj dio koda:
Code:
:global ddns-host "*1"

stavljao sam
Code:
:global ddns-host "*2"

pa
Code:
:global ddns-host "*3"

pa
Code:
:global ddns-host "*www.moja_adresa.zyns.com"

i isto se ponasa u svim slucajevima. skriptu sam ubacio u sheduler, a interval podesio na 5 minuta. Da li je jos neko imao slican problem? Koristim verziju 2.9.27.


MyCoNfa:
CPU: AMD Phenom II X4 965 3,4GHz BOX
Maticna:Asus M4A89GTD PRO
RAM: Corsair 4x2GB 1600MHz, 9-9-9-24
Grafa: Diamond ATI 5870 1GB
HDD:3xWD 320GB AAKS, stripe raid
DVD/RW:LG,SATA
SilverStone SST-ST50F 500W
CoolerMaster CM690
LG 24" 2453TQ-PF
Tastatura A4Tech X7 G800
Stakor: A4Tech X7-755FS
 
Odgovor na temu

stojkemon
Igor Stojkovic
Indjija

Član broj: 90436
Poruke: 76
217.169.219.*



+1 Profil

icon Re: changeip + mikrotik21.09.2007. u 10:05 - pre 173 meseci
Ja imam problem sa drugom skriptom i mislim da je u vezi sa mikrotik bug ili tako nesto. Ili ako ti se racunar resetuje on se pogubi... Podesio sam mu i vreme da se skida sa time servera i vreme je sad sto posto u redu ali se desi da ne odradi shedule kad treba.
 
Odgovor na temu

dejan024
Dejan Major
Yugoslavia,Subotica

Član broj: 2675
Poruke: 505
*.suonline.net.

ICQ: 273632292
Sajt: www.kuvajmo-blogovski.com


+1 Profil

icon Re: changeip + mikrotik01.10.2007. u 14:15 - pre 172 meseci
Scripta ima malih gresaka na tom linku. Evo ti kako je kod mene, ono sto je pod tarabom , je izbaceno. Ovako kako je scripta bez obzira na prethodnu ip updejtuje na changeip. Meni radi bez ikakvih problema na istoj verziji mt-a.


Citat:

:log info "DDNS Begin"
:global ddns-user "korisnik"
:global ddns-pass "sifra"
:global ddns-interface "interface"
:global ddns-host "*1"
:global ddns-ip [/ip address get [/ip address find interface=$ddns-interface] address]
:if {[ :typeof $ddns-lastip] = nil } do={ :global ddns-lastip 0.0.0.0/0 }
:if {[ :typeof $ddns-ip] = nil} do={
:log info "DDNS: No addres present on your interface, plesae check."
} else={
# :if ($ddns-ip != $ddns-lastip) do={
:log info "DDNS: Sending update!"
:log info [/tool dns-update name=$ddns-host address=[:pick $ddns-ip 0 [:find $ddns-ip "/"] ] key-name=$ddns-user key=$ddns-pass ]
# :global ddns-lastip $ddns-ip
# } else={
# :log info ("DDNS: No change.")
# }
}
:log info ("DDNS: End.")


menjaj samo ono sto je pod crvenim i mora da radi
 
Odgovor na temu

Kolins Balaban
Kolins Balaban
Srednja bosna

Član broj: 4847
Poruke: 1318
*.team.ba.

ICQ: 166070540


+8 Profil

icon Re: changeip + mikrotik06.10.2007. u 09:19 - pre 172 meseci
ok, hvala kolega. koliko sam ja skontao, tu problem pravi promjeniva ddns-lastip, u dijelu koda gdje skripta pokusava provjeriti da li je doslo do promjene ip adrese, i ako jeste da novu ip adresu posalje na sajt, i zapamti je u promjenivoj ddns-lastip. Ne znam dobro sintaxu, ali mi se cini da bi u ovoj skripti trebalo ovako nesto da stoji

Code:

:log info "DDNS: Sending update!"
:log info [/tool dns-update name=$ddns-host address=[:pick $ddns-ip 0 [:find $ddns-ip "/"] ] key-name=$ddns-user key=$ddns-pass ]
:global ddns-lastip=$ddns-ip


a ne

Code:

:log info "DDNS: Sending update!"
:log info [/tool dns-update name=$ddns-host address=[:pick $ddns-ip 0 [:find $ddns-ip "/"] ] key-name=$ddns-user key=$ddns-pass ]
:global ddns-lastip $ddns-ip *posljednja ip adresa postaje nova ip adresa


fali znak =, ako sam dobro skonto, $ znaci da se radi o promjenjivoj ili tako nesto.
Sada skripta radi, samo sto updatuje ip adresu i kad se ona nije izmjenila, ali to nije toliki problem :) u svakom slucaju hvala velika.
MyCoNfa:
CPU: AMD Phenom II X4 965 3,4GHz BOX
Maticna:Asus M4A89GTD PRO
RAM: Corsair 4x2GB 1600MHz, 9-9-9-24
Grafa: Diamond ATI 5870 1GB
HDD:3xWD 320GB AAKS, stripe raid
DVD/RW:LG,SATA
SilverStone SST-ST50F 500W
CoolerMaster CM690
LG 24" 2453TQ-PF
Tastatura A4Tech X7 G800
Stakor: A4Tech X7-755FS
 
Odgovor na temu

dragec.v

Član broj: 99877
Poruke: 39
86.61.93.*



Profil

icon Re: changeip + mikrotik09.10.2007. u 00:13 - pre 172 meseci
Pozdrav, ovakva skripta mi radi ma verziji 2.9.38, a na verziji 2.9.33 nece da proradi, u cemu je caka ?
 
Odgovor na temu

Kolins Balaban
Kolins Balaban
Srednja bosna

Član broj: 4847
Poruke: 1318
*.team.ba.

ICQ: 166070540


+8 Profil

icon Re: changeip + mikrotik09.10.2007. u 14:42 - pre 172 meseci
dobro pogledaj da nisi negdje pogrijesio prilikom ubacivanja skripte u mikrotik. da nisi zaboravio negdje neko slovo ili nesto slicno. ako radi na 2.9.27, onda bi trebala raditi i na svakoj novijoj.dobro pogledaj naziv interfejsa sa kojeg kupis ip.
MyCoNfa:
CPU: AMD Phenom II X4 965 3,4GHz BOX
Maticna:Asus M4A89GTD PRO
RAM: Corsair 4x2GB 1600MHz, 9-9-9-24
Grafa: Diamond ATI 5870 1GB
HDD:3xWD 320GB AAKS, stripe raid
DVD/RW:LG,SATA
SilverStone SST-ST50F 500W
CoolerMaster CM690
LG 24" 2453TQ-PF
Tastatura A4Tech X7 G800
Stakor: A4Tech X7-755FS
 
Odgovor na temu

[es] :: Wireless :: Mikrotik :: changeip + mikrotik

[ Pregleda: 4213 | Odgovora: 5 ] > FB > Twit

Postavi temu Odgovori

Navigacija
Lista poslednjih: 16, 32, 64, 128 poruka.