Navigacija
Lista poslednjih: 16, 32, 64, 128 poruka.

XFree 4.1.0 problem

[es] :: Linux :: XFree 4.1.0 problem

[ Pregleda: 4193 | Odgovora: 7 ] > FB > Twit

Postavi temu Odgovori

Autor

Pretraga teme: Traži
Markiranje Štampanje RSS

marvin
paranoid android
PA

Član broj: 818
Poruke: 62
*.ptt.yu

Jabber: marvin@elitesecurity.org
ICQ: 33359062
Sajt: doole.in.rs


Profil

icon XFree 4.1.0 problem28.08.2001. u 12:21 - pre 245 meseci
Instalirah Slackware 8 i sa njim XFree86 v4.1.0
Ali tu se javio problem koji nisam imao sa prethodnom
verzijama (4.0.2 i 3.3.6). Prilikom
# startx
dobijem na kraju poruku
"Caught signal 11. Server aborted"
Ima li neko ideju ucemu bi bio problem.
Graficka je Intel740. Pozdrav.

_moj_potpis_
 
Odgovor na temu

Tigerheart
Mladen Komac
Infrastructure Solution Consultant
S&T Slovenija d.d
Celje

Član broj: 306
Poruke: 460
*.verat.net

Jabber: tigerheart@elitesecurity.org
Sajt: www.linkedin.com/in/komac


Profil

icon Re: XFree 4.1.0 problem28.08.2001. u 22:21 - pre 245 meseci
Citat:
marvin je napisao:
Instalirah Slackware 8 i sa njim XFree86 v4.1.0
Ali tu se javio problem koji nisam imao sa prethodnom
verzijama (4.0.2 i 3.3.6). Prilikom
# startx
dobijem na kraju poruku
"Caught signal 11. Server aborted"
Ima li neko ideju ucemu bi bio problem.
Graficka je Intel740. Pozdrav.

Pokusaj da je konfigurises za xf86Config -om ... jeste da je macice teze al bi trebalo da ti odradi posao kako treba, pri setovanju trebace ti infoi od monitoru tj raspon vertikalne i horizontalne frekfrencije osvezavanja kao i tacan model katice ..... da bi mogao pravilno da je izaberes u xf8config -u
Moguce je da neka od informacija za X server nije ok pa ti i izbacuje taj info .......

--
Mladen Komac
Infrastructure Solution Consultant
Web site: http://www.linkedin.com/in/komac
Blog: http://guru4hp.blogspot.com


 
Odgovor na temu

marvin
paranoid android
PA

Član broj: 818
Poruke: 62
*.ptt.yu

Jabber: marvin@elitesecurity.org
ICQ: 33359062
Sajt: doole.in.rs


Profil

icon Re: XFree 4.1.0 problem28.08.2001. u 23:25 - pre 245 meseci
|| Pokusaj da je konfigurises za xf86Config -om

ma to sam i pokusao i nece da radi. cak sam i probao sa `xf86cfg', kao i sa `XFree86 -configure'. za sada sam stavio 3.3.6, ali bih 'teo 4.1!
_moj_potpis_
 
Odgovor na temu

tOwk
Danilo Šegan
Zemun/Beograd

Član broj: 94
Poruke: 2743
*.etf.bg.ac.yu

ICQ: 9344053
Sajt: alas.matf.bg.ac.yu/~mm011..


+2 Profil

icon Re: XFree 4.1.0 problem30.08.2001. u 02:14 - pre 245 meseci
Ukoliko ti je radio sa 4.0.2, uzmi njegov konfiguracioni fajl i koristi i za 4.1.0

Usput, reci gde prijavljuje gresku, nesto mi se sve cini da ne moze da ti pokrene WM (jesi li instalirao KDE, GNOME, WindowMaker, ...).

Ukoliko nije ni jedno od ova dva, moraces da das malo vise detalja.

Usput, XFree86 4.x ne koristi vise Video Timings kao 3.3.x.

Toliko.
Možda se moje mišljenje promenilo, ali ne i činjenica da sam u pravu.
 
Odgovor na temu

marvin
paranoid android
PA

Član broj: 818
Poruke: 62
*.ptt.yu

Jabber: marvin@elitesecurity.org
ICQ: 33359062
Sajt: doole.in.rs


Profil

icon Re: XFree 4.1.0 problem30.08.2001. u 10:10 - pre 245 meseci
Citat:
tOwk je napisao:
Ukoliko ti je radio sa 4.0.2, uzmi njegov konfiguracioni fajl i koristi i za 4.1.0

Usput, reci gde prijavljuje gresku, nesto mi se sve cini da ne moze da ti pokrene WM (jesi li instalirao KDE, GNOME, WindowMaker, ...).

Ukoliko nije ni jedno od ova dva, moraces da das malo vise detalja.


Probao sam sa konfiguracionim od 4.0.2 ali nece (a trenutno mi nije pri ruci CD sa 4.0.2, ali sam sacuvao conf fajl, tako da _trenutno_ ne mogu da instaliram 4.0.2).
Gresku prijavljuje nakon sto otkucam `startx', ekran pocrni (kao da se sprema da podigne X-e) i onda -- error poruka. A instalirao sam Gnome-a i stavio .xinitrc tako da to ne bi trabalo da bude problem. A i putanje do fontova su OK. Tako da nemam ideju sta bi to moglo da bude.
Obrisao sam bio 4.1.0 i stavio 3.3.6 od Slacka 7.1 i sve radi kako treba (podrazumeva se sam sam ponovo konfigurisao XF86Config).
A za jos detalja jedino da posaljem /var/log/XFree86.0.log fajl, ali je malo poveliki za post ovde...
_moj_potpis_
 
Odgovor na temu

tOwk
Danilo Šegan
Zemun/Beograd

Član broj: 94
Poruke: 2743
*.etf.bg.ac.yu

ICQ: 9344053
Sajt: alas.matf.bg.ac.yu/~mm011..


+2 Profil

icon Re: XFree 4.1.0 problem31.08.2001. u 08:33 - pre 245 meseci
Pa posalji samo relevantne delove (a da to odredis upotrebi ono sto se zove "Razum" kod jedne vrste zivih bica, ljudi :)

Da odredis takve delove moze ti pomoci da das par redova oko greske koju prijavljuje (naravno, sve greske koje prijavljuje), kao i upozorenja.

Naravno, bilo bi zanimljivo kada bi i poslao ceo ispis pri pokretanju "startx" komande (probaj da ga preusmeris pomocu >1, ili >2, ili kako to vec ide za stderr). Uglavnom se iz toga moze malo vise zakljuciti nego iz "Server aborted".

I jos jedna napomena: Prva veca razlika za konfiguraciju XFree86 4.x i 3.3.x servera je u tome sto bi na 4.x trebalo da bude default konf. fajl u /etc/X11/XF86Config, a na 3.3.x u /etc/XF86Config. Moguce je da ti je 4.0.2 koristio fall-back na /etc/XF86Config, a da ga 4.1.0 ne koristi u cilju promovisanja upotrebe umesnijeg /etc/X11/XF86Config.

Toliko.
Možda se moje mišljenje promenilo, ali ne i činjenica da sam u pravu.
 
Odgovor na temu

random
Vladimir Vrzić
Beograd

Član broj: 85
Poruke: 3866
194.106.163.*

Sajt: www.last.fm/user/vrza


+4 Profil

icon Re: XFree 4.1.0 problem01.09.2001. u 11:31 - pre 245 meseci
Code:

startx >startx.log 2>&1

int rand(void);

Those who do not understand Unix are condemned to reinvent it, poorly.

Upali lampicu — koristi Jabber!
 
Odgovor na temu

marvin
paranoid android
PA

Član broj: 818
Poruke: 62
*.ptt.yu

Jabber: marvin@elitesecurity.org
ICQ: 33359062
Sajt: doole.in.rs


Profil

icon Re: XFree 4.1.0 problem02.09.2001. u 20:29 - pre 245 meseci
evo je (malo) skaracena verzija .log-a:

XFree86 Version 4.1.0 / X Window System
(protocol Version 11, revision 0, vendor release 6510)
[...]
Module Loader present
(==) Log file: "/var/log/XFree86.0.log", Time: Wed Aug 29 12:13:01 2001
(==) Using config file: "/etc/X11/XF86Config"
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) ServerLayout "Simple Layout"
(**) |-->Screen "Screen 1" (0)
(**) | |-->Monitor "AVI ProVista"
(**) | |-->Device "Intel 740 (generic)"
(**) |-->Input Device "Mouse1"
(**) |-->Input Device "Keyboard1"
(**) Option "AutoRepeat" "500 30"
(**) Option "XkbRules" "xfree86"
(**) XKB: rules: "xfree86"
(**) Option "XkbModel" "pc104"
(**) XKB: model: "pc104"
(**) Option "XkbLayout" "us"
(**) XKB: layout: "us"
(**) Option "XkbOptions" "grp:toggle"
(**) XKB: options: "grp:toggle"
(==) Keyboard: CustomKeycode disabled
(**) FontPath set to "/usr/X11R6/lib/X11/fonts/local/,/usr/X11R6/lib/X11/fonts/misc/,/usr/X11R6/lib/X11/fonts/75dpi/:unscaled,/usr/X11R6/lib/X11/fonts/100dpi/:unscaled,/usr/X11R6/lib/X11/fonts/Type1/,/usr/X11R6/lib/X11/fonts/Speedo/,/usr/X11R6/lib/X11/fonts/75dpi/,/usr/X11R6/lib/X11/fonts/100dpi/"
(**) RgbPath set to "/usr/X11R6/lib/X11/rgb"
(==) ModulePath set to "/usr/X11R6/lib/modules"
(--) using VT number 7

(WW) Cannot open APM
(II) Module ABI versions:
XFree86 ANSI C Emulation: 0.1
XFree86 Video Driver: 0.4
XFree86 XInput driver : 0.2
XFree86 Server Extension : 0.1
XFree86 Font Renderer : 0.2
(II) Loader running on linux
(II) LoadModule: "bitmap"
(II) Loading /usr/X11R6/lib/modules/fonts/libbitmap.a
(II) Module bitmap: vendor="The XFree86 Project"
compiled for 4.1.0, module version = 1.0.0
Module class: XFree86 Font Renderer
ABI class: XFree86 Font Renderer, version 0.2
(II) Loading font Bitmap
(II) LoadModule: "pcidata"
(II) Loading /usr/X11R6/lib/modules/libpcidata.a
(II) Module pcidata: vendor="The XFree86 Project"
compiled for 4.1.0, module version = 0.1.0
ABI class: XFree86 Video Driver, version 0.4
(II) PCI: Probing config type using method 1
(II) PCI: Config type is 1
(II) PCI: stages = 0x03, oldVal1 = 0x00000000, mode1Res1 = 0x80000000
(II) PCI: PCI scan (all values are in hex)
[...]
(II) PCI: End of PCI scan
(II) LoadModule: "scanpci"
(II) Loading /usr/X11R6/lib/modules/libscanpci.a
(II) Module scanpci: vendor="The XFree86 Project"
compiled for 4.1.0, module version = 0.1.0
ABI class: XFree86 Video Driver, version 0.4
(II) UnloadModule: "scanpci"
(II) Unloading /usr/X11R6/lib/modules/libscanpci.a
(II) Host-to-PCI bridge:
(II) PCI-to-ISA bridge:
(II) PCI-to-PCI bridge:
(II) Bus 0: bridge is at (0:0:0), (-1,0,0), BCTRL: 0x08 (VGA_EN is set)
[...]
(II) Bus -1 prefetchable memory range:
(--) PCI:*(1:0:0) Intel i740 (AGP) rev 33, Mem @ 0xe7000000/24, 0xdf800000/19, BIOS @ 0xe6fc0000/18
(II) Addressable bus resource ranges are
[...]
(II) LoadModule: "dbe"
(II) Loading /usr/X11R6/lib/modules/extensions/libdbe.a
(II) Module dbe: vendor="The XFree86 Project"
compiled for 4.1.0, module version = 1.0.0
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.1
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "extmod"
(II) Loading /usr/X11R6/lib/modules/extensions/libextmod.a
(II) Module extmod: vendor="The XFree86 Project"
compiled for 4.1.0, module version = 1.0.0
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.1
(II) Loading extension SHAPE
(II) Loading extension MIT-SUNDRY-NONSTANDARD
(II) Loading extension BIG-REQUESTS
(II) Loading extension SYNC
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XC-MISC
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-Misc
(II) Loading extension DPMS
(II) Loading extension FontCache
(II) Loading extension TOG-CUP
(II) Loading extension Extended-Visual-Information
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) LoadModule: "type1"
(II) Loading /usr/X11R6/lib/modules/fonts/libtype1.a
(II) Module type1: vendor="The XFree86 Project"
compiled for 4.1.0, module version = 1.0.0
Module class: XFree86 Font Renderer
ABI class: XFree86 Font Renderer, version 0.2
(II) Loading font Type1
(II) Loading font CID
(II) LoadModule: "freetype"
(II) Loading /usr/X11R6/lib/modules/fonts/libfreetype.a
(II) Module freetype: vendor="The XFree86 Project"
compiled for 4.1.0, module version = 1.1.9
Module class: XFree86 Font Renderer
ABI class: XFree86 Font Renderer, version 0.2
(II) Loading font FreeType
(II) LoadModule: "i740"
(II) Loading /usr/X11R6/lib/modules/drivers/i740_drv.o
(II) Module i740: vendor="The XFree86 Project"
compiled for 4.1.0, module version = 1.0.0
Module class: XFree86 Video Driver
ABI class: XFree86 Video Driver, version 0.4
(II) LoadModule: "mouse"
(II) Loading /usr/X11R6/lib/modules/input/mouse_drv.o
(II) Module mouse: vendor="The XFree86 Project"
compiled for 4.1.0, module version = 1.0.0
Module class: XFree86 XInput Driver
ABI class: XFree86 XInput driver, version 0.2
(II) I740: Driver for Intel i740 chipset: i740 (agp), i740 (pci)
(II) Primary Device is: PCI 01:00:0
(--) Assigning device section with no busID to primary device
(--) Chipset i740 (agp) found
(II) resource ranges after xf86ClaimFixedResources() call:
[...]
(II) resource ranges after probing:
[...]
(II) Setting vga for screen 0.
(II) Loading sub module "vgahw"
(II) LoadModule: "vgahw"
(II) Loading /usr/X11R6/lib/modules/libvgahw.a
(II) Module vgahw: vendor="The XFree86 Project"
compiled for 4.1.0, module version = 0.1.0
ABI class: XFree86 Video Driver, version 0.4
(**) I740(0): Depth 16, (--) framebuffer bpp 16

Fatal server error:
Caught signal 11. Server aborting


_moj_potpis_
 
Odgovor na temu

[es] :: Linux :: XFree 4.1.0 problem

[ Pregleda: 4193 | Odgovora: 7 ] > FB > Twit

Postavi temu Odgovori

Navigacija
Lista poslednjih: 16, 32, 64, 128 poruka.