Navigacija
Lista poslednjih: 16, 32, 64, 128 poruka.

broken packages na ubuntu!

[es] :: Linux :: broken packages na ubuntu!

[ Pregleda: 2708 | Odgovora: 10 ] > FB > Twit

Postavi temu Odgovori

Autor

Pretraga teme: Traži
Markiranje Štampanje RSS

Ivan_HR

Član broj: 87291
Poruke: 142
*.cmu.carnet.hr.



Profil

icon broken packages na ubuntu!22.06.2006. u 01:57 - pre 185 meseci
Pokušavajući instalirati package da bi mogao otvarati rar datoteke 'rar_3.30-2ubuntu2_i386' morao sam insatlirati i još neki package! bio mi je potreban 'gcc-4.0-base_4.0.3-1ubuntu5_i386' ali kad sam gledao u Synapticu već je bio instaliran iako mi je ovaj rar javljao da fali! ja otišao na net i sa pckages.ubuntu.. skinio taj gcc-4.0-base te ga iz kozole ponovo instalirao, nakon toga uspio i rar!
e sada problem odmah nakon instalacije toga dobio sam 7 broken packages i sada to više nikako ne mogu ispraviti. probao sam ići na reinstall ali mi previše njih mora maknuti da bi se reinstalirala bilo koja od ovih broken pa se bojim da ću sve pogubit! probao sam maknuti samo ovu 'gcc-base' ali ne vrijedi šta ja tu sada mogu napraviti a da nikako ništa ne gubim što će biti ako odem na reinstall jednostavno ima previše ovih packages za remove??
...trying to do my best...
 
Odgovor na temu

formeye
Ivan Čukić
KDE developer, Free Software Network
Serbia
BGD

Član broj: 5188
Poruke: 388
..taman-bg.customer.sbb.co.yu.

Sajt: ivan.fomentgroup.org


Profil

icon Re: broken packages na ubuntu!22.06.2006. u 06:50 - pre 185 meseci
Pre svega, kad instalises nesto na Debian (ili Ubuntu) nemoj da skidas .deb sa neta pa da ga instalises. (pogotovo ne za GCC i takve vazne stvari). Rar si imao u repozitorijumima Ubuntua, tako da ne znam zasto si morao rucno da ga skidas.

Mozes da probas apt-get -f install sto bi trebalo da dovede pakete u red. Ako bude trazio da brise puno paketa izanaliziraj koji su paketi problem (apt-get daje veoma detaljan izvestaj o tome) i sta bi ti uradio da to sredis. Alternativa je da pritisnes 'yes' pa ponovo instalises sklonjene pakete (brisanje paketa ne brise konfiguracione fajlove)


While you were hanging yourself on someone else's words
Dying to believe in what you heard
I was staring straight into the shining sun
 
Odgovor na temu

absBeg
BiH

Član broj: 97773
Poruke: 201
*.com
Via: [es] mailing liste



Profil

icon Re: broken packages na ubuntu!22.06.2006. u 07:55 - pre 185 meseci
Probaj i
apt-get autoclean

Pa onda
apt-get -f install

Ako slucajno svic -f prijavi gresku, onda probaj svic --fix-missing
"I don't read books, but I have friends who do."
George W. Bush
 
Odgovor na temu

Ivan_HR

Član broj: 87291
Poruke: 142
*.cmu.carnet.hr.



Profil

icon Re: broken packages na ubuntu!22.06.2006. u 11:30 - pre 185 meseci
Mislim da to neće ići!! Bit će red nova instalacija zar ne???
Code:
[email protected]:~# apt-get autoclean
Reading package lists... Done
Building dependency tree... Done
[email protected]:~# apt-get -f install
Reading package lists... Done
Building dependency tree... Done
Correcting dependencies... Done
The following packages will be REMOVED:
  acpi-support apt apt-utils aptitude aspell aspell-en base-config
  beep-media-player bluez-cups bluez-pin bsh bug-buddy build-essential
  capplets-data cdrdao contact-lookup-applet cpp cpp-4.0 cupsys
  cupsys-driver-gimpprint cupsys-driver-gimpprint-data dselect dvd+rw-tools
  eog evince evolution evolution-data-server evolution-exchange
  evolution-plugins evolution-webcal file-roller firefox firefox-gnome-support
  foomatic-db-gimp-print foomatic-db-hpijs freeglut3 g++ g++-4.0 gaim
  gcalctool gcc gcc-4.0 gconf-editor gconf2 gdm gedit gij gij-4.0 gksu
  gnome-about gnome-app-install gnome-applets gnome-applets-data
  gnome-btdownload gnome-control-center gnome-cups-manager gnome-games
  gnome-media gnome-netstatus-applet gnome-nettool gnome-panel
  gnome-panel-data gnome-pilot gnome-pilot-conduits gnome-session gnome-spell
  gnome-system-monitor gnome-system-tools gnome-terminal gnome-utils
  gnome-volume-manager gnomebaker gnomemeeting groff-base gs-common gs-esp
  gstreamer0.8-gnomevfs gstreamer0.8-misc gstreamer0.8-vorbis gthumb
  gtkhtml3.8 gucharmap hal-device-manager hpijs hplip-base hplip-data
  hwdb-client ijsgimpprint java-gcj-compat language-selector
  language-support-en libaspell15 libbonobo2-0 libbonobo2-common
  libbonoboui2-0 libcamel1.2-6 libdjvulibre15 libebook1.2-5 libecal1.2-3
  libedata-book1.2-2 libedata-cal1.2-1 libedataserver1.2-4
  libedataserverui1.2-6 libeel2-2 libegroupwise1.2-8 libexchange-storage1.2-0
  libgc1c2 libgcj6 libgcj6-common libgconf2-4 libgksu1.2-0 libgksuui1.0-0
  libgl1-mesa libgl1-mesa-dri libgle3 libglu1-mesa libglut3 libgnome-desktop-2
  libgnome2-0 libgnome2-common libgnome2-perl libgnome2-vfs-perl
  libgnomecupsui1.0-1 libgnomeui-0 libgnomevfs2-0 libgnomevfs2-common
  libgnucrypto-java libgnujaxp-java libgsf-1 libgstreamer-gconf0.8-0
  libgtkhtml3.8-15 libgtkspell0 libgucharmap4 libhsqldb-java libid3-3.8.3c2
  libidl0 libjaxp1.2-java libjessie-java liblpint-bonobo0 libmetacity0
  libmusicbrainz2c2 libmusicbrainz4c2 libmyspell3c2 libnautilus-extension1
  libopenal0 libopenh323-1.15.3c2 liborbit2 libpanel-applet2-0 libpoppler0c2
  libpoppler0c2-glib libpt-1.8.3c2 libpt-plugins-alsa libpt-plugins-v4l
  libpt-plugins-v4l2 librsvg2-2 librsvg2-common libservlet2.3-java libsmpeg0c2
  libstdc++6 libstdc++6-4.0-dev libstlport4.6c2 libtotem-plparser0 libwpd8c2
  libwvstreams4.0c2-base libwvstreams4.0c2-extras libxalan2-java
  libxerces2-java libxplc0.3.11c2 libxt-java lshw man-db mesa-utils metacity
  mozilla-firefox-locale-en-gb nautilus nautilus-cd-burner nautilus-sendto
  notification-daemon openoffice.org2 openoffice.org2-base
  openoffice.org2-calc openoffice.org2-common openoffice.org2-core
  openoffice.org2-draw openoffice.org2-evolution openoffice.org2-gnome
  openoffice.org2-impress openoffice.org2-java-common
  openoffice.org2-l10n-en-us openoffice.org2-math openoffice.org2-writer
  pnm2ppa powermanagement-interface python-apt python-gnome2
  python-gnome2-extras python-id3lib python-musicbrainz python-pyorbit
  python-uno python2.4-apt python2.4-gnome2 python2.4-gnome2-extras
  python2.4-id3lib python2.4-musicbrainz python2.4-pyorbit rhythmbox rss-glx
  serpentine sound-juicer synaptic telnet toshset totem totem-gstreamer
  tsclient ubuntu-desktop ubuntu-minimal ubuntu-standard update-manager
  update-notifier vino w3m wvdial x-window-system-core xbase-clients xdriinfo
  xscreensaver-gl xvncviewer yelp
WARNING: The following essential packages will be removed.
This should NOT be done unless you know exactly what you are doing!
  apt libstdc++6 (due to apt)
0 upgraded, 0 newly installed, 230 to remove and 0 not upgraded.
Need to get 0B of archives.
After unpacking 738MB disk space will be freed.
You are about to do something potentially harmful.
To continue type in the phrase 'Yes, do as I say!'
 ?]

Na ovakva pitanja uvijek je odgovor ne!!!!!!!!!!!!!
Kažu ljudi na greškama se ući!!
...trying to do my best...
 
Odgovor na temu

Ivan_HR

Član broj: 87291
Poruke: 142
*.cmu.carnet.hr.



Profil

icon Re: broken packages na ubuntu!22.06.2006. u 11:33 - pre 185 meseci
Jel ima ubuntu neki reinstall? da ne gubim sve postavke?
...trying to do my best...
 
Odgovor na temu

Astral Projection
Goran S Pejović
MNE

Član broj: 36254
Poruke: 714
*.crnagora.net.

Sajt: me.linkedin.com/in/goranp..


+4 Profil

icon Re: broken packages na ubuntu!22.06.2006. u 12:50 - pre 185 meseci
probaj sa #aptitude update ili pokusaj sa #apt-get -f dist-upgrade ili #aptitude -f dist-upgrade
Ovim bi trebalo da popravis "broken" pakete..
:(){ :|:& };:
Peace, Love, Unity, Respect!
 
Odgovor na temu

Ivan_HR

Član broj: 87291
Poruke: 142
*.adsl.net.t-com.hr.



Profil

icon Re: broken packages na ubuntu!24.06.2006. u 14:36 - pre 185 meseci
Pokušano no ništa ne radi , svaki puta mi mora ukloniti milion povezanih paketa! Lijepo sam ja to sve reinstalirao, ponovo podtavio i tako sad sve radi! Znam barem šta više neću radit! Sad sam si bar uspio i wireless konekciju uspostavit!
...trying to do my best...
 
Odgovor na temu

Astral Projection
Goran S Pejović
MNE

Član broj: 36254
Poruke: 714
*.crnagora.net.

Sajt: me.linkedin.com/in/goranp..


+4 Profil

icon Re: broken packages na ubuntu!24.06.2006. u 15:28 - pre 185 meseci
A nijesi trebao reinstall imao sam ja isti problem.. i na freenodeu su mi rekli kako to da rijesim, ali da me ubijes ne sjecam se.. Nesto tipa dpkg --remove gcc-4.0 ili sta vec i onda odradis apt-get... I jedan hint... Nikad ne koristi alien.. ;)
:(){ :|:& };:
Peace, Love, Unity, Respect!
 
Odgovor na temu

Ivan_HR

Član broj: 87291
Poruke: 142
*.adsl.net.t-com.hr.



Profil

icon Re: broken packages na ubuntu!24.06.2006. u 15:44 - pre 185 meseci
Ma probao sam ja remove i maknio taj gcc-4.0. ali mi je poremetio sve živo i ne znam činila mi se najjednostavnija opcija sve reinstalirat jer sam tek postavio sustav pa nisam ništa puno gubi,o a i početnik sam pa mi dobro dođe utvrđivanje gradiva, tj. kako sve postaviti da radi ispočetka!
...trying to do my best...
 
Odgovor na temu

Borovic
Stefan Borovic
Beograd

Član broj: 80154
Poruke: 204
*.eunet.yu.

Jabber: borovic@elitesecurity.org


Profil

icon Re: broken packages na ubuntu!25.06.2006. u 13:07 - pre 185 meseci
Ovo je komanda za slapt-get (apt-get system for Slackware). Meni je ova komanda uspela da "popravi" sistem posle delimično neuspele instalacije.

Code:
slapt-get --available|grep inst=no|awk '{print $1}'|uniq|xargs -r slapt-get -y --install


P.S. Pošto si reinstalirao sistem, nećeš moći da probaš ovu komandu, ali sam ti je napisao ukoliko se ovako nešto ponovo desi.
n
 
Odgovor na temu

Ivan_HR

Član broj: 87291
Poruke: 142
*.adsl.net.t-com.hr.



Profil

icon Re: broken packages na ubuntu!25.06.2006. u 20:16 - pre 185 meseci
Hvala na riješenju ako opet za**em znat cu sta da radim!
...trying to do my best...
 
Odgovor na temu

[es] :: Linux :: broken packages na ubuntu!

[ Pregleda: 2708 | Odgovora: 10 ] > FB > Twit

Postavi temu Odgovori

Navigacija
Lista poslednjih: 16, 32, 64, 128 poruka.