Navigacija
Lista poslednjih: 16, 32, 64, 128 poruka.

emerge --update --deep world

[es] :: Linux :: emerge --update --deep world

[ Pregleda: 2884 | Odgovora: 10 ] > FB > Twit

Postavi temu Odgovori

Autor

Pretraga teme: Traži
Markiranje Štampanje RSS

vladared
Vladimir Crveni
Sistem Administrator
Novi Sad

Moderator
Član broj: 50291
Poruke: 1022
*.recnikonline.com.

Sajt: www.itpoint.rs


+394 Profil

icon emerge --update --deep world18.04.2006. u 10:00 - pre 197 meseci
Dakle imam gentoo-a što je vidljivo već preko naslovne linije. Problem sa kojim sam se susreo, kada sam završio sa instalacijom svega što sam želeo, pokušao sam da uradim update sistema (gore već pomenutom naredbom), ali umesto to da se dogodi dogoilo se blokiranje. Odjednom ima jako mnogo blokera svi su tipa


[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/kbproto-1.0.2)
.
.
.


sem zadnja dva koja su tipa..


[blocks B ] sys-apps/coldplug (is blocking sys-fs/udev-090)
[blocks B ] sys-apps/pam-login (is blocking sys-apps/shadow-4.0.15)



Kako da prevaziđem ovaj problem (sa obzirom da je umešan xorg u čitavu priču... Što je još gore dokle postoje ovi blokeri ne mogu ništa na svom sistemu da update-ujem...
 
Odgovor na temu

Stator
System Administrator
Beograd

Član broj: 14552
Poruke: 257
*.ADSL.neobee.net.



+3 Profil

icon Re: emerge --update --deep world18.04.2006. u 10:26 - pre 197 meseci
Code:

*udev-089 (03 Apr 2006) 

03 Apr 2006; Greg Kroah-Hartman <[email protected]
+files/udev-start-089.sh, +udev-089.ebuild: 
089 release 
adds a new library (can 64 bit arches please verify that I didn't mess 
something up here?) 
adds "coldplug" functionality to udev by default, use the module blacklist 
option to prevent things from being loaded if you don't like this.


Dakle nova nerzija udev-a sadrzi coldplug. Tako da emerge -C na coldplug, pa emerguj udev i resio si jedan problem.

A ovo za X-org ne znam d nisi mesao stabilnu i nestabilnu granu?
 
Odgovor na temu

vladared
Vladimir Crveni
Sistem Administrator
Novi Sad

Moderator
Član broj: 50291
Poruke: 1022
..mtsns-ns.customer.sbb.co.yu.

Sajt: www.itpoint.rs


+394 Profil

icon Re: emerge --update --deep world18.04.2006. u 10:44 - pre 197 meseci
Kako misliš mešao? Kada sam instalirao, instalirao sam live cd-a ali prva stvar koja je potom bila urađena jeste da ubacim nestabilnu granu?!? I posle toga je sve instalirano. Morao sam ovako da odradim jer jednostavno nije hteo da mi instalira gentooa...
 
Odgovor na temu

Stator
System Administrator
Beograd

Član broj: 14552
Poruke: 257
*.ADSL.neobee.net.



+3 Profil

icon Re: emerge --update --deep world18.04.2006. u 10:59 - pre 197 meseci
Dakle ja ti preporucujem da se vratis na SAMO stabilnu granu. E da nisi reko koji gentoo koristis 32-bitni ili 64-bitni?

Evo ja koristim stable 64 bitni sa i sa ovim xorgom nemam nikakvih problema

Code:

x11-base/xorg-x11
      Latest version available: 6.8.2-r6
      Latest version installed: 6.8.2-r6
      Size of downloaded files: 135,439 kB
      Homepage:    http://xorg.freedesktop.org/
      Description: An X11 implementation maintained by the X.Org Foundation
      License:     Adobe-X CID DEC DEC-2 IBM-X NVIDIA-X NetBSD SGI UCB-LBL XC-2 bigelow-holmes-urw-gmbh-luxi christopher-g-demetriou national-semiconductor nokia tektronix the-open-group todd-c-miller x-truetype xfree86-1.0 MIT SGI-B BSD || ( FTL GPL-2 )

 
Odgovor na temu

vladared
Vladimir Crveni
Sistem Administrator
Novi Sad

Moderator
Član broj: 50291
Poruke: 1022
..mtsns-ns.customer.sbb.co.yu.

Sajt: www.itpoint.rs


+394 Profil

icon Re: emerge --update --deep world18.04.2006. u 11:12 - pre 197 meseci
32 bitni je gentoo (sorry nisam zapazio taj deo).
 
Odgovor na temu

Tyler Durden
Tyler Durden
Beograd

Član broj: 4312
Poruke: 3379
*.verat.net.



+1365 Profil

icon Re: emerge --update --deep world18.04.2006. u 12:06 - pre 197 meseci
Izbaci citav output sto ti vrati emerge. Mozes prikaciti kao fajl.
XORG 7 je pusten u ~ grani tako da moras da obrises xorg6 koji ti blokira novu verziju i instaliras 7.
http://www.gentoo.org/proj/en/desktop/x/x11/modular-x-howto.xml
Beneath civilization's fragile crust, cold chaos churns...
 
Odgovor na temu

vladared
Vladimir Crveni
Sistem Administrator
Novi Sad

Moderator
Član broj: 50291
Poruke: 1022
*.recnikonline.com.

Sajt: www.itpoint.rs


+394 Profil

icon Re: emerge --update --deep world18.04.2006. u 21:49 - pre 197 meseci
evo mene napokon kući da mogu d apošaljem ovaj dizveštaj...

Code:

# emerge --update --deep --pretend world

These are the packages that I would merge, in order:

Calculating world dependencies ...done!
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/kbproto-1.0.2)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-misc/util-macros-1.0.1)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/xextproto-7.0.2)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/xproto-7.0.4)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/xf86bigfontproto-1.1.2)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/inputproto-1.3.2)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libX11-1.0.0-r2)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXau-1.0.0)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/bigreqsproto-1.0.2)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXdmcp-1.0.0)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/xcmiscproto-1.1.2)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/xtrans-1.0.0)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libxkbfile-1.0.2)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-apps/setxkbmap-1.0.2)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libICE-1.0.0)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libSM-1.0.0)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXext-1.0.0-r1)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXfixes-3.0.1.2)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/fixesproto-4.0)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/compositeproto-0.3.1)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXcomposite-0.3)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXt-1.0.0-r1)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXmu-1.0.0)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-apps/xauth-1.0.1)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-apps/mkfontscale-1.0.1)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libfontenc-1.0.1)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking media-fonts/encodings-1.0.0)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking media-fonts/font-util-1.0.0)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking media-fonts/font-adobe-100dpi-1.0.0)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-apps/bdftopcf-1.0.0)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/fontsproto-2.0.2)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/fontcacheproto-0.1.2)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXfont-1.1.0-r1)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-apps/mkfontdir-1.0.2)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking media-fonts/font-alias-1.0.1)

[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking app-doc/xorg-docs-1.1)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/damageproto-1.0.3)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXdamage-1.0.2.2)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-apps/xhost-1.0.1)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-base/xorg-x11-7.0-r1)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXScrnSaver-1.0.1-r1)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/scrnsaverproto-1.1.0)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/xf86dgaproto-2.0.2)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXxf86dga-1.0.0-r1)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking media-fonts/font-adobe-utopia-type1-1.0.1)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-apps/xmodmap-1.0.0)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXcursor-1.1.5.2-r1)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/renderproto-0.9.2)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXrender-0.9.0.2)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-apps/xclock-1.0.1)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXft-2.1.8.2)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXpm-3.5.4.2)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXaw-1.0.1)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-apps/xinit-1.0.2)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-apps/xrdb-1.0.1)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-wm/twm-1.0.1)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXrandr-1.1.0.2-r1)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/randrproto-1.1.2)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-apps/xrandr-1.0.1)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/xineramaproto-1.1.2)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXinerama-1.0.1)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking media-fonts/font-bh-type1-1.0.0)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/printproto-1.0.3)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXp-1.0.0)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/xf86miscproto-0.9.2)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXxf86misc-1.0.0-r1)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/liblbxutil-1.0.0)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/dmxproto-2.2.2)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/videoproto-2.2.2)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/trapproto-3.4.3)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/recordproto-1.13.2)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXtst-1.0.1)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libdmx-1.0.1)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/resourceproto-1.0.2)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-apps/iceauth-1.0.1)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking media-fonts/font-adobe-75dpi-1.0.0)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/xf86rushproto-1.1.2)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-base/xorg-server-1.0.2-r3)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking media-fonts/font-misc-misc-1.0.0)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libxkbui-1.0.1)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking media-fonts/font-cursor-misc-1.0.0)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/glproto-1.4.6)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXres-1.0.0-r1)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-apps/xkbcomp-1.0.1)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-misc/xbitmaps-1.0.1)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-apps/rgb-1.0.0)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-misc/makedepend-1.0.0)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking media-libs/mesa-6.4.2-r2)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/xf86vidmodeproto-2.2.2)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/xf86driproto-2.0.3)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXxf86vm-1.0.0-r1)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXi-1.0.0-r1)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libdrm-2.0.1)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/evieext-1.0.2)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXv-1.0.1)
[blocks B     ] sys-apps/coldplug (is blocking sys-fs/udev-090)
[blocks B     ] sys-apps/pam-login (is blocking sys-apps/shadow-4.0.15)


Naravno posalo sam samo blokere... (izvinjavam se što nisam poslao file nego sirov materijal)
 
Odgovor na temu

Tyler Durden
Tyler Durden
Beograd

Član broj: 4312
Poruke: 3379
195.252.86.*



+1365 Profil

icon Re: emerge --update --deep world18.04.2006. u 22:00 - pre 197 meseci
Da, definitivno je problem u X-u. Pogledaj ovaj gore link.
Beneath civilization's fragile crust, cold chaos churns...
 
Odgovor na temu

vladared
Vladimir Crveni
Sistem Administrator
Novi Sad

Moderator
Član broj: 50291
Poruke: 1022
*.recnikonline.com.

Sajt: www.itpoint.rs


+394 Profil

icon Re: emerge --update --deep world20.04.2006. u 06:26 - pre 197 meseci
Novi X 7,0 je namešten i fercera... Istog trennutka mi je proradio i update.... A joj majko moja 240 paketa.... Pa dobro, i ovako se sada uradi pa kasnije neće biti toliko :-/ ... U svakom slučaju hvala na pomoći...
 
Odgovor na temu

vladared
Vladimir Crveni
Sistem Administrator
Novi Sad

Moderator
Član broj: 50291
Poruke: 1022
..mtsns-ns.customer.sbb.co.yu.

Sajt: www.itpoint.rs


+394 Profil

icon Re: emerge --update --deep world25.04.2006. u 09:09 - pre 196 meseci
hmmm kako da isključim neki update (dakle da mi se sve updatuje sem)... Ovo je zbog toga što kada sam u stable grani ako uradim update on će mi izvršiti downgrade svih paketa koje su pod x86 granom sređeni, a to ipak ne bi želeo!!! (naravno uvek može ručni update, ali šta ako mi se nakupi paketa???)
 
Odgovor na temu

Stator
System Administrator
Beograd

Član broj: 14552
Poruke: 257
*.ADSL.neobee.net.



+3 Profil

icon Re: emerge --update --deep world25.04.2006. u 09:20 - pre 196 meseci
Code:

nano /etc/portage/package.keywords


I tu upises imana svih paketa koja oces da koristis u ~(unstable) grani
 
Odgovor na temu

[es] :: Linux :: emerge --update --deep world

[ Pregleda: 2884 | Odgovora: 10 ] > FB > Twit

Postavi temu Odgovori

Navigacija
Lista poslednjih: 16, 32, 64, 128 poruka.