Navigacija
Lista poslednjih: 16, 32, 64, 128 poruka.

Veliki problem sa SSH na mikrotik-u

[es] :: Wireless :: Mikrotik :: Veliki problem sa SSH na mikrotik-u

[ Pregleda: 798 | Odgovora: 13 ] > FB > Twit

Postavi temu Odgovori

Autor

Pretraga teme: Traži
Markiranje Štampanje RSS

scsi77
Kragujevac

Član broj: 234288
Poruke: 35
*.adsl.eunet.rs.



Profil

icon Veliki problem sa SSH na mikrotik-u10.07.2018. u 14:03 - pre 5 meseci
Postovani, potrebna mi je pomoc oko preusmeravanja porta 15001 na odredjenu adresu. U nat-u odradim podesavanje kako trebaali kada pokusam preko putty-a da pristiupim kaze da port nije otvoren (A JESTE)... Da li neko ima resenje za ovako nesto s obzirom da mi na linksys-u radi sasvim normalno...
 
Odgovor na temu

viss02

Član broj: 100217
Poruke: 336
*.dynamic.sbb.rs.



Profil

icon Re: Veliki problem sa SSH na mikrotik-u11.07.2018. u 09:14 - pre 5 meseci
Ako SSH radi na portu 23, a ti hoces od spolja da pristupis tako sto se konektujes port 15001, onda ti treba ovako nesto unutar /ip firewall nat
Code:
add action=dst-nat chain=dstnat dst-port=15001 in-interface=<wan interfejs> protocol=tcp to-addresses=<IP od uredjaja koji je ssh server> to-ports=22


Na MT gde radis nat nemoj da ostavis ssh na portu 15001, ali nemoj ni da radis nikakav drop i trebalo bi da bude ok.

Ako ne uspes, bilo bi dobro da das vise detalja kako bi mogli da pomognemo. Neki export, koje ip adrese koristis, sta sve imas od nat/firewall pravila.
 
Odgovor na temu

scsi77
Kragujevac

Član broj: 234288
Poruke: 35
*.adsl.eunet.rs.



Profil

icon Re: Veliki problem sa SSH na mikrotik-u11.07.2018. u 09:58 - pre 5 meseci
Hvala na odgovoru, za nekih sat vremena cu probati pa se javljam...
 
Odgovor na temu

scsi77
Kragujevac

Član broj: 234288
Poruke: 35
*.adsl.eunet.rs.



Profil

icon Re: Veliki problem sa SSH na mikrotik-u11.07.2018. u 10:01 - pre 5 meseci
jos malo detalja pre nego sto isprobam ovo sto ste mi napisali...

ip FW nat imam preusmerene portove 15000, 443, i oni rade, a kada preusmerim 15001 taj ne radi...

ip adresa rutera mi je 192.168.1.2, a ip adresa servera za koji otvaram port je 192.168.1.230

u opciji ip service ssh port je na 22
 
Odgovor na temu

scsi77
Kragujevac

Član broj: 234288
Poruke: 35
82.117.212.*



Profil

icon Re: Veliki problem sa SSH na mikrotik-u11.07.2018. u 11:48 - pre 5 meseci
ipak nece

add action=dst-nat chain=dstnat dst-port=15001 in-interface=ether1 protocol=tcp \ to-addresses=192.168.1.2 to-ports=22
 
Odgovor na temu

valjan
Janko Valencik
Inženjer/programer
Alfanum d.o.o.
Novi Sad

Član broj: 158605
Poruke: 3357
*.mediaworksit.net.

Sajt: www.alfanum.co.rs


Profil

icon Re: Veliki problem sa SSH na mikrotik-u11.07.2018. u 11:54 - pre 5 meseci
Pa ti reče da ti je adresa servera 192.168.1.230 a ovamo si u "to-addresses" stavio adresu rutera...
 
Odgovor na temu

scsi77
Kragujevac

Član broj: 234288
Poruke: 35
82.117.212.*



Profil

icon Re: Veliki problem sa SSH na mikrotik-u11.07.2018. u 12:02 - pre 5 meseci
izvini adresa servera je 192.168.1.230 i to je greska ali i sa tom ispravkom nece, a u ip service stoji ssh port 22
 
Odgovor na temu

valjan
Janko Valencik
Inženjer/programer
Alfanum d.o.o.
Novi Sad

Član broj: 158605
Poruke: 3357
*.mediaworksit.net.

Sajt: www.alfanum.co.rs


Profil

icon Re: Veliki problem sa SSH na mikrotik-u11.07.2018. u 13:06 - pre 5 meseci
A možeš li iz LAN-a da pristupiš tom portu preko putty-ja?
 
Odgovor na temu

scsi77
Kragujevac

Član broj: 234288
Poruke: 35
*.adsl.eunet.rs.



Profil

icon Re: Veliki problem sa SSH na mikrotik-u11.07.2018. u 13:30 - pre 5 meseci
Pazi ovako

kada pristupim iz lan-a preko putty-a prilazi normalno, tj. kada kucam ip adresu servera i port 15001

a kada iz lana ukucam staticku adresu i port 15001 nije hteo da pridje dok nisam odradio podesavanja koja si mi napisao ali kada probam sa druge lokacije on nece...
 
Odgovor na temu

valjan
Janko Valencik
Inženjer/programer
Alfanum d.o.o.
Novi Sad

Član broj: 158605
Poruke: 3357
*.mediaworksit.net.

Sajt: www.alfanum.co.rs


Profil

icon Re: Veliki problem sa SSH na mikrotik-u11.07.2018. u 13:58 - pre 5 meseci
Meni sad više ništa nije jasno koje portove ti koristiš...
 
Odgovor na temu

scsi77
Kragujevac

Član broj: 234288
Poruke: 35
*.adsl.eunet.rs.



Profil

icon Re: Veliki problem sa SSH na mikrotik-u11.07.2018. u 14:47 - pre 5 meseci
:)

ajmo iz pocetka

ja treba sa spoljne adrese preko porta 15001 da pridjem serveru koji koristi ssh, ip adresa servera je 192.168.1.230 a ip adresa rutera je 192.168.1.2

ma MT ruteru u opciji IP service list ssh je na 22 port-u to je podeseno po def....

za prilaz koristim putty aplikaciju....
 
Odgovor na temu

lazarevicc

Član broj: 115259
Poruke: 215



Profil

icon Re: Veliki problem sa SSH na mikrotik-u11.07.2018. u 17:33 - pre 5 meseci
Iskljuci ssh na mikrotiku ili ga prebaci na neki drugi port.
Koliko ja kontam ti hoces da pristupis serveru iza mikrotika koji ima ssh na portu 22,a i sam mikortik ima ssh na portu 22...verujem da tu dolazi do problema.
A sto se tice redirekta porta,to kako si podesio bi trebalo da radi.

Pozz
 
Odgovor na temu

dragansar
Sarajevo

Član broj: 84903
Poruke: 582
*.customer.blic.net.

Sajt: www.linkedin.com/pub/drag..


Profil

icon Re: Veliki problem sa SSH na mikrotik-u12.07.2018. u 12:51 - pre 5 meseci
Citat:
scsi77:
:)

ajmo iz pocetka

ja treba sa spoljne adrese preko porta 15001 da pridjem serveru koji koristi ssh, ip adresa servera je 192.168.1.230 a ip adresa rutera je 192.168.1.2

ma MT ruteru u opciji IP service list ssh je na 22 port-u to je podeseno po def....

za prilaz koristim putty aplikaciju....



Evo ti primjer, ako je tvoja javna adresa 31.223.25.82 i ako ides SSH po portu 15001 (kao na slici ispod)

A pritome imas pravilo na MT-u ispod, gdje ti je eth1 WAN intereface na MT-u (dolazni interefejs interneta);192.168.1.230 IP adresa servera koji osluskuje i prihvata SSH konekcije na portu TCP portu 22(provjeri da ti firewall ne blokira SSH sa nepoznati lokacija...tipa da dozvoljava samo sa mreze 192.168.1.0/24 a ostalo sjece)
Code:
add action=dst-nat chain=dstnat comment="SSH to Server" disabled=yes dst-port=15001 in-interface=eth1 protocol=tcp \
    to-addresses=192.168.1.230 to-ports=22

Na ovaj nacin ces pristupiti sa remote lokacije tom serveru.Jel ti ovo treba?
Citat:
ma MT ruteru u opciji IP service list ssh je na 22 port-u to je podeseno po def....

Ovo ti ne igra nikakvu ulogu ako ces ti doci po portu 15001, a NAT pravilo cete preusmjeriti na server po 22 portu.
U jednom postu sad vidjeh da si napisao
Citat:
add action=dst-nat chain=dstnat dst-port=15001 in-interface=ether1 protocol=tcp \ to-addresses=192.168.1.2 to-ports=22

Ako ti je 192.168.1.2 adresa MT-a, ne treba na nju da preusmjeravas nego na adresu tog servera 192.168.1.230 kao sto sam ti gore i napisao
Nisam stigao da procitam sav post, vidim da su ti vec sugerisali na ovo...tako da mislim da pravi problem firewall na tom serveru
I dali si gledao kada pokusava da se konektujes dali ti to pravilo me match-ira ikakav saobracaj?


[Ovu poruku je menjao dragansar dana 12.07.2018. u 14:02 GMT+1]
Šaka
 
Odgovor na temu

scsi77
Kragujevac

Član broj: 234288
Poruke: 35
*.adsl.eunet.rs.



Profil

icon Re: Veliki problem sa SSH na mikrotik-u12.07.2018. u 14:49 - pre 5 meseci
bas to mi treba...

sutra cu ja ovo da probam pa se javljam....
 
Odgovor na temu

[es] :: Wireless :: Mikrotik :: Veliki problem sa SSH na mikrotik-u

[ Pregleda: 798 | Odgovora: 13 ] > FB > Twit

Postavi temu Odgovori

Navigacija
Lista poslednjih: 16, 32, 64, 128 poruka.