Navigacija
Lista poslednjih: 16, 32, 64, 128 poruka.

CapsMan VLAN-ovi

[es] :: Wireless :: Mikrotik :: CapsMan VLAN-ovi

[ Pregleda: 368 | Odgovora: 2 ] > FB > Twit

Postavi temu Odgovori

Autor

Pretraga teme: Traži
Markiranje Štampanje RSS

sarmudin

Član broj: 82990
Poruke: 206
*.static1.client.xnet.hr.



+1 Profil

icon CapsMan VLAN-ovi05.04.2021. u 12:52 - pre 15 meseci
Između ostalog pokušavam natjerat CapsMan da radi sa VLAN-ima, tj da se emitiraju 2 mreže i svaka je svoj VLAN.
Na routeru sam napravio Bridge, spucao potrebne portove i VLAN-e na njega. Svaki VLAN ima svoj DHCP server.
Kad taj VLAN untaggea-m na switchu uredno dobijam DHCP server na svim VLAN-ima i imam izlaz na internet.
Nakon šta je sve to proradilo pokušavam složit CapsMan sa VLAN-ima. Provisioning radi, mreže su vidljive i može se spojit na njih ali DHCP server ne radi, kao da se VLAN-i ne prosljeđuju.

Capsman Config:

Code:

/caps-man channel
::
::Kanali upisani
::
/
/caps-man datapath
add arp=local-proxy-arp client-to-client-forwarding=no local-forwarding=no \
    name=DataPath_Biz vlan-id=128 vlan-mode=use-tag
add arp=local-proxy-arp client-to-client-forwarding=no local-forwarding=no \
    name=DataPath_Gosti vlan-id=200 vlan-mode=use-tag
/
/caps-man security
add authentication-types=wpa2-psk comment="PassPhrase: 12345678" encryption=\
    aes-ccm name=Guests passphrase=12345678
add authentication-types=wpa2-psk comment="PassPhrase: 12345678" encryption=\
    aes-ccm name=BIZ passphrase=12345678
/
/caps-man configuration
add channel.band=2ghz-g/n channel.tx-power=15 country=croatia datapath=\
    DataPath_Gosti installation=indoor mode=ap name=Guests_2.4 \
    security=Guests ssid=Guests
add channel.band=2ghz-g/n channel.tx-power=15 country=croatia datapath=\
    DataPath_Biz installation=indoor mode=ap name=BIZ_2.4 security=\
    BIZ ssid=BIZ
add channel.band=5ghz-a/n/ac channel.tx-power=20 country=croatia datapath=\
    DataPath_Biz installation=indoor mode=ap name=BIZ_5 rx-chains=0,1 \
    security=BIZ ssid=BIZ tx-chains=0,1
add channel.band=5ghz-a/n/ac channel.tx-power=20 country=croatia datapath=\
    DataPath_Gosti installation=indoor mode=ap name=Guests_5 \
    rx-chains=0,1 security=Guests ssid=Guests tx-chains=0,1
/
/caps-man manager
set enabled=yes
/
/caps-man manager interface
add disabled=no interface=VLAN_10
/
/caps-man provisioning
add action=create-dynamic-enabled hw-supported-modes=gn identity-regexp=\
    SeaWings_CAP master-configuration=Guests_2.4 slave-configurations=\
    BIZ_2.4
add action=create-dynamic-enabled hw-supported-modes=ac identity-regexp=\
    SeaWings_CAP master-configuration=Guests_5 slave-configurations=\
    BIZ_5
/


Cap config:
Code:

/
/interface bridge
add name=bridge1 vlan-filtering=yes
/
/interface vlan
add interface=bridge1 name=vlan10 vlan-id=10
add interface=bridge1 name=vlan128 vlan-id=128
add interface=bridge1 name=vlan200 vlan-id=200
/
/interface bridge port
add bridge=bridge1 interface=ether1 pvid=10
add bridge=bridge1 interface=ether2 pvid=10
add bridge=bridge1 interface=wlan1 pvid=200
add bridge=bridge1 interface=wlan2 pvid=200
add bridge=bridge1 interface=dynamic pvid=128
/
/interface bridge vlan
add bridge=bridge1 comment=LAN_Mgmt tagged=bridge1 untagged=ether1,ether2 vlan-ids=10
add bridge=bridge1 comment=WiFi_BIZ tagged=bridge1,ether1,ether2 vlan-ids=128
add bridge=bridge1 comment=WiFi_Gosti tagged=bridge1,ether1,ether2 untagged=wlan1,wlan2 vlan-ids=200
/
/interface wireless cap
set caps-man-addresses=10.200.1.1 discovery-interfaces=vlan10 enabled=yes interfaces=wlan1,wlan2
/


Imam osjecaj da sam ili sve falio ili je nesto previse ocito.
 
Odgovor na temu

DeLacy
Novi Sad

Član broj: 23344
Poruke: 102
*.dynamic.sbb.rs.



+66 Profil

icon Re: CapsMan VLAN-ovi06.04.2021. u 11:22 - pre 15 meseci
Citat:
/caps-man datapath
add arp=local-proxy-arp client-to-client-forwarding=no local-forwarding=no \
name=DataPath_Biz vlan-id=128 vlan-mode=use-tag
add arp=local-proxy-arp client-to-client-forwarding=no local-forwarding=no \
name=DataPath_Gosti vlan-id=200 vlan-mode=use-tag


Probaj da eliminišeš vlan-id i vlan-mode iz datapath konfiguracije - VLAN konfiguraciju mu definišeš u bridžu. Moraš definisati dva bridža, za svaki VLAN po jedan.
Bar tako kod mene funkcioniše.
 
Odgovor na temu

sarmudin

Član broj: 82990
Poruke: 206
*.static.a1.hr.



+1 Profil

icon Re: CapsMan VLAN-ovi15.04.2021. u 19:22 - pre 14 meseci
Rješio sam problem samo sa jednim bridg-eom, a bilo je toliko očito da sam ga previdio.
Zeznuo sam bio nešto u Trunk-u koji je prenosio VLAN-e. Sad sve radi
 
Odgovor na temu

[es] :: Wireless :: Mikrotik :: CapsMan VLAN-ovi

[ Pregleda: 368 | Odgovora: 2 ] > FB > Twit

Postavi temu Odgovori

Navigacija
Lista poslednjih: 16, 32, 64, 128 poruka.