Navigacija
Lista poslednjih: 16, 32, 64, 128 poruka.

Skripta za proveru napona na routerboardu i slanje izvestaja mailom

[es] :: Wireless :: Mikrotik :: Skripta za proveru napona na routerboardu i slanje izvestaja mailom

[ Pregleda: 2023 | Odgovora: 11 ] > FB > Twit

Postavi temu Odgovori

Autor

Pretraga teme: Traži
Markiranje Štampanje RSS

bmarkovic06

Član broj: 301412
Poruke: 688



+61 Profil

icon Skripta za proveru napona na routerboardu i slanje izvestaja mailom03.03.2016. u 21:42 - pre 49 meseci
Ako je neko od vas imao potrebu da mu je zatrebala notifikacija mailom ukoliko dodje do nestanka struje na nekoj od lokacija gde se koristite baterijski bekapi onda je ova skripta jako zgodna stvar. Ili ukoliko ste je koristili znacete da je prestala sa radom nakon 6.30 verzije ali nasao sam jednostavno resenje. Bila je samo jedna greska oko pozivanja druge skripte, a o cemu se radi napisacu ispod.


Naime treba napraviti 2 skripte, jedna za monitoring a druga za slanje dnevnog izvestaja (ukoliko zelite nesto poput toga)


Kreirati skriptu pod nazivom voltmonitor i obratiti paznju na poslednji deo koda koji je i pravio gresku u prethodnoj verziji:


/system script add name=voltmonitor

zatim uneti skriptu


#podesite lowvoltalarm kao napon za ~ 1V nize nego trenutna voltaza (jer kada nestane struje napon na baterijama ce pasti za otprilike 1v i nastavice da pada), podesavate ga kao trocifren broj, npr 125 = 12.5v
:global lowvoltalarm 260
:global highvolt
:global lowvolt
:global starttime
:global hivolttime
:global lovolttime
:global vh
:local thisbox [/system identity get name]
:global voltage [/system health get value-name=voltage]
:local thistime [/system clock get time]
:local thisdate [/system clock get date]
:local thishour [:pick $thistime 0 2]
:local emessage ($thisbox . " voltage is " . [:pick $voltage 0 2] . "." . [:pick $voltage 2 3])
:if ([:len $lowvolt] < 1) do={:set lowvolt 999; :set highvolt 0}
# set your email address in the next line
:if ($voltage <= $lowvoltalarm) do={/tool e-mail send to="email na koji cete slati mail" subject="$thisbox low voltage" body=$emessage start-tls=yes}
:if ($voltage > $highvolt) do={:set highvolt $voltage; :set hivolttime ($thistime . " " . $thisdate)}
:if ($voltage < $lowvolt) do={:set lowvolt $voltage; :set lovolttime ($thistime . " " . $thisdate)}
:if ([:len $vh] > 0) do={:set vh ([:toarray $voltage] + $vh)} else={:set vh [:toarray $voltage]}
:if ([:len $starttime] < 1) do={:set starttime ($thistime . " " . $thisdate)}
#ovde obratiti paznju. nekada je skripta pozivala voltreport skriptu ali ovako (:if ($thishour = "23") do={:execute voltreport} ), medjutim pozivanje komandom execute nakon verzije 6.30 vise ne radi ukoliko se naziv skripte ne postavi pod navodnike i zato ih morate dodati u nazivu skripte koju pozivate i to je cela zavrzlama.
:if ($thishour = "23") do={:execute "voltreport"}
#:if ($thishour = "23") znaci da ce u 23h skripta poslati mail sa listom napona u svakom satu. Ukoliko zelite u neko drugo vreme da se salje onda postavite vreme koje vam odgovara.


Nakon toga napravite skriptu voltreport koja ce slati dnevni izvestaj sa listom napona u svakom satu.

/system script add name=voltreport

zatim u nju unestite sledeci kod:
:global highvolt
:global lowvolt
:global hivolttime
:global lovolttime
:global starttime
:global vh
:local tvolt
:local thisbox [/system identity get name]
:local thisdate [/system clock get date]
:local thishour
:local emessage "Daily voltage report for $thisbox on $thisdate\n\n"
:if ([:len $vh] > 0) do={
:for x from=0 to=([:len $vh]-1) step=1 do={
:set tvolt [:tostr [:pick $vh $x]]
:set thishour [:tostr (23 - $x)]
:while ([:len $thishour] < 2) do={:set thishour ("0" . $thishour)}
:set emessage ($emessage . $thishour . ":00 = " . [:pick $tvolt 0 2] . "." . [:pick $tvolt 2 3] . "\n")
}
:set emessage ($emessage . "\nSince voltmonitor started on " . $starttime . "\n")
:set tvolt [:tostr $highvolt]
:set emessage ($emessage . "Maximum = " . [:pick $tvolt 0 2] . "." . [:pick $tvolt 2 3] . "v at " . $hivolttime . "\n")
:set tvolt [:tostr $lowvolt]
:set emessage ($emessage . "Minimum = " . [:pick $tvolt 0 2] . "." . [:pick $tvolt 2 3] . "v at " . $lovolttime . "\n")
# set email address in next line
/tool e-mail send to="mail na koji ce biti poslato" subject="$thisbox Voltage Report" body=$emessage start-tls=yes
}
# remark out the next line for testing to avoid resetting the voltage array
:set vh


Naravno za sve ovo morate imati podesen email. Za slanje sa gmail naloga dodajte sledece:

/tool e-mail
set address=64.233.166.108 from="email sa koga saljete" password="sifra od gmail naloga" port=587 start-tls=yes user="ponovo mail adresa gmail naloga"


Ako smtp server prestane da radi, sto se desava ponekad onda mozete dodati deo skripte koja ce automatski resolvovati smtp server. Dodajte sledece ko dela skripte koja salje mail:

dodate promenljivu na pocetku bilo gde

:local SMTPserver "smtp.gmail.com"

zatim u delu skripte gde saljete mail, npr:
:if ($voltage <= $lowvoltalarm) do={/tool e-mail set address=[:resolve $SMTPserver] send to="email na koji cete slati mail" subject="$thisbox low voltage" body=$emessage start-tls=yes}

I naravno za sve ovo jedan scheduler da pokrece voltmonitor svakih sat vremena:

/system scheduler
add interval=1h name=voltmonitor on-event=voltmonitor policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive start-date=mar/01/2016 start-time=00:00:00

Izvor: http://wiki.mikrotik.com/wiki/...r_input_voltage_on_RB333/433AH.

[Ovu poruku je menjao bmarkovic06 dana 03.03.2016. u 22:54 GMT+1]
 
Odgovor na temu

npero
Vojvodina

Član broj: 8831
Poruke: 307
*.uns.ac.rs.

Sajt: www.bajmok.org


+10 Profil

icon Re: Skripta za proveru napona na routerboardu i slanje izvestaja mailom04.03.2016. u 09:24 - pre 49 meseci
Citat:
bmarkovic06
/tool e-mail
set address=64.233.166.108 from="email sa koga saljete" password="sifra od gmail naloga" port=587 start-tls=yes user="ponovo mail adresa gmail naloga"


Od neke verzije za address prihvata i host name tako da slobodno smtp.gmail.com umesto adrese i ovaj deo address=[:resolve $SMTPserver] moze da se izbaci naravno konfigurisan DNS na ruteru, tako da u skripti moze da ostane samo ova sintaksa

/tool e-mail send [email protected] subject="xxx" body="xxxx";


Ja bi obe skripte skupio u jednu i napravio samo da salje upozorenje kada je nestalo napajanje padne napon ispod definisane granice i upozorenje kada padne blizu kriticne za iskljucenje baterija, takodje kada se vrati napajanje posmatranje sadasnjeg i prethodnog stanja odnoso promene napona.


Nadzor baterija kome treba obicno za solarna resenja bi radije odradio citajuci preko api to sigurno radi posto imam uradjeno ili preko SNMP ne znam da li ima oid nisam gledao, dobro je preko mail ali meni ne prakticno za neke analize bolje citati periodicno preko api i stavljati u bazu posle je lakse raditi sa podacima.

Primer iz baze:


http://i.imgur.com/UTHTiAR.png
 
Odgovor na temu

bmarkovic06

Član broj: 301412
Poruke: 688



+61 Profil

icon Re: Skripta za proveru napona na routerboardu i slanje izvestaja mailom04.03.2016. u 10:22 - pre 49 meseci
Da prihvata, ali meni nekada iz nekog nepoznatog razloga i na 6.33+ zna umesto smtp.gmail.com posle odredjenog vremena da ostavi samo IP adresu. Mada za pptp kada se kacim preko dns-a to radi bez problema.


Meni je dojava na mail dosta prakticnija jer sam stalno u pokretu. Ovako znam kada je napon pao i odmah dobijem notifikaciju. Ukoliko je to posle 18h onda mi ne gine da na lokaciju nosim neki veci akumulator jer eps-ovci problem nece resiti do sutra u 12. To za par lokacija samo, negde gde ima manje uredjaja sa kombinacijom 2x9Ah baterije drze i po 14-15h.

Ima i skripta koja javlja kada napon padne ispod odredjene granice i kada napon predje odredjenu granicu.


Code:


# Low Voltage script

:global VoltageStatus

:local VoltageLimitLow 255  <----dojava kada napon padne ispod ove granice

:local VoltageLimitHigh 260 <----dojava kada se napon vrati, odnosno predje ovu granicu

:local myemail "[email protected]"

:local SMTPserver "smtp.gmail.com"

 

# define Variables

:local VoltageNow

:local mysubject

:local s

 

:set VoltageNow (:tonum [/system health get voltage])

#:log info $VoltageNow

 

:if ([:typeof $VoltageStatus] = "nothing") do={

  :if ($VoltageNow < $VoltageLimitLow) do={

      :set VoltageStatus "BAD" 

      :set mysubject ([/system identity get name]." Voltage is ".$VoltageNow)

      /tool e-mail set address=[:resolve $SMTPserver]

      :foreach s in=[:toarray $myemail] do={

           /tool e-mail send to=$s subject=$mysubject}

   } else={

       :if ($VoltageNow > $VoltageLimitHigh) do={

           :set VoltageStatus "OK"}

   }

} else={ 

   :if ($VoltageNow < $VoltageLimitLow and $VoltageStatus="OK") do={

     :set VoltageStatus "BAD" 

     :set mysubject ([/system identity get name]." Voltage is ".$VoltageNow)

     /tool e-mail set address=[:resolve $SMTPserver]

     :foreach s in=[:toarray $myemail] do={

         /tool e-mail send to=$s subject=$mysubject }}

   :if ($VoltageNow > $VoltageLimitHigh and $VoltageStatus="BAD") do={

     :set VoltageStatus "OK" 

     :set mysubject ([/system identity get name]." Voltage is ".$VoltageNow)

     /tool e-mail set address=[:resolve $SMTPserver]

     :foreach s in=[:toarray $myemail] do={

             /tool e-mail send to=$s subject=$mysubject }}

}

#:log info "end"
 
Odgovor na temu

npero
Vojvodina

Član broj: 8831
Poruke: 307
*.uns.ac.rs.

Sajt: www.bajmok.org


+10 Profil

icon Re: Skripta za proveru napona na routerboardu i slanje izvestaja mailom04.03.2016. u 10:41 - pre 49 meseci
Citat:
bmarkovic06: Da prihvata, ali meni nekada iz nekog nepoznatog razloga i na 6.33+ zna umesto smtp.gmail.com posle odredjenog vremena da ostavi samo IP adresu. Mada za pptp kada se kacim preko dns-a to radi bez problema.

Meni je dojava na mail dosta prakticnija jer sam stalno u pokretu. Ovako znam kada je napon pao i odmah dobijem notifikaciju. Ukoliko je to posle 18h onda mi ne gine da na lokaciju nosim neki veci akumulator jer eps-ovci problem nece resiti do sutra u 12.


Nisam primetio obicno resolvuje nije pravio problem za sada tj. stoji mi vec par meseci host name.

Da dojava obavezno na mail, gde je kriticno i na SMS, ali ona statistika sto se salje jednom dnevno po meni mnogo bolje u bazu laksi pregled, analiza i sta vec padne na pamet.


U svakom slucaju za napajanje iz baterija treba ovako nesto da bi moglo da se analizira duzina trajanja baterija tj. proceni vek trajanja, zamene ukoliko nece da menja u nekim intervalima bez obzira na trajanje, nego na stanje.
 
Odgovor na temu

bmarkovic06

Član broj: 301412
Poruke: 688



+61 Profil

icon Re: Skripta za proveru napona na routerboardu i slanje izvestaja mailom04.03.2016. u 18:36 - pre 49 meseci
Meni statistika treba zbog elektricara. Da im pokazem koliko im je reakcija brza :). A baterije bi trebalo menjati svakih 30 meseci max. Ja nabavljam CSB i one su mi se pokazale kao najbolje. Mada ni everexceed nisu lose, jedino sto brzo jedna od baterija pobrljavi.
 
Odgovor na temu

alekksandar
Aleksandar Stojanovic
sys admin, Dream AG
Aleksinac

Član broj: 305757
Poruke: 196
37.220.74.*

Sajt: www.dream-bay.com


+18 Profil

icon Re: Skripta za proveru napona na routerboardu i slanje izvestaja mailom05.03.2016. u 05:31 - pre 49 meseci
Probaj sa MHB ja ih trosim vec par godina, nema problema nikakvih
I to od 28Ah, iskreno bas su se pokazale.
Ponavljanje je majka ucenja
 
Odgovor na temu

bmarkovic06

Član broj: 301412
Poruke: 688



+61 Profil

icon Re: Skripta za proveru napona na routerboardu i slanje izvestaja mailom05.03.2016. u 08:24 - pre 49 meseci
Meni se CSB najbolje pokazao. Jesu skuplje skoro pa duplo ali vrede svaku paru.

Uh pa mnogo mi za pubjac 28A. Sta koristis od punjaca? Ja uzimam one MeanWell 155B, 100B i 65B. To su DC punjaci sa UPS funkcijom. 155B puni svega 0.5A na 24V, dok na izlaz daje 24V 5A za potrosace.


Edit: inace imam 2kom MHB 18Ah. Radile ko lude dok ih nisam poneo na Drinsku regatu prolse godine pa su plovile u vodi 7-8h :D.
 
Odgovor na temu

alekksandar
Aleksandar Stojanovic
sys admin, Dream AG
Aleksinac

Član broj: 305757
Poruke: 196
37.220.74.*

Sajt: www.dream-bay.com


+18 Profil

icon Re: Skripta za proveru napona na routerboardu i slanje izvestaja mailom06.03.2016. u 05:05 - pre 49 meseci
Iste punjace koristim, nema veze sto je 0.5 A samo ga duze puni, sto je svakako dobro. Ne valja samo ako cesto nema struje pa baterije ne stignu da se napune do kraja, mada se to retko desi.
Ponavljanje je majka ucenja
 
Odgovor na temu

bmarkovic06

Član broj: 301412
Poruke: 688



+61 Profil

icon Re: Skripta za proveru napona na routerboardu i slanje izvestaja mailom06.03.2016. u 15:01 - pre 49 meseci
Pa mojom matematikom ako imas 2x28A baterije u redu povezane, treba ti oko 60h da se napuni do kraja :). To mu dodje skoro 3 dana da mora imati konstatno struje na lokaciji. Nije problem za standardne nestanke nego za zimski period kada nestane struje po nekoliko puta u nedelji na po par desetina sati.

Samo ove godine u januaru sam imao 5-6 nestanaka koji su bili duzi od 2 dana :).


Inace, ima jedno jako dobro resenje od ENEL-a. Punjac akumulatora i UPS, 24-48V (ne moze da se bira nego ili 24 ili 48V uredjaj), 250W izlazne snage i punjac koji puni 3A/h do 100A za baterije. Idealna stvar za 2x100A 24V ili 4x100A za 48V. Ceo sistem sa 2x65A baterije kostao je nekih 450eur koliko se secam. Ukoliko nadjem specifikaciju okacicu ovde. Sistem jeste skup ali je jako pouzdan. Ima gomilu nekih zastita od svega i svacega a pruza odlicnu autonomiju.
 
Odgovor na temu

alekksandar
Aleksandar Stojanovic
sys admin, Dream AG
Aleksinac

Član broj: 305757
Poruke: 196
37.220.74.*

Sajt: www.dream-bay.com


+18 Profil

icon Re: Skripta za proveru napona na routerboardu i slanje izvestaja mailom07.03.2016. u 05:58 - pre 49 meseci
Bas toliko duge nestanke nemam, bude po par sati, nekad i 6 sati, ali vise od toga ne, tako da mi savrseno zavrsavaju posao i pune se bez problema.
Ponavljanje je majka ucenja
 
Odgovor na temu

bmarkovic06

Član broj: 301412
Poruke: 688



+61 Profil

icon Re: Skripta za proveru napona na routerboardu i slanje izvestaja mailom07.03.2016. u 09:08 - pre 49 meseci
Pa nemam ni ja u gradu i blizu puta :). Nego kod mene je malo specifican kraj. Stara sela su napustena, eps ne zeli da zbog 2 kuce menja kompletan kabl (nekoliko kilometara) pa je sam vod do mnogih izdvojenih tacaka u uzasnom stanju. Na dobrom delu puta nema bandera nego koriste drvece pa u njih navrnu nosace kablova :). Padne sneg, padne drvo i nema struje :D.
 
Odgovor na temu

vinted

Član broj: 320599
Poruke: 596

Sajt: https://sigurnostnamrezi...


+53 Profil

icon Re: Skripta za proveru napona na routerboardu i slanje izvestaja mailom07.03.2016. u 10:11 - pre 49 meseci
Citat:
bmarkovic06: Pa nemam ni ja u gradu i blizu puta :). Nego kod mene je malo specifican kraj. Stara sela su napustena, eps ne zeli da zbog 2 kuce menja kompletan kabl (nekoliko kilometara) pa je sam vod do mnogih izdvojenih tacaka u uzasnom stanju. Na dobrom delu puta nema bandera nego koriste drvece pa u njih navrnu nosace kablova :). Padne sneg, padne drvo i nema struje :D.

jeste malo više off topic, ali se nadam da će svi imati razumevanja.
kada pročitam ovako nešto što naš član @bmarkovic06 napisa, samo kažem "**bem ti sistem" da u XXI veku njima (EDB Srbije) bude teško da postave 10 ili ne znam koliko bandera i provuku kablove, makar i za jednu jedinu kuću.
šta da ti kažem druže sem da mi je jako krivo kada pročitam ovakve stvari sa kojima se ljudi susreću.


 
Odgovor na temu

[es] :: Wireless :: Mikrotik :: Skripta za proveru napona na routerboardu i slanje izvestaja mailom

[ Pregleda: 2023 | Odgovora: 11 ] > FB > Twit

Postavi temu Odgovori

Navigacija
Lista poslednjih: 16, 32, 64, 128 poruka.