Navigacija
Lista poslednjih: 16, 32, 64, 128 poruka.

MPLS ne radi sa Totally Stubby OSPF Area-om?

[es] :: Enterprise Networking :: MPLS ne radi sa Totally Stubby OSPF Area-om?

[ Pregleda: 1730 | Odgovora: 4 ] > FB > Twit

Postavi temu Odgovori

Autor

Pretraga teme: Traži
Markiranje Štampanje RSS

dragansar
Sarajevo

Član broj: 84903
Poruke: 612
*.paleol.net.

Sajt: https://nf-tel.com


+22 Profil

icon MPLS ne radi sa Totally Stubby OSPF Area-om?25.05.2012. u 13:00 - pre 143 meseci
Pokusavam da zamjenim EoIP tunele sa VPLS tunelima.Ruteri jesu Mikrotik ali mislim da je pitanje za Enterprise Newtworking, ako admini misle drugacije nek prebace temu :)
Evo priblizna topologija na kojoj mogu da objasnim problem.

Poenta price je da ruter R5 moze da VPLS-om dodje do R2 koji je PPPoE koncetrator i da se konektuje na PPPoE server.
LDP i MPLS su podeseni kako treba i to mi radi bez problema.Ruting protokol je OSPF i on radi bez problema.
Ako je area77 podesena kao "Stub Area" onda mi VPLS sa R5-->R2 radi bez problema i PPPoE konekcije normalno se ostvaruju na R5 i dalje iza njega...i kada uradim traceroute sa R5 na R2 vidim tacno kroz koje labele prodje...tj MPLS usmjerava pakete a ne IP

Ali problem mi se desava kada je area77 "Totally Stubby Area"....sto mi upravo i treba...u tom slucaju kada radim traceroute sa R5 na R2 ne vidim labele (tj predpostavljam da IP preusmjerava pakete) VPLS tunel sa R5-->R2 se podigne (vidim i ruter u Neighbor Listi....sto bi trebalo da znaci da ima neku Layer2 vezu) ali PPPoE ne moze nikako da prodje!
Dali neku ima ideju zasto se desavaju ovo problemi sa Totally Stubby Area-om?
Šaka
 
Odgovor na temu

gogo82

Član broj: 228454
Poruke: 118



+8 Profil

icon Re: MPLS ne radi sa Totally Stubby OSPF Area-om?26.05.2012. u 07:27 - pre 143 meseci
Pozdrav,


nemam nekog iskustva sa Mikrotik-om ali imam sa OSPF Multiarea protokolom.

U vezi tvog problema, prvo sto mi pada na pamet je sljedece:
U Totaly stubby OSPF, u shemi koju si prilozio, u area 77 (koja je totally stubby) nijedan ruter koji se nalazi iza ABR (Area Border Router) tj granicnog rutera regiona, u tvom slucaju ruter R3, ne bi trebalo da imaju pojedinacne rute za prefikse iz drugih Area-a nego se zamjenjuju sa default rutom koju bi trebalo da generise ruter R3.

- Provjeri da li ruter R5 i ostali ruteri u Area 77 imaju default rutu od rutera R3
- Provjeri sa Traceroute da li IP saobracaj sa R5 dolazi na R2 i obrnuto
- Provjeri da li ruter R3 oglasava prefikse iz Area 77 prema ruteru R2


Pozdrav!
Gogo82
 
Odgovor na temu

djk494

Član broj: 494
Poruke: 320
*.dynamic.isp.telekom.rs.



+39 Profil

icon Re: MPLS ne radi sa Totally Stubby OSPF Area-om?26.05.2012. u 12:59 - pre 143 meseci
Zdravo,

Nikad nisam konfigurisao mikrotik niti sam konfigurisao "Totally Stubby Area" u MPLS core-u, tako da mogu samo da teoretski pretpostavim sta je problem.

Pogledaj kako ide mapiranje spoljnjih labela sa default-routom u area 77 (i da li uopste postoji labela, posto ako se dobro secam na Cisco-u moras da ukucas eksplicitno komandu da bi generisao labelu za default route-u).
Ako imas labelu - moja pretpostavka je da posto je njen originator ABR - koji je kod tebe R3, on oglasava implicit null labelu tako da R4 radi PHP i skida spoljnju labelu a R3 radi black holing tog saobracaja.
Po meni bi uvek morao da imas sve looback route na svim router-ima koji ucestvuju u MPLS routiranju (one koji se koriste za spoljnju labelu), bez obzira na area-e, sve ostale mreze mozes da sumarizujes, filtiras, ili routiras preko default rute.


Pozdrav,
Vedran

 
Odgovor na temu

dragansar
Sarajevo

Član broj: 84903
Poruke: 612
89.111.226.*

Sajt: https://nf-tel.com


+22 Profil

icon Re: MPLS ne radi sa Totally Stubby OSPF Area-om?26.05.2012. u 18:44 - pre 143 meseci
@Djaki
Citat:
Nikad nisam konfigurisao mikrotik niti sam konfigurisao "Totally Stubby Area" u MPLS core-u, tako da mogu samo da teoretski pretpostavim sta je problem.

Dobro si predpostavio :)
Citat:
Po meni bi uvek morao da imas sve looback route na svim router-ima koji ucestvuju u MPLS routiranju (one koji se koriste za spoljnju labelu), bez obzira na area-e, sve ostale mreze mozes da sumarizujes, filtiras, ili routiras preko default rute.

Kada je area77 bila "Stub Area" onda je i imao route ka loopback interfejsu R2 koji je LDP transport address i to je radilo u tom slucaju.A ako je area77 "Totally Stubby Area" (sto mi u stvari i treba, posto ruteri u toj area-i idu samo prema jednom izlazu i nema potrebe da imaju rute od bilo cega sto nije u njihovoj area-i) onda je imao samo default rutu do R4
Citat:
Ako imas labelu - moja pretpostavka je da posto je njen originator ABR - koji je kod tebe R3, on oglasava implicit null labelu tako da R4 radi PHP i skida spoljnju labelu a R3 radi black holing tog saobracaja.

Ja mislim da je R3 to upravo i radio
Citat:
Pogledaj kako ide mapiranje spoljnjih labela sa default-routom u area 77 (i da li uopste postoji labela, posto ako se dobro secam na Cisco-u moras da ukucas eksplicitno komandu da bi generisao labelu za default route-u).

Kada sam na R5 i R4 definisao
Code:
mpls ldp set distribute-for-default-route=yes

Onda mi je sve i proradilo kako treba, nadam se da ce i raditi :)

Hvala Vedrane na odgovoru, pomogao si mi!

@gogo82
Hvala i tebi na pomoci, pod sve 3 tacke je odgovor DA, tj OSPF je uvijek i radio kako treba, ali MPLS je imao ove male zackoljice koje mi je Vedran pomogao da rijesim :D
Šaka
 
Odgovor na temu

djk494

Član broj: 494
Poruke: 320
*.dynamic.isp.telekom.rs.



+39 Profil

icon Re: MPLS ne radi sa Totally Stubby OSPF Area-om?27.05.2012. u 13:51 - pre 142 meseci
Super.

 
Odgovor na temu

[es] :: Enterprise Networking :: MPLS ne radi sa Totally Stubby OSPF Area-om?

[ Pregleda: 1730 | Odgovora: 4 ] > FB > Twit

Postavi temu Odgovori

Navigacija
Lista poslednjih: 16, 32, 64, 128 poruka.