Navigacija
Lista poslednjih: 16, 32, 64, 128 poruka.

Toliko o kompatibilnosti, grrr

[es] :: Java :: Toliko o kompatibilnosti, grrr

[ Pregleda: 3398 | Odgovora: 12 ] > FB > Twit

Postavi temu Odgovori

Autor

Pretraga teme: Traži
Markiranje Štampanje RSS

stalker
Branko Kokanovic
Beograd

Član broj: 11897
Poruke: 606
*.rcub.bg.ac.yu



+2 Profil

icon Toliko o kompatibilnosti, grrr03.01.2004. u 20:38 - pre 223 meseci
Napravio sam mali programcic u Javi, proverio ga kuci sa IE5 i radio je. Trebao sam da udjem u jedan obrazovni centar i, posto sam trebao da se predstavim, kazem da sam uradio i programce. Oni se oduseve -Gde je?, a ja, iskusno odgovorim -Na internetu,he,he. -Jao, daj da vidimo, kad ono,prc, ne radi. IE5 - njihov kaze NullPointerException. Sva sreca pa ovo nije bilo presudno. Dodjem ja kuci, ovih dana upicanim program i iz cista mira ne radi ni meni. Probam sa Mozilla-om - radi! ...dok ne kliknem reload, onda ista stvar. Na linux-u - radi. Sad, debagovacu program cim nabavim neki alat (ne znam kako iz notepad-a i prompta to raditi:>, ali me ne zanima to, nego kako je moguce da java radi ovako nesto???
 
Odgovor na temu

alex
Aleksandar Radulovic
Senior Software Engineer, Spotify
Stockholm, Sweden

Član broj: 71
Poruke: 2194
*.du.heimsnet.is

Jabber: alex@a13x.info
ICQ: -1
Sajt: www.a13x.info


+1 Profil

icon Re: Toliko o kompatibilnosti, grrr03.01.2004. u 21:19 - pre 223 meseci
Problem je u tome sto IE5 ne radi refresh apleta - svaki put kada generises novu verziju apleta moras da restartujes IE (zatvoris prozor, otvoris prozor, ucitas aplet stranicu).

To je problem do JVM-a, i postoji jos odavno.

Preporucio bih ti da svo testiranje apleta radis u appletviewer programu (cesto moze vrlo lako da se integrise u IDE) a ne u IE5.

Sto se tice alata za rad, razvoj i debugging, preporucio bih ti Eclipse (http://www.eclipse.org) - stvarno odlican alat.

Pozdrav,
alex.

Alex: My favorite site is http://localhost/
R.J. Oppenheimer: "I am become death, destroyer of worlds" (1945 AD)
tweet.13x ||
linkedin.13x
 
Odgovor na temu

stalker
Branko Kokanovic
Beograd

Član broj: 11897
Poruke: 606
*.rcub.bg.ac.yu



+2 Profil

icon Re: Toliko o kompatibilnosti, grrr03.01.2004. u 22:55 - pre 223 meseci
Zaboravi da kazem, u appletviewer-u sve lepo radi. Program ucitava stvari iz INI fajla, a ja nisam implementirao (citaj: ne znam) kod za obradu gresaka, verovatno je tu greska. Nema veze, to trenutno nije bitno, naci cu je ja, nego me interesuje zasto se ovako bezveze ponasa. Galeon odmah javi gresku, Mozilla radi lepo na Linux-u, na Windows-u koci, rekoh vec...Glupost, kazem ja

BTW, imam JBuilder za Linux, instalirao sam ga, ali nemam serijski broj koji trazi. Pretrazio sam CD, rekose mi da je na njemu, na njemu ni traga. Anyone?
 
Odgovor na temu

alex
Aleksandar Radulovic
Senior Software Engineer, Spotify
Stockholm, Sweden

Član broj: 71
Poruke: 2194
*.du.heimsnet.is

Jabber: alex@a13x.info
ICQ: -1
Sajt: www.a13x.info


+1 Profil

icon Re: Toliko o kompatibilnosti, grrr03.01.2004. u 23:17 - pre 223 meseci
JBuilder je komercijalni program - zabranjeno je na forumima traziti serijske brojeve takvih programa..

Eclipse je sigurno tvoj najbolji izbor..


Alex: My favorite site is http://localhost/
R.J. Oppenheimer: "I am become death, destroyer of worlds" (1945 AD)
tweet.13x ||
linkedin.13x
 
Odgovor na temu

stalker
Branko Kokanovic
Beograd

Član broj: 11897
Poruke: 606
*.rcub.bg.ac.yu



+2 Profil

icon Re: Toliko o kompatibilnosti, grrr04.01.2004. u 12:38 - pre 223 meseci
Oops, ja se izvinjavam
Skinucu Eclipse, radice poslice koji meni trebaju. Hvala
 
Odgovor na temu

stalker
Branko Kokanovic
Beograd

Član broj: 11897
Poruke: 606
*.rcub.bg.ac.yu



+2 Profil

icon Re: Toliko o kompatibilnosti, grrr18.01.2004. u 15:26 - pre 223 meseci
E, sad sam se iznervirao...

Polako, evo od pocetka. Doterao sam program koji sigurno radi. U appletviewer-u RADI. U glupom IE-u NE radi. U Mozilli NE radi. Da li ja mogu da vidim sopstveni program u IE-u. Pitanje: Kako obrisati kes IE-u? Pitanje: Da li Mozilla koristi kes? Pitanje: Ako koristi, kako Mozilli izbrisati kes? Hteo bih da budem 100% siguran da program radi pre nego ga upload-ujem.
 
Odgovor na temu

river
System Architect

Član broj: 12566
Poruke: 62
157.161.141.*



+1 Profil

icon Re: Toliko o kompatibilnosti, grrr18.01.2004. u 23:40 - pre 223 meseci
U jednom postu si rekao da applet cita podatke iz ini fajla. Tu lezi tvoj
problem. Appleti ukoliko nisu potpisani, i ukoliko im u tom slucaju ne
dodelis privilegije ne mogu da citaju sa diska.

Ukoliko zelis da se cita ini fajl moraces da ga postavis na server gde je i
applet i da koristis taj fajl. Ovo medjutim ima nedostatke posto nije
prakticno dozvoljavati svim klijentima (korisnicima koji koriste applet) da
pisu po istom ini fajlu.

Ukoliko zelis jos pomoci postavi stack trace. Koju gresku dobijas?


Everything should be made as simple as possible, but not simpler. - AA
 
Odgovor na temu

stalker
Branko Kokanovic
Beograd

Član broj: 11897
Poruke: 606
*.rcub.bg.ac.yu



+2 Profil

icon Re: Toliko o kompatibilnosti, grrr18.01.2004. u 23:50 - pre 223 meseci
Pazi, ja samo iz njih citam, i to radi - u appletviewer-u doduse. U IE i Mozilli javlja NullPointerException, a posto koristim "notepad" okruzenje, pricekaces sa stack trace-om (dok ne naucim kako se koristi i sta je to)
 
Odgovor na temu

stalker
Branko Kokanovic
Beograd

Član broj: 11897
Poruke: 606
*.drenik.net



+2 Profil

icon Re: Toliko o kompatibilnosti, grrr24.01.2004. u 11:49 - pre 223 meseci
http://home.drenik.net/kokanb/test/vezba1.html
http://home.drenik.net/kokanb/test/vezba2.html
http://home.drenik.net/kokanb/test/vezba3.html
http://home.drenik.net/kokanb/test/vezba4.html

Pogledajte da li ovo radi ako vam nije tesko. Meni u IE i Mozilli ne radi, dok u Linux-u na Mozilli radi. Uzeo sam Eclipse u njemu (tj. u appletviewer-u opet) radi. Stvarno ne znam u kom grmu lezi zec. Poslacu i kod ako hocete, nije mi tesko, ali sad me bas, bas zanima sta je lose
 
Odgovor na temu

dinke
Dragan Dinić
General Manager / Lampix.net
Beograd

Član broj: 933
Poruke: 1008
*.boox.co.yu

Sajt: www.dinke.net


+2 Profil

icon Re: Toliko o kompatibilnosti, grrr18.02.2004. u 15:02 - pre 222 meseci
Sva je prilika da je problem do Java plug-in-a za explorer. Ako se ne varam do verzije 6 IE je imao ugradjen java 1.0 plug-in, sto prakticno znaci da ako tvoji apleti koriste stvari iz novijih verzija Jave (npr. Swing komponente), oni jednostavno nece raditi. Od verzije 6 IE uopste nema Java support, tako da nijedan aplet nece raditi dok user ne downloaduje i instalira odgovarajuci plug-in.

Na tvojoj masini problem ces lako resiti tako sto instaliras jre (www.java.com) ali imaj u vidu da ce klijenti imati probleme. Inace kod mene tvoji apleti rade u IE-u,ali ja naravno imam JRE 1.4.2 plug-in sto kod tebe nije slucaj :)

Pozdrav
Dinke
 
Odgovor na temu

olorin
Bratislav Ljubisic
Beograd

Član broj: 20448
Poruke: 22
*.dial.b92.net

ICQ: 11412608
Sajt: www.fmmedia.co.yu


Profil

icon Re: Toliko o kompatibilnosti, grrr18.02.2004. u 18:48 - pre 222 meseci
I kod mene radi, Mac OS X 10.2.8, Internet Explorer 5.2.3 i Safari 1.0. Sigurno je do jre-a, ie ga nema po defaultu pa ces izgleda morati na download.
 
Odgovor na temu

stalker
Branko Kokanovic
Beograd

Član broj: 11897
Poruke: 606
*.rcub.bg.ac.yu



+2 Profil

icon Re: Toliko o kompatibilnosti, grrr18.02.2004. u 20:58 - pre 222 meseci
Pa dobro ja nemam taj plug, ali to znaci i da ga nema 99% ljudi koji koriste internet, tako da nista od pokazivanja ovog cuda javnosti, tj. kolegama (da li sam dobro shvatio?)
 
Odgovor na temu

dinke
Dragan Dinić
General Manager / Lampix.net
Beograd

Član broj: 933
Poruke: 1008
*.verat.net

Sajt: www.dinke.net


+2 Profil

icon Re: Toliko o kompatibilnosti, grrr18.02.2004. u 21:17 - pre 222 meseci
Nisam siguran da je procenat bas toliko visok, ali sustina je ista. M$ u IE ukljucuje samo support za Javu 1.1 dok je u XP-u Java potpuno izbacena. Resenje je da pravis applet tako da koristis stvari do te verzije. Ovo sto si ti odradio to svakako moze (koriscenjem awt-a a ne swing-a npr). Ako ti je za utehu mislim da je Java potpuno ukljucena u Mac OSX tako da ce cak i Java desktop aplikacije raditi bez problema, sto nije slucaj na ostalim platformama. Uzgred, za ovo za sta si ti koristio aplete, mnogo bolje je koristiti server side scripting (jsp, php ...).

Pozdrav
Dinke



 
Odgovor na temu

[es] :: Java :: Toliko o kompatibilnosti, grrr

[ Pregleda: 3398 | Odgovora: 12 ] > FB > Twit

Postavi temu Odgovori

Navigacija
Lista poslednjih: 16, 32, 64, 128 poruka.