Navigacija
Lista poslednjih: 16, 32, 64, 128 poruka.

dnevni download limit

[es] :: Wireless :: Mikrotik :: dnevni download limit

[ Pregleda: 1900 | Odgovora: 6 ] > FB > Twit

Postavi temu Odgovori

Autor

Pretraga teme: Traži
Markiranje Štampanje RSS

vlcek vladimir
sid

Član broj: 74016
Poruke: 4
*.adsl.eunet.rs.



Profil

icon dnevni download limit27.10.2009. u 12:55 - pre 127 meseci
imam sad namestenu mrezu gde se klijenti kace preko PPPoE

se sad treba da im namestim i dnevni download limit
interesuje me da li moze u postojecoj konfiguraciji sa PPPoE

ili moram nekako drugacije

uglavnom mi treba smernica preko cega to da izvedem
(usere vamo namestis, limit tamo, ip staticka ili dhcp...)

mtik je 2.9

hvala unapred
 
Odgovor na temu

xenox
ex Memodata sysadmin
Beograd

Član broj: 6903
Poruke: 168
195.178.35.*

ICQ: 7682925


+3 Profil

icon Re: dnevni download limit27.10.2009. u 23:29 - pre 127 meseci
Sumnjam da se to samo n MTK moze izvesti... Neki Radius server doprogramiran bi mogao nesto na tom fazonu...
 
Odgovor na temu

Predrag Supurovic
Pedja YT9TP
Užice

Član broj: 157129
Poruke: 5844

Sajt: pedja.supurovic.net


+1385 Profil

icon Re: dnevni download limit28.10.2009. u 00:41 - pre 127 meseci
Ja sma to napravio samo sa Mikrotikom, ali bez pppoe. Pretpostavljam da moze i sa pppoe.

Cak sam napravio i da se mogu podesavati razliciti nivoi korisnika prema cemu se odredjuje brzina i protok.

Imas detaljno uputstvo i skript na http://wireless.uzice.net/uput...k-ogranicenjeprotokaponivoima/
 
Odgovor na temu

vlcek vladimir
sid

Član broj: 74016
Poruke: 4
*.adsl.eunet.rs.



Profil

icon Re: dnevni download limit28.10.2009. u 09:49 - pre 127 meseci
da video sam
zar ne postoji neka mogucnost bez skripti
ipak je ovo mtik kako upste provajderi koji prodaju po kolicini ovo rade

sad protok regulisem preko queue tree
tazdvojio sam port 80 i ostale
dao prioritete i po korisnicima, nemaju ogranicen max protok vec samo prioritete za bandwidth po grupama
kao direktor-high user i radnici-low users

u PPP scret moze da se namesti download i upload limit ali to neradi posao
samo otkaci korisnika resetuje brojac, korisnik se zakaci ponovo i ima jos jednu kvotu

znaci trebao bi da prepravim ovu skriptu da radi na PPP, znaci da cu morati i to da ucim
 
Odgovor na temu

Predrag Supurovic
Pedja YT9TP
Užice

Član broj: 157129
Poruke: 5844

Sajt: pedja.supurovic.net


+1385 Profil

icon Re: dnevni download limit28.10.2009. u 15:08 - pre 127 meseci
Za ozbiljno merenje i ogranicavanje protoka koristi se Radius.
A pre toga se stavi legalan Mikrotik.
 
Odgovor na temu

mravko
Vladimir
NBG

Član broj: 121855
Poruke: 73
*.dynamic.sbb.rs.



Profil

icon Re: dnevni download limit30.10.2009. u 00:18 - pre 127 meseci
Citat:
Predrag Supurovic: Za ozbiljno merenje i ogranicavanje protoka koristi se Radius.
A pre toga se stavi legalan Mikrotik.


Potpis!!

Imam staza sa Mikrotikom , ali sam se slabo pojavljivao ovde..tacnije cituckao sam samo ... Cena licence je toliko smesna da ja nemam reci ... a mogucnosti su prevelike ...
 
Odgovor na temu

vlcek vladimir
sid

Član broj: 74016
Poruke: 4
193.34.64.*



Profil

icon Re: dnevni download limit01.11.2009. u 17:02 - pre 126 meseci
evo napisao sam skriptu
nema smisla da koristim sa radius, ne znam ni da li bi znao da ga namestim
svidela mi se ideja predraga supurovica da se problem resi skriptom

menja profil korisnika u /ppp secret
skripta koristi /ip accounting snapshot listu za racunanje downloada
skripta racuna samo download mada se moze lako prepraviti i da racuna upload
kada korisnik premasi limit prebacuje se sa jednog ppp profila na drugi
nakon restarta skripte skripta sama vraca profile korisnicima koji su bili premasili limit

OVO SU VREDNOSTI KOJE MOZETE MENJATI U ZAVISNOSTI OD VASIH POTREBA

ovde upisujete korisnike koji imaju download limit, to su username iz ppp secret
!!!!!!mora postojati minimum 2 korisnika moze se stavljati i nepostojeci korisnik
:global kor ana,marko,branko,pera.smilja;

ovde upisujete nazive profila
"visoki" je profil sa kojeg se korisnik prebacuje na
"niski" ako premasi download limit
:global Hprofil visoki; :global Lprofil niski;

ovde stavite download limit u bajtima npr 500000000 je 500MB
:global limit 500000000;

ovo su vrednosti za min i max duzinu snapshot liste i postavlja threshold na 1000
duzh i duzl su granice u kojima ce skripta pokusavati da odrzi duzinu snapshot liste
i na osnovu ovih granica menja vreme delay izmedju /ip accounting snapshot take naredbi
ako snapshot lista premasu threshold limit onda postoji saobracaj koji nije accountovan
tj nezna se kojem korisniku da se doda
:global duzh 400; :global duzl 200; :global tres 1000;

ovo su okvirna vremena za pauze izmedju dva snapshot take
vrh je max granica za pauzu
vrl je min granica za pauzu
kas je pocetno vreme za pauzu
pa ako duzina snapshot liste pred vrh ili vrl tada se vrednost kas smanjuje ili povecava za 1 sekundu
:global vrh 10; :global vrl 3; :global kas 6;

ako vas interesuje ko je do sada premasio limit otkucajte :put $apreterali;

testirajte probajte pa ako nesto nevalja da menjam
A EVO I SKRIPTE

{/ip accounting snapshot{
#ovde su definisane promenljive koje se menjaju u zavisnosti od vasih potreba
:global kor ana,marko,branko,pera.smilja;
:global Hprofil visoki; :global Lprofil niski;
:global limit 500000000;
:global duzh 400; :global duzl 200; :global tres 1000;
:global vrh 10; :global vrl 3; :global kas 6;
#sledece promenljive sluze za izvrsavanje skripte i netreba ih menjati
:global dow 10,10;
:global adow 10,10;
:global pretero ovajonaj;
:global prekom [:len $apreterali];
#kad se skripta prekine i ponovo pokrene korisnici koji su bili prebaceni na Lprofil se vracaju na Hprofil
#ali se sada ne diskonektuju tj ne dobijaju novu ip iz Hprofila sve dok se sami ne rekonektuju
:if ($prekom > 2) do={:for s from=0 to=($prekom - 3) do={/ppp secret set [find name [:pick $apreterali ($s + 2)]] profile=$Hprofil};};
:global apreterali neko,neko;
:global brkor [:len $kor]; :for g from=0 to=($brkor - 1) do={:set dow ($dow . 0)};
/ip accounting set threshold $tres;
take;
#ovaj deo skripte se izvrsava beskonacno put sve dok je ne prekinete
:while (true) do=\
{
#provera duzine snapshot niza i na osnovu duzine menja delay vreme do sledeceg snapshot
:set kom [:len [find;]];
:if (($kom > $duzh)||($kom < $duzl)) do=\
{
:if ($kom < $duzl)\
do={:set kas ($kas + 1); :if ($kas > $vrh) do={:set kas $vrh};}\
else={:set kas ($kas - 1); :if ($kas < $vrl) do={:set kas $vrl}; };
};
take; :delay ($kas . s); :set adow 10,10;
#sabira sav download korisnika iz niza kor
:for i from=0 to=($brkor - 1) do=\
{
:set tdow [:pick $dow ($i + 2)];
:foreach j in=[find dst-user [:pick $kor $i]] do=\
{
:set tdow ($tdow + [get $j bytes]);
};
:set adow ($adow . $tdow);
#proverava da li ne neko premasio dozvoljeni limit
:if ($tdow > $limit) do=\
{
/ppp secret
{
:set pretero [find name [:pick $kor $i]];
#proverava da li je taj na visem profilu Hprofil ako jeste onda ga prebacuje na Lprofil i diskonektuje
:if ([get $pretero profile] = $Hprofil) do=\
{
set $pretero profile=($Lprofil); :set apreterali ($apreterali . [:pick $kor $i]);
/ppp active
{
:if ([find name [:pick $kor $i]] = [find name saasdrttio])\
do={:nothing}\
else={remove [find name [:pick $kor $i]]};
};
};
};
};
};
:set dow $adow;
};
}}
Prikačeni fajlovi
 
Odgovor na temu

[es] :: Wireless :: Mikrotik :: dnevni download limit

[ Pregleda: 1900 | Odgovora: 6 ] > FB > Twit

Postavi temu Odgovori

Navigacija
Lista poslednjih: 16, 32, 64, 128 poruka.