Navigacija
Lista poslednjih: 16, 32, 64, 128 poruka.

Brzi Browsing kroz MT

[es] :: Wireless :: Mikrotik :: Brzi Browsing kroz MT

Strane: 1 2

[ Pregleda: 6667 | Odgovora: 29 ] > FB > Twit

Postavi temu Odgovori

Autor

Pretraga teme: Traži
Markiranje Štampanje RSS

nenapop
Nemanja Popovic
Gracanica

Član broj: 41849
Poruke: 12
82.114.66.*



Profil

icon Brzi Browsing kroz MT20.10.2007. u 14:16 - pre 159 meseci
Interesuje me, ima li nacina da userima limitiram samo DOWNlOAD, a da im browsing ide onoliko koliki je bandwith.

Jel ima neka caka???
NEMANJA
 
Odgovor na temu

EmirHozic

Član broj: 158868
Poruke: 520
91.191.37.*



+7 Profil

icon Re: Brzi Browsing kroz MT20.10.2007. u 14:49 - pre 159 meseci
i mene interesuje ista tema, da li je moguce kao na linux routerima odrediti prioritete po protokolima i prioritete po protokolima do odredjene kolicine odataka, npr. ja sad na linux baziranom routeru imam mogucnost da postimam da ako zahte ide prema portu 80 sve sto dodje od njega velicine do 512 kilobajta ide na toliko i toliko posto od dostupne propusnosti a preko 512 router racuna da je download i smanjuje propusnost na puno nizu vrijednost, da li je to moguce odraditi na mikrotiku.
 
Odgovor na temu

Predrag Supurovic
Pedja YT9TP
Užice

Član broj: 157129
Poruke: 5924

Sajt: pedja.supurovic.net


+1439 Profil

icon Re: Brzi Browsing kroz MT20.10.2007. u 20:10 - pre 159 meseci
Tu moze da ti pomogne bursting u ogranicavanju protoka. To je vrlo lepo objasnjeno u uputstvu mikrotika.

 
Odgovor na temu

nenapop
Nemanja Popovic
Gracanica

Član broj: 41849
Poruke: 12
82.114.66.*



Profil

icon Re: Brzi Browsing kroz MT21.10.2007. u 13:35 - pre 159 meseci
Ehh...

Kad bi mogo ovo neko da mi objasni kako valjaaa.... :(:(:(


NEMANJA
 
Odgovor na temu

EmirHozic

Član broj: 158868
Poruke: 520
91.191.37.*



+7 Profil

icon Re: Brzi Browsing kroz MT21.10.2007. u 23:06 - pre 159 meseci
mislim da to nerjesava problem.
Mene konkretno interesuje da ako imam megabit od providera i dijelim ga korisnicima, malko poglupo je nekome ogranicti na 128 ili 256 ako mu mozes dati cijeli megabit kad nikoga drugog nema, e sad na linux baziranim routerima moguce je po src adresi po dest adresi po portu ili protokolu poredati internet promet u nekoliko razreda prioriteta npr torrent na nizi prioritet ali ako nema http-a njemu se da da ide koliko mjesta ima ali kad se pojavi pop3 torrenti usporavaju a pop3 dobija veci prostor ako se u tom momentu pojavi zahtjev na portu 80 npr protok pop3 pada ali i torrenta pada jos nize a http dobija prioritet, e sad posto je i mikrotik linux baziran moralo bi valjda biti moguce to izvesti.
 
Odgovor na temu

Sasha_bn
Aleksandar Kamenjasevic
Bijeljina

Član broj: 144252
Poruke: 224
*.telrad.net.

Sajt: www.scwlan.com


Profil

icon Re: Brzi Browsing kroz MT22.10.2007. u 08:03 - pre 159 meseci
Pa imas prioritete. Mislim da ih nije bilo tesko uociti :D
 
Odgovor na temu

Predrag Supurovic
Pedja YT9TP
Užice

Član broj: 157129
Poruke: 5924

Sajt: pedja.supurovic.net


+1439 Profil

icon Re: Brzi Browsing kroz MT22.10.2007. u 12:57 - pre 159 meseci
Emire, nije u MT nikakav problem rasproediti saobracaj po prioritetima ili raylicito shae'ovatiprotok, ako moyes da raydvojis saobracaj.

Problem je sto korisnik, ako DL-uje preko HTTP, ruter nema nacina da razlikuje da li je to DL datoteke ili otvaranje neke web strane.

Tada se koristi bursting, takoda se kraci DL tretira kao otvaranje web strane i daje mu se veca brzina, a ako DL potraje, onda se brzina ograničava.

 
Odgovor na temu

EmirHozic

Član broj: 158868
Poruke: 520
91.191.37.*



+7 Profil

icon Re: Brzi Browsing kroz MT22.10.2007. u 21:21 - pre 159 meseci
Hvala na usmjeravanju.
Mikrotik mi je nuzno zlo trenutno a jako je tesko dobiti support a mikrotik ovdje kod mene.
 
Odgovor na temu

pospanko80
Marijan Rengel

Član broj: 111781
Poruke: 14
*.adsl.net.t-com.hr.



Profil

icon Re: Brzi Browsing kroz MT23.10.2007. u 00:40 - pre 159 meseci
Code:
/ip firewall mangle add chain=forward protocol=tcp action=mark-connection \
new-connection-mark=konekcija passthrough=yes
/ip firewall mangle add chain=prerouting connection-mark=konekcija protocol=tcp\
connection-bytes=0-500000 action=mark-packet new-packet-mark=tcp_hi passthrough=no
/ip firewall mangle add chain=prerouting connection-mark=konekcija protocol=tcp \
action=mark-packet new-packet-mark=tcp_low passthrough=no


Ovo će ti označiti prvih pola megabajta svake konekcije na tcp protokolu odnosno ostatak konekcije. Dalje radiš sa queue treeom. Ovo je osnovni primjer. Prilagodi ga svojim potrebama. Ovdje se radi da npr. staviš visok prioritet na tcp_hi, a niski na tcp_low pa ako neko skida više od 0,5MB onda mu lijepo uspori, a inaće prvih pola skida jako brzo. Surfanje leti a download stigne... :)

[Ovu poruku je menjao pospanko80 dana 24.10.2007. u 10:49 GMT+1]

[Ovu poruku je menjao pospanko80 dana 24.10.2007. u 10:50 GMT+1]
 
Odgovor na temu

mravko
Vladimir
NBG

Član broj: 121855
Poruke: 73
89.216.196.*



Profil

icon Re: Brzi Browsing kroz MT23.10.2007. u 02:33 - pre 159 meseci
ne vidim sta to toliko mozes u linuxu sto ovde ne mozes...recimo delay pool kod squida koji mene lepo obavlja posao na linuxu...ali burst je jako korisna stvarcica i mislim da to moze da zadovolji sve prohteve... dakle evo prostog objasnjenja bursta..jer vidim da neko nije shvatio...dakle podesis ga tako (ali ima fore oko "proporcije" ) da svi imaju full 120 sec a posle toga ga obara na ... dodas vrednost po vodlji... Stvarcica koja radi i ne zahteva neku mudrost ;)
 
Odgovor na temu

pospanko80
Marijan Rengel

Član broj: 111781
Poruke: 14
*.adsl.net.t-com.hr.



Profil

icon Re: Brzi Browsing kroz MT23.10.2007. u 15:48 - pre 159 meseci
Citat:
mravko: ne vidim sta to toliko mozes u linuxu sto ovde ne mozes...recimo delay pool kod squida koji mene lepo obavlja posao na linuxu...ali burst je jako korisna stvarcica i mislim da to moze da zadovolji sve prohteve... dakle evo prostog objasnjenja bursta..jer vidim da neko nije shvatio...dakle podesis ga tako (ali ima fore oko "proporcije" ) da svi imaju full 120 sec a posle toga ga obara na ... dodas vrednost po vodlji... Stvarcica koja radi i ne zahteva neku mudrost ;)


Khm... Izgleda da ti nisi shvatio što je bursting....
Bursting NE omogućava da daš korsniku 120 sekundi burst brzine, a onda mu skineš na zadanu. U burst-u sekunde označavaju, koliko vremena treba proći, ako je korisnik ispod tresholda da se aktivira burst. A samo trajanje bursta NIJE definirano!!!! Burst traje sve dok se prosječna brzina ne popne iznad praga tresholda.
Toliko o tome.

Moja preporuka, kreni odmah sa mangle+queue tree (teži put iako je jednostavno postaviti osnovno. Ima tonu primjera na netu), i kasnije češ moći puno više toga isprofilirati i posložiti.

Svaka čast simple queue-ovima, ali ali do mangel+queue tree nema ni iz daleka.
 
Odgovor na temu

Kolins Balaban
Kolins Balaban
Srednja bosna

Član broj: 4847
Poruke: 1318
*.team.ba.

ICQ: 166070540


+8 Profil

icon Re: Brzi Browsing kroz MT23.10.2007. u 17:30 - pre 159 meseci
i mene zanima ovako nesto. znaci, kad korisnik koristi maximalnu brzinu nekih 60 sec (to bi trebalo znaciti da nesto downloaduje), da mu se onda sreze brzina na neku koju ja odredim.

Code:

Dalje radiš sa queue treeom. Ovo je osnovni primjer. Prilagodi ga svojim potrebama. Ovdje se radi da npr. staviš visok prioritet na tcp_hi, a niski na tcp_low pa ako neko skida više od 0,5MB onda mu lijepo uspori, a inaće prvih pola skida jako brzo. Surfanje leti a download stigne... :)


Kako mislis to, daljes radis queue tree-om? probao sam to tvoje ubaciti u tik, i ovaj parametar connection-bytes=0-500000 mi nije aktivan. zasto? kazes da prvih pola mb skida jako brzo?kojom brzinom? na koju brzinu mu uspori nakon tih pola mb? to je ono sto me zanima.pozz

MyCoNfa:
CPU: AMD Phenom II X4 965 3,4GHz BOX
Maticna:Asus M4A89GTD PRO
RAM: Corsair 4x2GB 1600MHz, 9-9-9-24
Grafa: Diamond ATI 5870 1GB
HDD:3xWD 320GB AAKS, stripe raid
DVD/RW:LG,SATA
SilverStone SST-ST50F 500W
CoolerMaster CM690
LG 24" 2453TQ-PF
Tastatura A4Tech X7 G800
Stakor: A4Tech X7-755FS
 
Odgovor na temu

tox!e
NS

Član broj: 20007
Poruke: 268
*.eunet.yu.

ICQ: 267386221


+3 Profil

icon Re: Brzi Browsing kroz MT23.10.2007. u 19:02 - pre 159 meseci
A sto jednostavno ne uradite markiranje paketa za web pomocu content filtera.Tamo stavite deo http koda, zatim queue i to je to.
 
Odgovor na temu

Kolins Balaban
Kolins Balaban
Srednja bosna

Član broj: 4847
Poruke: 1318
*.team.ba.

ICQ: 166070540


+8 Profil

icon Re: Brzi Browsing kroz MT24.10.2007. u 19:28 - pre 159 meseci
ovako, cackao sam po tikovom forumu, ne bi li nasao odgovor na svoje pitanje, i nasao sam ovaj post:
http://forum.mikrotik.com/viewtopic.php?f=2&t=12870
Koliko sam shvatio, to je ono sto meni treba, ali nazalost, ne mogu to da primjenim u praksi :( ne znam sta predstavlja "Public" u ovoj komandi:
Code:

/queue tree add name="Main_Upload" parent=Public packet-mark="" limit-at=0 queue=default priority=8 max-limit=5000000 burst-limit=0 burst-threshold=0 burst-time=0s disabled=no

pa ako neko moze da pomogne, bio bih jako zahvalan. pozz
MyCoNfa:
CPU: AMD Phenom II X4 965 3,4GHz BOX
Maticna:Asus M4A89GTD PRO
RAM: Corsair 4x2GB 1600MHz, 9-9-9-24
Grafa: Diamond ATI 5870 1GB
HDD:3xWD 320GB AAKS, stripe raid
DVD/RW:LG,SATA
SilverStone SST-ST50F 500W
CoolerMaster CM690
LG 24" 2453TQ-PF
Tastatura A4Tech X7 G800
Stakor: A4Tech X7-755FS
 
Odgovor na temu

pospanko80
Marijan Rengel

Član broj: 111781
Poruke: 14
*.adsl.net.t-com.hr.



Profil

icon Re: Brzi Browsing kroz MT24.10.2007. u 23:06 - pre 159 meseci
Public ti je izlazni interface... Znaći pppoe konekcija prema provideru ili nešto slično...
 
Odgovor na temu

pospanko80
Marijan Rengel

Član broj: 111781
Poruke: 14
*.adsl.net.t-com.hr.



Profil

icon Re: Brzi Browsing kroz MT24.10.2007. u 23:13 - pre 159 meseci
Citat:
Kako mislis to, daljes radis queue tree-om? probao sam to tvoje ubaciti u tik, i ovaj parametar connection-bytes=0-500000 mi nije aktivan. zasto? kazes da prvih pola mb skida jako brzo?kojom brzinom? na koju brzinu mu uspori nakon tih pola mb? to je ono sto me zanima.pozz


Ja imam link 5M/512k. Ovo ti je osnovna konfiguracija. Ali je dobro za početak...
I connection-bytes ti je bio siv jer sam zaboravio staviti protocol=tcp u primjeru. Sad je ispravljeno. Dodaj samo protocol=tcp

/queue tree
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
max-limit=4500000 name="DL" packet-mark="" parent=link:ap priority=8 \
queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=3000000 \
max-limit=4500000 name="DL_500k" packet-mark=tcp_hi parent=DL \
priority=1 queue=PCQ_DL
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=1000000 \
max-limit=2000000 name="DL_Ostalo" packet-mark=tcp_low parent=DL \
priority=2 queue=PCQ_DL
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
max-limit=450000 name="UL" packet-mark="" parent=pppoe-out1 priority=8 \
queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=300000 \
max-limit=400000 name="UL_512k" packet-mark=tcp_hi parent=UL \
priority=5 queue=PCQ_UL
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=100000 \
max-limit=150000 name="UL_Ostalo" packet-mark=tcp_low parent=UL \
priority=7 queue=PCQ_UL

/queue type
add kind=pcq name="PCQ_UL" pcq-classifier=src-address pcq-limit=50 pcq-rate=0 \
pcq-total-limit=2000
add kind=pcq name="PCQ_DL" pcq-classifier=dst-address pcq-limit=50 pcq-rate=0 \
pcq-total-limit=2000

[Ovu poruku je menjao pospanko80 dana 25.10.2007. u 15:22 GMT+1]
 
Odgovor na temu

Kolins Balaban
Kolins Balaban
Srednja bosna

Član broj: 4847
Poruke: 1318
*.team.ba.

ICQ: 166070540


+8 Profil

icon Re: Brzi Browsing kroz MT25.10.2007. u 13:58 - pre 159 meseci
opet ja :( valjda nisam toliko dosadan. ne znam sta je, ali ova pravila za markiranje novih konekcija, novih i starih paketa nece da mi rade (broj bajta i paketa stoji na nuli):( uradio sam sve po uputstvu, ali nece pa nece. sta bi moglo biti? pravila su na tren su proradila, i opet stala :( je li bitan raspored ovih pravila? koliko ja mogu skontat, ne bi trebao biti. kod mene je prvo markiranje novih konekcija, pa markiranje novih paketa, i na kraju markiranje starih paketa.

[Ovu poruku je menjao Kolins Balaban dana 25.10.2007. u 15:18 GMT+1]
MyCoNfa:
CPU: AMD Phenom II X4 965 3,4GHz BOX
Maticna:Asus M4A89GTD PRO
RAM: Corsair 4x2GB 1600MHz, 9-9-9-24
Grafa: Diamond ATI 5870 1GB
HDD:3xWD 320GB AAKS, stripe raid
DVD/RW:LG,SATA
SilverStone SST-ST50F 500W
CoolerMaster CM690
LG 24" 2453TQ-PF
Tastatura A4Tech X7 G800
Stakor: A4Tech X7-755FS
 
Odgovor na temu

pospanko80
Marijan Rengel

Član broj: 111781
Poruke: 14
*.adsl.net.t-com.hr.



Profil

icon Re: Brzi Browsing kroz MT25.10.2007. u 14:24 - pre 159 meseci
Da li ti je /ip firewall connection tracking uključen?
 
Odgovor na temu

Kolins Balaban
Kolins Balaban
Srednja bosna

Član broj: 4847
Poruke: 1318
*.team.ba.

ICQ: 166070540


+8 Profil

icon Re: Brzi Browsing kroz MT25.10.2007. u 16:51 - pre 159 meseci
da, ukljucen je tracking ;) nego, da li ovaj public treba da budes bas pppoe konekcija ka provideru, ili ethernet karta na kojoj je ta pppoe konekcija?
MyCoNfa:
CPU: AMD Phenom II X4 965 3,4GHz BOX
Maticna:Asus M4A89GTD PRO
RAM: Corsair 4x2GB 1600MHz, 9-9-9-24
Grafa: Diamond ATI 5870 1GB
HDD:3xWD 320GB AAKS, stripe raid
DVD/RW:LG,SATA
SilverStone SST-ST50F 500W
CoolerMaster CM690
LG 24" 2453TQ-PF
Tastatura A4Tech X7 G800
Stakor: A4Tech X7-755FS
 
Odgovor na temu

Sasha_bn
Aleksandar Kamenjasevic
Bijeljina

Član broj: 144252
Poruke: 224
*.telrad.net.

Sajt: www.scwlan.com


Profil

icon Re: Brzi Browsing kroz MT25.10.2007. u 17:35 - pre 159 meseci
Naravno da je pppoe. ppp pravi virtualne interface i gateway-e. Tako da je tebi izlazni interface pppoe.

Mada na to markiranje ja bi dodao jos ovo connection-state=new.

Po vasim pravilima to ce samo da radi prvih pola mb ukupnog saobracaja tj od trenutka dodavanja marka. A ovo ce da vazi za svaki novi klik tj svako novo uspostavljanje veze.
Pozdrav
 
Odgovor na temu

[es] :: Wireless :: Mikrotik :: Brzi Browsing kroz MT

Strane: 1 2

[ Pregleda: 6667 | Odgovora: 29 ] > FB > Twit

Postavi temu Odgovori

Navigacija
Lista poslednjih: 16, 32, 64, 128 poruka.