Navigacija
Lista poslednjih: 16, 32, 64, 128 poruka.

traffic shaping za PPPoE usere

[es] :: Wireless :: Mikrotik :: traffic shaping za PPPoE usere

Strane: 1 2

[ Pregleda: 6099 | Odgovora: 20 ] > FB > Twit

Postavi temu Odgovori

Autor

Pretraga teme: Traži
Markiranje Štampanje RSS

dr_ambis
Uzice

Član broj: 36362
Poruke: 221
77.46.253.*



Profil

icon traffic shaping za PPPoE usere03.05.2007. u 20:41 - pre 176 meseci
Imam PPPoE server na mikrotiku i imam dva profila. Jedan je ogranicen na 30k/70k (A) a drugi(B) je bez ogranicenja protoka i ima nas trojica koji koristimo internet.Jedan na A a druga dva na B.

E sad, kad se korisnik A zakaci protok koji preostaje je manji za 30k/70k.

Zanima me kako da namestim queues da kada smo sva trojica ovom A ostaje koliko pise a da mi B delimo ostatak na dva jednaka dela, tj kad je jedan iz B zakacen da vuce ostatak a kad se obojica zakacimo da onda deli na dva dela?

Poedesavao sam queues tako da sve radi lepo dok su korisnici zakaceni, posto kad se neko zakaci pojavi se lepo taj interface( npr <pppoe-jovan>) i za taj interface radim queues, ali cim se korisnik otkaci interface u queues se postavi na all tako da kad se zakaci ovaj pod A onda on ima protok veci od 30k/70k.

Verujem da malo upuceniji znaju o cemu pricam.
Imam MT 2.9.27 level 6.

Postoji li neki elegantan nacin da se ovo na MT-u resi.

neceg novog se ne treba plasiti, treba ga razumeti
 
Odgovor na temu

dr_ambis
Uzice

Član broj: 36362
Poruke: 221
77.46.253.*



Profil

icon Re: traffic shaping za PPPoE usere03.05.2007. u 22:12 - pre 176 meseci
Evo, sam pitah sam i odgovorih.

Za svkog usera sa sam stavio posebnu remote adresu u secrets i po toj adresi radim shaping.

Ako neko zna neki drugi nacin za ovo sta ja hocu neka javi.

neceg novog se ne treba plasiti, treba ga razumeti
 
Odgovor na temu

Odmetnik
SRBIJA

Član broj: 131710
Poruke: 160
195.252.117.*



Profil

icon Re: traffic shaping za PPPoE usere04.05.2007. u 10:34 - pre 176 meseci
Ne znam da li cu ti pomoci ako ti kazem da Mtik u verzijama do 2.9.27 ima problem sa shapingom, meni se dogadjalo da kad dodam neko novo pravilo jednom useru on pokrece kontrolu tog poslednjeg pravila a gasi prethodno. Veliki problem Mtika! To sto si ti uradio je dobro, samo kad hoces da kontrolises usera po jos jednom pravilu nastaju problemi. Ja licno mislim da je do verzije,mozda i gresim. Voleo bi da me neko ispravi ako nije tako. Ako je greska u postavljanju pravila.
 
Odgovor na temu

dr_ambis
Uzice

Član broj: 36362
Poruke: 221
77.46.253.*



Profil

icon Re: traffic shaping za PPPoE usere04.05.2007. u 12:53 - pre 176 meseci
Ma radi ovo meni, nego kad jedan vuce sav protok i u tom trenutku se na internet nakaci drugi onda mu treba citav minut da ovom prvom obori protok na pola.

Ja bi ako moze nesto trenutno da se desava ( za oko 10 sekundi najvise).



neceg novog se ne treba plasiti, treba ga razumeti
 
Odgovor na temu

Odmetnik
SRBIJA

Član broj: 131710
Poruke: 160
77.46.178.*



Profil

icon Re: traffic shaping za PPPoE usere05.05.2007. u 23:56 - pre 176 meseci
Pa sad, ne mogu ti 100% pomoci ali te mogu usmeriti na Mtikov BURST limit p/s pa da pokusas tu malo da se pozabavis. On bi trebalo da resi tvoj prb. po mom skromnom misljenju. Ja sad nemam mogucnost za experimentisanje,ali bi ta opcija trebalo da daje pravilo koje tebi treba!
pozz
 
Odgovor na temu

Odmetnik
SRBIJA

Član broj: 131710
Poruke: 160
77.46.178.*



Profil

icon Re: traffic shaping za PPPoE usere06.05.2007. u 13:18 - pre 176 meseci
Pokusaj
Max limit: 128K upload/256K download
Burst limit: 256K/512K
Burst Threshold: 128K/256K
Burst Time: 10s/10s

Burst ti je uvecanje brzine po sekundama.
 
Odgovor na temu

broker

Član broj: 2415
Poruke: 8514
77.46.254.*



+11 Profil

icon Re: traffic shaping za PPPoE usere06.05.2007. u 22:44 - pre 176 meseci
Ovo podesavanje za burst nije dobro. Burst-treshold treba da bude manje od max-limit i to po pravilu mnogo manje.
 
Odgovor na temu

sojic
Dalibor Sojic
Makedonija

Član broj: 7051
Poruke: 796
62.162.224.*

Sajt: right-sock.net


+1 Profil

icon Re: traffic shaping za PPPoE usere07.05.2007. u 16:00 - pre 176 meseci
I meni treba ovakvo nesto.

Shvatio sam da trebam stelovati mangle i queue ali iskreno da kazem, NEMAM BLAGE VEZE o cemu se radi.

Vise-manje sam podesio sve sto mi treba jos ogranicenje i limitiranja nisam.

@dr_ambis Ako moze da pises kako si ti resio ovo (makar privremeno resenje).
routing protocols enable routers to route routed protocols!
 
Odgovor na temu

Odmetnik
SRBIJA

Član broj: 131710
Poruke: 160
77.46.176.*



Profil

icon Re: traffic shaping za PPPoE usere07.05.2007. u 17:17 - pre 176 meseci
Jeste verovartno treba. Ja sam ovo naveo kao primer nisam isprobao kako se ponasa. Jednostavno sam procitao uputstvo i po njemu odgovorio!

A sto se prikazivanja shapinga tice imao sam broker situaciju da kod dodavanja jos jednog pravila istom useru, recimo kontrola protoka p2p ili http paketa ili bilo koje drugo pravilo koje sam mu pridodao pod recimo prioritet 1 prioritet 2 ... automatski je zaustavljao predhodno prikazivanje. Veoma mi je cudno to ponasanje.
Kod tebe je druga situacija koliko se secam vezani su ti korisnici direktno preko lana?
 
Odgovor na temu

dr_ambis
Uzice

Član broj: 36362
Poruke: 221
77.46.253.*



Profil

icon Re: traffic shaping za PPPoE usere07.05.2007. u 23:29 - pre 176 meseci
Sojicu

Nisam jos resio ovo da se trenutno odaziva, i dalje je od minut do dva dok se raspodeli kako treba.

Ali radim na tome, tj probam sve moguce kombinacije uz konsultovanje manuala naravno.

neceg novog se ne treba plasiti, treba ga razumeti
 
Odgovor na temu

dr_ambis
Uzice

Član broj: 36362
Poruke: 221
77.46.253.*



Profil

icon Re: traffic shaping za PPPoE usere09.05.2007. u 11:20 - pre 176 meseci
Privremeno resenje je ovo kao sto odmetnik rece sa burst time 2s, vreme deljenja se skratilo, sad je oko 30 sekundi.

Namestam dalje, cim namestim kako treba javljam naravno.


Skoro sam krenuo u rat sa MT-om ali nabudzicu ja to da radi kako ja hocu.

neceg novog se ne treba plasiti, treba ga razumeti
 
Odgovor na temu

sojic
Dalibor Sojic
Makedonija

Član broj: 7051
Poruke: 796
62.162.226.*

Sajt: right-sock.net


+1 Profil

icon Re: traffic shaping za PPPoE usere09.05.2007. u 13:57 - pre 176 meseci
Ne znam dali ce ovo pomoci:

http://wiki.mikrotik.com/wiki/...erading_and_Internal_Web-Proxy
routing protocols enable routers to route routed protocols!
 
Odgovor na temu

dr_ambis
Uzice

Član broj: 36362
Poruke: 221
77.46.253.*



Profil

icon Re: traffic shaping za PPPoE usere09.05.2007. u 18:42 - pre 176 meseci
Ma ne treba mi proxy nego sad procitah manual i evo odlomka:

This example shows how to equally share 10Mibps download and 2Mibps upload among active
users in the network 192.168.0.0/24. If Host A is downloading 2 Mibps, Host B gets 8 Mibps and
vice versa. There might be situations when both hosts want to use maximum bandwidth (10 Mibps),
then they will receive 5 Mibps each, the same goes for upload. This setup is also valid for more than
2 users.
At first, mark all traffic, coming from local network 192.168.0.0/24 with a mark users:
/ip firewall mangle add chain=forward src-address=192.168.0.0/24 \
action=mark-connection new-connection-mark=users-con
/ip firewall mangle add connection-mark=users-con action=mark-packet \
new-packet-mark=users chain=forward
Now we will add 2 new PCQ types. The first, called pcq-download will group all traffic by
destination address. As we will attach this queue type to the Local interface, it will create a
dynamic queue for each destination address (user) which is downloading to the network
192.168.0.0/24. The second type, called pcq-upload will group the traffic by source address. We
will attach this queue to the Public interface so it will make one dynamic queue for each user who
is uploading to Internet from the local network 192.168.0.0/24.
/queue type add name=pcq-download kind=pcq pcq-classifier=dst-address
/queue type add name=pcq-upload kind=pcq pcq-classifier=src-address
Finally, make a queue tree for download traffic:
/queue tree add name=Download parent=Local max-limit=10240000
/queue tree add parent=Download queue=pcq-download packet-mark=users
And for upload traffic:
/queue tree add name=Upload parent=Public max-limit=2048000
/queue tree add parent=Upload queue=pcq-upload packet-mark=users
Note! If your ISP cannot guarantee you a fixed amount of traffic, you can use just one queue for
upload and one for download, attached directly to the interface:
/queue tree add parent=Local queue=pcq-download packet-mark=users
/queue tree add parent=Public queue=pcq-upload packet-mark=users

idem da probam pa javljam da li je uspelo. Mada nesto mi sumnjivo ovde

neceg novog se ne treba plasiti, treba ga razumeti
 
Odgovor na temu

Sasha_bn
Aleksandar Kamenjasevic
Bijeljina

Član broj: 144252
Poruke: 224
77.239.66.*

Sajt: www.scwlan.com


Profil

icon Re: traffic shaping za PPPoE usere10.05.2007. u 17:05 - pre 176 meseci
Ja sam pre koristio to pravilo.... Medjutim se meni isto pokazalo sporo na 30 racunara od 10 do 30 sekundi.
Pozdrav
 
Odgovor na temu

dr_ambis
Uzice

Član broj: 36362
Poruke: 221
77.46.253.*



Profil

icon Re: traffic shaping za PPPoE usere11.05.2007. u 13:38 - pre 176 meseci
Jos jedna cudna stvar mi se javlja ( ili nije cudna).

Naime koliko god ja ogranico jednog korisnika sa max limit i limit at, kad god drugi surfuju samo a ovaj downloaduje konstantno uvek je u crvenoj zoni tj. protk mu ide preko onog u max limit.

Jel ovo ovako treba ili sta vec?

Drugim korisnicima pocinje da usporava mnogo i treba bas dosta vremena da se stabilizuje sve (preko 5-10 min)

neceg novog se ne treba plasiti, treba ga razumeti
 
Odgovor na temu

Sasha_bn
Aleksandar Kamenjasevic
Bijeljina

Član broj: 144252
Poruke: 224
77.239.69.*

Sajt: www.scwlan.com


Profil

icon Re: traffic shaping za PPPoE usere11.05.2007. u 14:01 - pre 176 meseci
Dovoljno ti je da samo postavis pravilo max limit.
Ja nemam tih problema u jednoj drugoj mrezi imam 15 racunara. Markirao sam konekciju na port 80 i postavio da swakom pojedinacno ogranicavam tu konekciju. Nekada mi preskoci 10-15 k najvishe u trenutku otwaranja stranice i samom pocetku download-a na neki 2-3 sek.
Racunar je :
133 mhz
32 ram.
Poz
 
Odgovor na temu

dr_ambis
Uzice

Član broj: 36362
Poruke: 221
77.46.253.*



Profil

icon Re: traffic shaping za PPPoE usere11.05.2007. u 20:03 - pre 176 meseci
A sta da stavim za limit? Jel mislis da za limit treba da stoji UNLIMITED?

Da li to znaci da on posle ne gleda pravilo za limit?

neceg novog se ne treba plasiti, treba ga razumeti
 
Odgovor na temu

dr_ambis
Uzice

Član broj: 36362
Poruke: 221
77.46.253.*



Profil

icon Re: traffic shaping za PPPoE usere14.05.2007. u 20:44 - pre 175 meseci
Sta god pokusao ne vredi, pokusao sam i sa global-in i global-out, prvo markiram pakete za svakog korisnika pa posle ogranicavam ali isto, opet mu mnogo treba vremena da podeli protok.

Ajmo, mora da neko zna konkretno resenje.

neceg novog se ne treba plasiti, treba ga razumeti
 
Odgovor na temu

sojic
Dalibor Sojic
Makedonija

Član broj: 7051
Poruke: 796
88.85.123.*

Sajt: right-sock.net


+1 Profil

icon Re: traffic shaping za PPPoE usere18.05.2007. u 08:06 - pre 175 meseci
Dali ima teorija ovo da se uradi preko radius servera? Mikrotik ima neki radius server. http://mikrotik/userman

http://wiki.mikrotik.com/wiki/User_Manager
routing protocols enable routers to route routed protocols!
 
Odgovor na temu

Sasha_bn
Aleksandar Kamenjasevic
Bijeljina

Član broj: 144252
Poruke: 224
77.239.66.*

Sajt: www.scwlan.com


Profil

icon Re: traffic shaping za PPPoE usere19.05.2007. u 00:08 - pre 175 meseci
Pa najbolji nacin je da limitiras po useru.
Mt je software-ski router. Procesor od obicnog kompa je predvidjen za vishe operacija, nije za neku profesionalne namene,kao npr sto ciscov procesor je samo za obradu mrezni paketa itd.

Sta da ti kazem nego jednostavno limitiraj svakog posebno i uzivaj.
Postavi max-limit
 
Odgovor na temu

[es] :: Wireless :: Mikrotik :: traffic shaping za PPPoE usere

Strane: 1 2

[ Pregleda: 6099 | Odgovora: 20 ] > FB > Twit

Postavi temu Odgovori

Navigacija
Lista poslednjih: 16, 32, 64, 128 poruka.