Navigacija
Lista poslednjih: 16, 32, 64, 128 poruka.

OpenGl problem, radi za roota, ne za usere

[es] :: Linux desktop okruženja :: OpenGl problem, radi za roota, ne za usere

[ Pregleda: 3033 | Odgovora: 5 ] > FB > Twit

Postavi temu Odgovori

Autor

Pretraga teme: Traži
Markiranje Štampanje RSS

bdusan

Član broj: 8779
Poruke: 26
*.verat.net



Profil

icon OpenGl problem, radi za roota, ne za usere23.04.2003. u 10:43 - pre 206 meseci
Imam Radeon9500, X 4.3.0 i Slack 8.1 i instalirane ATi drajvere za X 4.3.0. Sv je lepo instalirano i sve radi odlicno kada sam ulogovan kao root, znaci glxinfo izbacuje poruku da je ukljucena hardverska podrska za opengl, glxgears vrti one zupcanike, igrice rade odlicno, bez razlika u donosu na win. Ali ako sam ulogovan kao root, od opengla nista, glxinfo mi prijavljuje da koristi softversku akceleraciju, glxgears mi daju manji fps, a igrice se vuku. Cak nece ni Xawtv da mi radi kada sam user.
Evo ukratko sta mi izbaci glxifo
Code:

name of display: :0.0
libGL error: failed to open DRM: Operation not permitted
libGL error: reverting to (slow) indirect rendering
display: :0  screen: 0
direct rendering: No

Slicnu poruku izbacuje i xawtv, libGL error: failed to open DRM:...

Naravno u /etc/x11/XF86Config-4 imam sekciju
Code:

Section "dri"
# Access to OpenGL ICD is allowed for all users:
    Mode 0666


Kako da omogucim i userima da koriste opengl(drm, dri, sta li vec)?
 
Odgovor na temu

random
Vladimir Vrzić
Beograd

Član broj: 85
Poruke: 3866
*.f.bg.ac.yu

Sajt: www.last.fm/user/vrza


+4 Profil

icon Re: OpenGl problem, radi za roota, ne za usere23.04.2003. u 14:36 - pre 206 meseci
# chmod 666 /dev/dri/card0

Ili napravi grupu 'dri', pa dodaj korisnike koji treba da koriste X u nju, pa onda

# chgrp dri /dev/dri/card0
# chmod 660 /dev/dri/card0

U tom slučaju naravno bi trebalo da podesiš i prava pristupa u XF86Config-u adekvatno.
int rand(void);

Those who do not understand Unix are condemned to reinvent it, poorly.

Upali lampicu — koristi Jabber!
 
Odgovor na temu

bdusan

Član broj: 8779
Poruke: 26
*.verat.net



Profil

icon Re: OpenGl problem, radi za roota, ne za usere24.04.2003. u 00:21 - pre 206 meseci
Uradio sam ovo prvo i nema efekta i dalje isto.
Jedino mi nije jasno zasto javlja poruku failed to open DRM... kada nigde u XF86Config-u ne poziva DRM, nigde nema nista slicno. Da li ima veze sto kada sam kompajlirao kernel (2.4.20) stavio podrsku za DRI i DRM 4.1 a ne za old DRM (XFree 4.0)?
 
Odgovor na temu

random
Vladimir Vrzić
Beograd

Član broj: 85
Poruke: 3866
*.f.bg.ac.yu

Sajt: www.last.fm/user/vrza


+4 Profil

icon Re: OpenGl problem, radi za roota, ne za usere24.04.2003. u 14:13 - pre 206 meseci
Pogledaj da li u XF86Config-u, u sekciji "Modules" imaš linije.

Load "dri"
Load "glx"

Ako nemaš, dodaj ih.

Takođe, pogledaj temu #11111
int rand(void);

Those who do not understand Unix are condemned to reinvent it, poorly.

Upali lampicu — koristi Jabber!
 
Odgovor na temu

bdusan

Član broj: 8779
Poruke: 26
*.mobtel.co.yu



Profil

icon Re: OpenGl problem, radi za roota, ne za usere24.04.2003. u 19:54 - pre 206 meseci
Pogledacu ovo kada stignem kuci, mada mislim da ima.

Da li sam mogao nesto da pogresim kada sam instalirao X, instalirao sam iz sourcea, kompajlirao, (make world, make install) i to je bilo to, nije javi nikakvu gresku, nista. Da li ima neki switch da se otkuca uz make ili nesto slicno? Da li je moguce da su drajveri losi, bagoviti? Ili da vratim default X 4.2.0 i da koristim oficijelne ATi drajvere, sa ati.com-a?
Jedino sto je drajver bio RPM, pa je prijavljivao da mi fale neke stvari i onda sam ja znalacki stavio --nodeps i onda se instalirao bez da se zalio na ista :))) Mada mislim da to nema veze posto za roota sve radi.

I jedno pitanje u vezi ovih kernel modula, drm-kmod, posto ih nisam primetio u menuconfig prilikom konfigurisanja kernela. Da li se posebno instaliraju, odakle da ih skinem, sa dri sajta ili negde drugde? Ajde posto nisam neki linux guru, ako moze jos neki hint.


Edit: evo pogledao sam imam obe te stavke. Ajde ako moze objasnjenje oko ovih drm modula.
 
Odgovor na temu

bdusan

Član broj: 8779
Poruke: 26
217.26.67.*



Profil

icon Re: OpenGl problem, radi za roota, ne za usere01.05.2003. u 16:42 - pre 205 meseci
Evo pojavila se nova verzija drajvera za X 4.3.0 ovde http://www.schneider-digital.de/html/body_download_ati.html (ima i za raije verzije Xa) i njih sam instalirao i opet isto, za roota sve rad,i za usere nista. Cak i kada sam u Xu kao user i otvorm dve konzole, jednu kao root, drugu kao user, u onoj gde je root sve radi u onoj gde je user nista.

Da li je neko probao ove drajvere, i da li mu rade kako treba? Ima li neko ideju sta bih mogao da bude problem kod mene, sta da uradim?
 
Odgovor na temu

[es] :: Linux desktop okruženja :: OpenGl problem, radi za roota, ne za usere

[ Pregleda: 3033 | Odgovora: 5 ] > FB > Twit

Postavi temu Odgovori

Navigacija
Lista poslednjih: 16, 32, 64, 128 poruka.