Navigacija
Lista poslednjih: 16, 32, 64, 128 poruka.

Debian, php i gd.so

[es] :: PHP :: Debian, php i gd.so

[ Pregleda: 2564 | Odgovora: 7 ] > FB > Twit

Postavi temu Odgovori

Autor

Pretraga teme: Traži
Markiranje Štampanje RSS

mrki
radnik
Sombor

Član broj: 1050
Poruke: 580
*.129.nat-pool-bgd.sbb.co.yu.

Jabber: mrki@elitesecurity.org
ICQ: 58816584


Profil

icon Debian, php i gd.so26.06.2006. u 00:30 - pre 186 meseci
Ima li neko ovu kombinaciju, ja definitivno ne mogu da ukljucim GD podrsku za php modul ;(

Debian: Sarge

php -v
PHP 4.4.2 (cli) (built: Feb 27 2006 22:44:57)
Copyright (c) 1997-2006 The PHP Group
Zend Engine v1.3.0, Copyright (c) 1998-2004 Zend Technologies

-rw-r--r-- 1 root root 81884 2005-08-25 05:27 gd.so

php.ini:
extension_dir = "/usr/lib/php4/20020429/"
extension=msql.so

Code:

PHP Warning:  Unknown(): Unable to load dynamic library '/usr/lib/php4/20020429/gd.so' 
- /usr/lib/php4/20020429/gd.so: undefined symbol: gdImagePngCtx in Unknown on line 0


Prosto ne mogu da verujem da se moram sa ovi muciti, vec preterano mnogo dana a vreme je novac




Nekad sam bio mlad ;)
 
Odgovor na temu

bojan_bozovic

Član broj: 29028
Poruke: 3292
*.pat-pool.le.sbb.co.yu.

Sajt: angelstudio.org


+392 Profil

icon Re: Debian, php i gd.so26.06.2006. u 00:53 - pre 186 meseci
BTW nije msql.so vec gd.so, ali verujem da si onako pogresio. Promeni distro za neki koji radi (testiraj prvo u lokalu) ili uzmi FreeBSD/NetBSD server (tesko se to nalazi, ali bas taj PHP 4.4.2 super radi sa GD+freetype2 na NetBSD 3 - znam).

Solucija br.2 je da skines sors, i molis boga da moze da se kompajlira ;-)

[Ovu poruku je menjao flylord dana 26.06.2006. u 08:59 GMT+1]
 
Odgovor na temu

mulaz
Ljubljana

Član broj: 47602
Poruke: 2239
*.dial-up.dsl.siol.net.

Jabber: mulaz@elitesecurity.org
Sajt: www.mulaz.org


+184 Profil

icon Re: Debian, php i gd.so26.06.2006. u 01:05 - pre 186 meseci
zasto se ne bi iskompajlirao?

inace treba ti lib gd za taj build php-a koji imas

btw, si php sam kompajlirao?


[Ovu poruku je menjao flylord dana 26.06.2006. u 08:59 GMT+1]
Bolje ispasti glup nego iz aviona
http://www.mulaz.org/
 
Odgovor na temu

bojan_bozovic

Član broj: 29028
Poruke: 3292
*.pat-pool.le.sbb.co.yu.

Sajt: angelstudio.org


+392 Profil

icon Re: Debian, php i gd.so26.06.2006. u 01:09 - pre 186 meseci
Ako je do gd.so onda kompajliraj php sa staticki linkovanim gd.

[Ovu poruku je menjao flylord dana 26.06.2006. u 09:00 GMT+1]
 
Odgovor na temu

Not now, John!

Član broj: 231
Poruke: 1317
87.250.104.*



+4 Profil

icon Re: Debian, php i gd.so26.06.2006. u 01:12 - pre 186 meseci
Ako sumnjaš da je problem do Debianovog paket menadžera skini lijepo source kod PHP-a i kompajliraj ga. GD2 podrška dolazi uz PHP, tako da ne treba posebno da je instaliraš. Evo kako sam ja kompajlirao i sve je prošlo uredno:
'./configure' '--prefix=/usr' '--sysconfdir=/etc' '--with-apxs2' '--with-config-file-path=/etc' '--with-zlib=/usr' '--enable-bcmath' '--with-bz2=/usr/lib' '--enable-calendar' '--enable-dba' '--enable-exif' '--enable-ftp' '--with-gd' '--with-jpeg-dir=/usr/lib' '--with-png-dir=/usr/lib' '--with-zlib-dir=/usr/lib' '--with-xpm-dir=/usr/lib' '--with-ttf=/usr/lib' '--with-freetype-dir=/usr/lib' '--enable-gd-native-ttf' '--with-gettext' '--enable-mbstring' '--with-mysql=/usr/lib/mysql' '--with-mysqli=/usr/bin/mysql_config' '--with-ncurses' '--with-pear' '--with-readline'
make && make install

Inače, u php.ini nemam ništa od eksplicitno uključenih ektenzija, tako da php.ini ne moraš da mijenjaš zbog GD2 podrške.
"I'd take the awe of understanding over the awe of ignorance any day."
- Douglas Adams
 
Odgovor na temu

mrki
radnik
Sombor

Član broj: 1050
Poruke: 580
*.129.nat-pool-bgd.sbb.co.yu.

Jabber: mrki@elitesecurity.org
ICQ: 58816584


Profil

icon Re: Debian, php i gd.so26.06.2006. u 01:52 - pre 186 meseci
Code:

zasto se ne bi iskompajlirao?

inace treba ti lib gd za taj build php-a koji imas

btw, si php sam kompajlirao?


I koristim takav
Imam jednostavno 5 razlicith iskompaljliranih modula, sto 4vorke sto 5ice...s kojim god da probam nece!
Jedina stvar koju sam nisam kompajlirao je gd.so, njega sam apt-get install php4-GD.
Verziju gd koju sam ukljucio je gd-2.0.33 (make je prosao bez problema).

btw @bojan_bozovic
mojne me sa varijantama promeni distro, ok
sta si hteo reci:
"Ako je do gd.so onda kompajliraj php sa staticki linkovanim gd" ???

[Ovu poruku je menjao flylord dana 26.06.2006. u 09:00 GMT+1]
Nekad sam bio mlad ;)
 
Odgovor na temu

mrki
radnik
Sombor

Član broj: 1050
Poruke: 580
*.129.nat-pool-bgd.sbb.co.yu.

Jabber: mrki@elitesecurity.org
ICQ: 58816584


Profil

icon Re: Debian, php i gd.so26.06.2006. u 01:58 - pre 186 meseci
Code:

Inače, u php.ini nemam ništa od eksplicitno uključenih ektenzija


;extension=mcrypt.so
;extension=mysql.so
extension=gd.so
;extension=domxml.so
zend_extension=/usr/local/Zend/lib/ZendExtensionManager.so
zend_extension_ts=/usr/local/Zend/lib/ZendExtensionManager_TS.so

Nekad sam bio mlad ;)
 
Odgovor na temu

mulaz
Ljubljana

Član broj: 47602
Poruke: 2239
*.dial-up.dsl.siol.net.

Jabber: mulaz@elitesecurity.org
Sajt: www.mulaz.org


+184 Profil

icon Re: Debian, php i gd.so26.06.2006. u 17:12 - pre 186 meseci
Citat:

php -v
PHP 4.4.2 (cli) (built: Feb 27 2006 22:44:57)
Copyright (c) 1997-2006 The PHP Group
Zend Engine v1.3.0, Copyright (c) 1998-2004 Zend Technologies

-rw-r--r-- 1 root root 81884 2005-08-25 05:27 gd.so

php.ini:
extension_dir = "/usr/lib/php4/20020429/"
extension=msql.so


php je build: 20060227
kako moze extension dir da bude 20020429 ? 4godina stariji extensioni od php-a?
ili proveri dali postoji neki novi extension dir i pormeni ga u php.ini ili stvarno na novo iskompajliraj gd
Bolje ispasti glup nego iz aviona
http://www.mulaz.org/
 
Odgovor na temu

[es] :: PHP :: Debian, php i gd.so

[ Pregleda: 2564 | Odgovora: 7 ] > FB > Twit

Postavi temu Odgovori

Navigacija
Lista poslednjih: 16, 32, 64, 128 poruka.