Navigacija
Lista poslednjih: 16, 32, 64, 128 poruka.

Cisco - rtp priority

[es] :: Enterprise Networking :: Cisco - rtp priority

Strane: 1 2

[ Pregleda: 6488 | Odgovora: 28 ] > FB > Twit

Postavi temu Odgovori

Autor

Pretraga teme: Traži
Markiranje Štampanje RSS

kosac
BG

Član broj: 21764
Poruke: 341
*.adsl.sezampro.yu.



+5 Profil

icon Cisco - rtp priority13.02.2006. u 20:17 - pre 188 meseci
Ajd kad mi danas vec dobro ide da pitam jos nesto. :)

CCM se nalazi u BG-u a imam i nekoliko filijala po Srbiji i na svakoj od njih po nekoliko IP telefona. Filijale su vezane FR-om sa BG-om. U filijalama se nalazi 2801 a u BG-u 3825. Na dnu poruke su podesavanja FR-a.

Problem je sto ovaj rtp priority ne radi onako kako bi trebao da radi.
Pozovem nekog u filijalu i razgovor tece normalno. Cist zvuk.
Onda pokrenem neki "teski" download iz te filijale i razgovor odmah pocne da secka.
Znaci da QoS ne radi.

Ima li neko ideju sta bih jos mogao da odradim?
Gojko?


interface Serial0/0/0
no ip address
encapsulation frame-relay IETF
frame-relay traffic-shaping
!
interface Serial0/0/0.1 point-to-point
description Frame Relay veza ka Novom Sadu
ip address 10.10.100.1 255.255.255.252
frame-relay class cir128
frame-relay interface-dlci 101 CISCO
frame-relay ip rtp header-compression
!
map-class frame-relay cir128
frame-relay fragment 160
frame-relay ip rtp priority 16384 16383 100
frame-relay traffic-rate 128000 256000
frame-relay fair-queue
 
Odgovor na temu

MihailoM
Mihailo Marjanovic
Beograd

Član broj: 56363
Poruke: 15
*.telekom.yu.



Profil

icon Re: Cisco - rtp priority14.02.2006. u 08:07 - pre 188 meseci
Ne znam za rtp priority, ali čini mi se da bi trebalo da staviš traffic rate 64000 128000, a mogao bi i da promeniš ime map klase.
 
Odgovor na temu

kosac
BG

Član broj: 21764
Poruke: 341
*.wiener.co.yu.



+5 Profil

icon Re: Cisco - rtp priority14.02.2006. u 08:17 - pre 188 meseci
Citat:
MihailoM: Ne znam za rtp priority, ali čini mi se da bi trebalo da staviš traffic rate 64000 128000, a mogao bi i da promeniš ime map klase.


Najiskrenije ... nisam te razumeo!
Zasto da odradim te dve stvari?
 
Odgovor na temu

positive0

Član broj: 64952
Poruke: 143
*.logosoft.ba.



Profil

icon Re: Cisco - rtp priority14.02.2006. u 08:28 - pre 188 meseci


Probaj ovako:

class-map voice
match ip rtp 16384 16383

class-map ostali_saobracaj
match ostali_saobracaj

policy-map priority
class voice
priority bandwidth_u_procentima_ili_kbps
class ostali_saobracaj
bandwidth bandwidth_u_procentima_ili_kbps

map-class frame-relay cir128
service-policy output priority

pozdrav,

Sasa
 
Odgovor na temu

MihailoM
Mihailo Marjanovic
Beograd

Član broj: 56363
Poruke: 15
*.telekom.yu.



Profil

icon Re: Cisco - rtp priority14.02.2006. u 10:16 - pre 188 meseci
Zato što ti je port u NS 128/64, pa treba da pustiš PVC da radi između ove dve vrednosti. Do sada si bombardovao Novi Sad malo više nego što može da podnese. A ime promeni čisto da odgovara stvarnoj situaciji.
 
Odgovor na temu

kosac
BG

Član broj: 21764
Poruke: 341
*.wiener.co.yu.



+5 Profil

icon Re: Cisco - rtp priority14.02.2006. u 10:29 - pre 188 meseci
Citat:
positive0: Probaj ovako:

class-map voice
match ip rtp 16384 16383

class-map ostali_saobracaj
match ostali_saobracaj

policy-map priority
class voice
priority bandwidth_u_procentima_ili_kbps
class ostali_saobracaj
bandwidth bandwidth_u_procentima_ili_kbps

map-class frame-relay cir128
service-policy output priority

pozdrav,

Sasa


Sad cu to da postavim pa da probam.

Citat:
MihailoM: Zato što ti je port u NS 128/64, pa treba da pustiš PVC da radi između ove dve vrednosti. Do sada si bombardovao Novi Sad malo više nego što može da podnese. A ime promeni čisto da odgovara stvarnoj situaciji.


Zbunj! A kako si ti iz ovoga sto sam ja postovao ovde zakljucio koliki je port u NS ?
Ti radis u Telekomu?
 
Odgovor na temu

MihailoM
Mihailo Marjanovic
Beograd

Član broj: 56363
Poruke: 15
*.telekom.yu.



Profil

icon Re: Cisco - rtp priority14.02.2006. u 11:10 - pre 188 meseci
Veliki Brat vas posmatra...
 
Odgovor na temu

kosac
BG

Član broj: 21764
Poruke: 341
*.wiener.co.yu.



+5 Profil

icon Re: Cisco - rtp priority14.02.2006. u 11:13 - pre 188 meseci
JUPAK ?
Dane i Mihajlo? :)
 
Odgovor na temu

kosac
BG

Član broj: 21764
Poruke: 341
*.wiener.co.yu.



+5 Profil

icon Re: Cisco - rtp priority14.02.2006. u 11:45 - pre 188 meseci
Ja sam napravio jednu klasu posto imam samo jedan prioritet na linku - glas. Ostalo prolazi samo kad ima slobodnog linka. Da li je to OK ili moram napraviti i klasu za ostali saobracaj?



class-map match-all voice
match ip rtp 16384 16383
!
!
policy-map priority
class voice
priority percent 95
!
map-class frame-relay cir128
service-policy output priority
snmp-server community private RW
snmp-server community public RO
snmp-server ifindex persist
!


Citat:
positive0: Probaj ovako:

class-map voice
match ip rtp 16384 16383

class-map ostali_saobracaj
match ostali_saobracaj

policy-map priority
class voice
priority bandwidth_u_procentima_ili_kbps
class ostali_saobracaj
bandwidth bandwidth_u_procentima_ili_kbps

map-class frame-relay cir128
service-policy output priority

pozdrav,

Sasa
 
Odgovor na temu

positive0

Član broj: 64952
Poruke: 143
*.logosoft.ba.



Profil

icon Re: Cisco - rtp priority14.02.2006. u 13:39 - pre 188 meseci
Ne moras...mozes koristiti class_default - ova ti hvata sav ostali saobrcaj! Ona ce ti se svakako pitati nakon priority klase pa nije lose da joj eventualno explicitno definises i bandwidth, polising, shaping...sta ti volja



S

[Ovu poruku je menjao positive0 dana 14.02.2006. u 14:49 GMT+1]
 
Odgovor na temu

kosac
BG

Član broj: 21764
Poruke: 341
*.wiener.co.yu.



+5 Profil

icon Re: Cisco - rtp priority14.02.2006. u 14:03 - pre 188 meseci
Hvala!
Sve sam postavio kao sto sam i napisao ranije u poruci. Uradio sam mali test. Dok sam razgovarao sa koleginicom iz Novog Sada pustio sam i kopiranje nekog fajla od 1GB sa svog na njen racunar. Par puta je doslo do manjeg seckanja. Ovo je EXTREMNA situacija i nije realno da se tako nesto dogodi (kopiranje fajla od 1GB preko FR) u svakodnevnom koriscenju FR-a. Cekam reakcije korisnika iz ostalih filijala.

Hvala na pomoci.

Citat:
positive0: Ne moras...mozes koristiti class_default - ova ti hvata sav ostali saobrcaj! Ona ce ti se svakako pitati nakon priority klase pa nije lose da joj eventualno explicitno definises i bandwidth, polising, shaping...sta ti volja
 
Odgovor na temu

positive0

Član broj: 64952
Poruke: 143
*.logosoft.ba.



Profil

icon Re: Cisco - rtp priority14.02.2006. u 14:48 - pre 188 meseci

Do sjeckanja ne bi smjelo da dolazi...s obzirom da LLQ osigurava bandwidth/delay za tu klasu....mozda bi trebalo da pogledas jos jednom kako si primjenio map_class-u!

Da li ti je prioritet definisan i sa druge strane?

Sasa
 
Odgovor na temu

kosac
BG

Član broj: 21764
Poruke: 341
*.wiener.co.yu.



+5 Profil

icon Re: Cisco - rtp priority14.02.2006. u 15:13 - pre 188 meseci
Evo setovanja u BG-u i NS-u pa prosudi sam. Kako ti izgleda?

Beograd#sh run
!
class-map match-all voice
match ip rtp 16384 16383
!
policy-map priority
class voice
priority percent 90
!
interface Serial0/0/0.2 point-to-point
description Frame Relay veza ka Novom Sadu
ip address 10.10.100.1 255.255.255.252
frame-relay class cir128
frame-relay interface-dlci 101 CISCO
frame-relay ip rtp header-compression
!
map-class frame-relay cir128
service-policy output priority
snmp-server community private RW
snmp-server community public RO
snmp-server ifindex persist

Novi_Sad#sh run
!
interface Serial0/1/0
bandwidth 128
no ip address
encapsulation frame-relay IETF
ip route-cache flow
no fair-queue
frame-relay traffic-shaping
frame-relay lmi-type ansi
!
interface Serial0/1/0.1 point-to-point
ip address 10.10.100.2 255.255.255.252
frame-relay class cir128
frame-relay interface-dlci 100 CISCO
frame-relay ip rtp header-compression
!
class-map match-all voice
match ip rtp 16384 16383
!
policy-map priority
class voice
priority percent 95
!
map-class frame-relay cir128
service-policy output priority
snmp-server community private RW
snmp-server community public RO
snmp-server ifindex persist
!


Citat:
positive0: Do sjeckanja ne bi smjelo da dolazi...s obzirom da LLQ osigurava bandwidth/delay za tu klasu....mozda bi trebalo da pogledas jos jednom kako si primjenio map_class-u!

Da li ti je prioritet definisan i sa druge strane?

Sasa
 
Odgovor na temu

positive0

Član broj: 64952
Poruke: 143
*.logosoft.ba.



Profil

icon Re: Cisco - rtp priority14.02.2006. u 15:26 - pre 188 meseci
Ispade ti koristis 90% linka za voice???

Btw, koji kodek koristis? ova kompresija rtp headera moze praviti problem, u zavisnosti od kodeka koji koristis.

Ja bih ovako:

class-map match-all voice
match ip rtp 16384 16383
!
policy-map priority
class voice
priority percent 20
class class-default
bandwidth percent 80
random-detect
random-detect ecn
!
interface Serial0/0/0.2 point-to-point
description Frame Relay veza ka Novom Sadu
ip address 10.10.100.1 255.255.255.252
frame-relay class cir128
frame-relay interface-dlci 101 CISCO

!
map-class frame-relay cir128
adaptive-shaping becn
service-policy output priority



Novi_Sad#sh run
!
interface Serial0/1/0
bandwidth 128
no ip address
encapsulation frame-relay IETF
ip route-cache flow
no fair-queue
frame-relay traffic-shaping
frame-relay lmi-type ansi
!
interface Serial0/1/0.1 point-to-point
ip address 10.10.100.2 255.255.255.252
frame-relay class cir128
frame-relay interface-dlci 100 CISCO

!
class-map match-all voice
match ip rtp 16384 16383
!
policy-map priority
class voice
priority percent 20
class class-default
bandwidth percent 80
random-detect
random-detect ecn
!
map-class frame-relay cir128
adaptive-shaping becn
service-policy output priority


P.S. Ja sam stavio 20% za voice....ti ces vec vidjeti koliko ti treba - prosudi prema broju poziva i kodeku koji koristis!
E, da- mozda mozes umjesto adaptive-shapinga d ukljucis konkretne definicije za cir-ove...ja nisam znao kako su ti brzine distribuirane po dlci-ima, pa sam stavio adaptive-shaping becn!

Pozdrav,

Sasa


---

[Ovu poruku je menjao positive0 dana 14.02.2006. u 16:28 GMT+1]

[Ovu poruku je menjao positive0 dana 14.02.2006. u 16:47 GMT+1]
 
Odgovor na temu

positive0

Član broj: 64952
Poruke: 143
*.logosoft.ba.



Profil

icon Re: Cisco - rtp priority14.02.2006. u 15:56 - pre 188 meseci

BTW,

Mozda ne bilo lose da napravis posebnu klasu i samo za signaling saobracaj...sip, h323, mgcp...sta vec koristis...


--
 
Odgovor na temu

kosac
BG

Član broj: 21764
Poruke: 341
*.adsl.sezampro.yu.



+5 Profil

icon Re: Cisco - rtp priority14.02.2006. u 17:49 - pre 188 meseci
Pazi ovako ... dok sam imao FR 256/128 nisam imao nikakav problem. Sve je funkcionisalo perfektno. Onda sam oborio FR na 128/64 i poceli su problemcici. Nije ovo seckanje bas izrazeno ... dogodi se ponekad.
Zasto sam smanjio kapacitet FR-a? Pa razlika izmedju 256 i 128 je preko 20000 dinara mesecno pa to sve puta broj lokacija (koji ce biti poprilican) vidite koja se usteda ostvari mesecno! Codec za komunikaciju izmedju filijale i centrale je g729r8.
Svaka filijala ima od 6 do 10 IP telefona i isto toliko racunara.
Od aplikacija koje koriste FR na racunarima rade samo Outlook i IE. Nista vise.

Ideja je da voice ima puni prioritet a sve ostalo da koristi preostali deo bandwidth-a.

Mislis da treba da ukljucim adaptive-shaping ?





Citat:
positive0: Ispade ti koristis 90% linka za voice???

Btw, koji kodek koristis? ova kompresija rtp headera moze praviti problem, u zavisnosti od kodeka koji koristis.

P.S. Ja sam stavio 20% za voice....ti ces vec vidjeti koliko ti treba - prosudi prema broju poziva i kodeku koji koristis!
E, da- mozda mozes umjesto adaptive-shapinga d ukljucis konkretne definicije za cir-ove...ja nisam znao kako su ti brzine distribuirane po dlci-ima, pa sam stavio adaptive-shaping becn!
 
Odgovor na temu

positive0

Član broj: 64952
Poruke: 143
85.158.38.*



Profil

icon Re: Cisco - rtp priority14.02.2006. u 18:53 - pre 188 meseci
Voice-u ces dati puni prioritet vec samom cinjenicom da ga ukljucujes u LLQ queue...e sad da li za njega treba rezervisati bas 90% linka izracunaj sam:
ti si bas uzeo najfensi codec G729 - 8kbps po pozivu ako se dobro sjecam....vec si tu unio odredjeni processing i serialization delay (iako si smanjio end-to-end delay)...u svakom slucaju, 8kbps*8 telefona u prosjeku=64kbps u situaciji u kojoj ti svih 8 telefona prica istovremeno.

Kao bilo...ja bih prije isao na neki slabiji codec - meni licno najvise odgovara 711, ali to je vjerovatno zato sto imam bandwitha koliko hocu

frame-relay shaping obavezno stavi...njime kontrolises layer2 burst na samom FRF-u...kao sto sam ti rekao, posto ja ne znam koliko jos lokacija imas i kako ti ide taj burst na FRF-u, stavio sam adaptive-shaping....za tebe bi najbolje bilo da definises konkretne vrijednosti za cir i bc: shaping average itd....ima tu par komandi...

pozdrav,

Sasa
 
Odgovor na temu

kosac
BG

Član broj: 21764
Poruke: 341
*.adsl.sezampro.yu.



+5 Profil

icon Re: Cisco - rtp priority14.02.2006. u 19:10 - pre 188 meseci
Mislim da 711 koristi preko 45 kbps a 729 negde oko 25 kbps. Mogu to da tvrdim sa 85% sigurnosti ... mislim da sam to negde citao.
Po ovoj kalulaciji ja sam i stavio da bude 90%.

Da li ja treba obavezno da definisem vrednosti za CIR na ruteru?
Od cega on racuna tih 90% ... od tih definicija ili?

Mogu ja i da povecam CIR-ove na FR-ovim ali ne volim da placam ono sto ne moram. Zato se sad malo igram da vidim koliko mogu dobro da iskoristim i ovih 128/64 ! :)

Citat:
positive0: Voice-u ces dati puni prioritet vec samom cinjenicom da ga ukljucujes u LLQ queue...e sad da li za njega treba rezervisati bas 90% linka izracunaj sam:
ti si bas uzeo najfensi codec G729 - 8kbps po pozivu ako se dobro sjecam....vec si tu unio odredjeni processing i serialization delay (iako si smanjio end-to-end delay)...u svakom slucaju, 8kbps*8 telefona u prosjeku=64kbps u situaciji u kojoj ti svih 8 telefona prica istovremeno.

Kao bilo...ja bih prije isao na neki slabiji codec - meni licno najvise odgovara 711, ali to je vjerovatno zato sto imam bandwitha koliko hocu :)

frame-relay shaping obavezno stavi...njime kontrolises layer2 burst na samom FRF-u...kao sto sam ti rekao, posto ja ne znam koliko jos lokacija imas i kako ti ide taj burst na FRF-u, stavio sam adaptive-shaping....za tebe bi najbolje bilo da definises konkretne vrijednosti za cir i bc: shaping average itd....ima tu par komandi...

pozdrav,

Sasa
 
Odgovor na temu

kosac
BG

Član broj: 21764
Poruke: 341
*.adsl.sezampro.yu.



+5 Profil

icon Re: Cisco - rtp priority14.02.2006. u 19:13 - pre 188 meseci
A evo i jednog korisnog linka o tome koliko koji codec uzima bandwidth-a ...

http://www.cisco.com/warp/publ...ce-general/bwidth_consume.html
 
Odgovor na temu

positive0

Član broj: 64952
Poruke: 143
85.158.38.*



Profil

icon Re: Cisco - rtp priority14.02.2006. u 22:13 - pre 188 meseci
Citat:
kosac: Mogu to da tvrdim sa 85% sigurnosti ... mislim da sam to negde citao.


Kako si izracunao da si bas 85% siguran?
Nego...da...u pravu si...8kbps je bit rate!


Znaci jos jednom:


map-class cir128
no frame-relay adaptive-shaping
frame-relay cir 128000
frame-relay bc 640 (- ovde forsiras Tc=10 ms)
frame-relay mincir 64000 (- ne moras ovo stavljati jer ti je vec disablovan adaptive shaping, ali nije lose)
service-policy output priority


Sto se tvog pitanja o izracunavanju procenta tice, :
http://www.cisco.com/en/US/pro...9186a0080443156.html#wp1024688 ... u sustini, svodi se na to da se procenat izracunava na osnovu cir/2

A ako te i dalje brine na osnovu cega se izracunava procenat, predlazem ti dvije alternative:

1. koristi konkretne vrijednosti kbps unutar policy mape umjesto procenata!

2. shape-uj sav saobracaj na interfejsu drugom policy mapom:

policy-map shape
class-class-default
shape average 128
service-policy priority

a onda hvataj cir128 map-classom ovu shape klasu umjesto priority!




Ok?


Pozdrav

 
Odgovor na temu

[es] :: Enterprise Networking :: Cisco - rtp priority

Strane: 1 2

[ Pregleda: 6488 | Odgovora: 28 ] > FB > Twit

Postavi temu Odgovori

Navigacija
Lista poslednjih: 16, 32, 64, 128 poruka.