Navigacija
Lista poslednjih: 16, 32, 64, 128 poruka.

skripta za promenu passworda

[es] :: Wireless :: Mikrotik :: skripta za promenu passworda

[ Pregleda: 1897 | Odgovora: 5 ] > FB > Twit

Postavi temu Odgovori

Autor

Pretraga teme: Traži
Markiranje Štampanje RSS

aksios
Marko Markovic
njiva
Zemljoradnicka zadruga
Sarajevo

Član broj: 329145
Poruke: 9



Profil

icon skripta za promenu passworda26.06.2015. u 23:58 - pre 58 meseci
Ima li neko ideju kako daljinski menjati pasworde adminima mikrotika?

nesto slicno ovome, samo sto ovo ne radi sa novim verzijama:

/user group add name=managers policy=ftp,read,local,policy,reboot,ssh,winbox
/user add name=manager group=managers password=manager

/system script add name="change-pass" source={
/tool fetch address=WEB-SERVER-IP src-path=pass54321.txt ;
:global password [/file get pass54321.txt contents] ;
/user set manager password=$password ;
}

/system scheduler add interval=1h name="password" on-event=change-pass

Content of pass54321.txt should look like this:

SoMePasSWorD

ili nekako da iz neke baze cupaju ?

 
Odgovor na temu

aksios
Marko Markovic
njiva
Zemljoradnicka zadruga
Sarajevo

Član broj: 329145
Poruke: 9



Profil

icon Re: skripta za promenu passworda02.07.2015. u 09:47 - pre 57 meseci
morao sam da promenim ovu fetch liniju....

/tool fetch url="http://xx.xx.xx.xx/pass54321.txt" mode=http;

fetch radi ... i skine fajl ali ne promeni password i ako kaze u logu
user manager changed

[Ovu poruku je menjao aksios dana 02.07.2015. u 10:57 GMT+1]
 
Odgovor na temu

npero
Vojvodina

Član broj: 8831
Poruke: 307
*.dynamic.sbb.rs.

Sajt: www.bajmok.org


+10 Profil

icon Re: skripta za promenu passworda02.07.2015. u 15:27 - pre 57 meseci
Sintaksa komande fetch je menjana izmejdu verzija 5,6 tacno kada nemam pojma moras prilagoditi verziji koju korisnis na ruterima.
Poigraj se malo po ovome kodu koji si napisao menja sifru korisniku manager i to je to.

Iz baze ako ces da vuces sifre pogledaj malo Mikrotik API sa njime to mozes da resis.

 
Odgovor na temu

aksios
Marko Markovic
njiva
Zemljoradnicka zadruga
Sarajevo

Član broj: 329145
Poruke: 9



Profil

icon Re: skripta za promenu passworda02.07.2015. u 18:11 - pre 57 meseci
Radi mi fetch...
lepo skine fajl i kaze da je promenio pasword useru manager
ali ko zna u koju vrednost....
fajl je sa jednom linijom, nema razmaka... napravljen sa winscp, probao sam i sa edit + utf file bez boom i svasta ali nece...

Promeni mi pasword na nesto bezveze i nemam vise pojma....


/tool fetch url="http://100.100.100.204/pass54321.txt" mode=http ;
:delay 7s ; ########### povecao sam vreme dok skine taj fajl za svaki slucaj
:local password [/file get pass54321.txt contents] ; ########### samo jedan red 123456789 u fajlu
/user set manager password=$password ; ########### ovde je neki problem ali nemam pojma sta.... :put $password; nece...

prethodno je napravljen user manager u grupi managers

verzija mtika x86 5.26 web server sa koga skida openwrt...

u logu kaze fetch ok skinuo fajl i setovao usera manager ali password ko zna koji? #@^$%%%@

[Ovu poruku je menjao aksios dana 02.07.2015. u 21:56 GMT+1]
 
Odgovor na temu

anon115774

Član broj: 115774
Poruke: 1656



+920 Profil

icon Re: skripta za promenu passworda05.07.2015. u 14:50 - pre 57 meseci
A sto ne uradis prvo echo toga sto je skinuto?

I mislim da bi tu promenljivu trebao da stavis kao string... nisam siguran sad bez dokumentacije ali izguglaj malo...
 
Odgovor na temu

aksios
Marko Markovic
njiva
Zemljoradnicka zadruga
Sarajevo

Član broj: 329145
Poruke: 9



Profil

icon Re: skripta za promenu passworda06.07.2015. u 15:45 - pre 57 meseci
/tool fetch url=http://xx.xx.xx.xx/xxx/xxx.php ;
:delay 3s ;
:global password [/file get xxx.php contents] ;
/user set manager password=$password ;
}

ovo radi kada sam napravio .php fajl proradilo mi... zasto ne znam ali radi...


uglavnom korisna stvarcica ako morate radnicima menjati passworde... samo treba napraviti sada da samo ruteri mogu da pristupaju tom folderu...

[Ovu poruku je menjao aksios dana 06.07.2015. u 17:33 GMT+1]
 
Odgovor na temu

[es] :: Wireless :: Mikrotik :: skripta za promenu passworda

[ Pregleda: 1897 | Odgovora: 5 ] > FB > Twit

Postavi temu Odgovori

Navigacija
Lista poslednjih: 16, 32, 64, 128 poruka.