Navigacija
Lista poslednjih: 16, 32, 64, 128 poruka.

Django 1.5, virtualenv

[es] :: Python :: Django 1.5, virtualenv

[ Pregleda: 2527 | Odgovora: 3 ] > FB > Twit

Postavi temu Odgovori

Autor

Pretraga teme: Traži
Markiranje Štampanje RSS

disko

Član broj: 550
Poruke: 164
*.180.255.221.targo.rs.

ICQ: 84032332


+3 Profil

icon Django 1.5, virtualenv17.04.2013. u 22:50 - pre 84 meseci
Da li neko ima vremena da napise nesto o virtualenv i Django 1.5.
Cemu sluze, kako ih instalirati,setovati?

Hvala u napred.
 
Odgovor na temu

Panta_
Aleksandar Pantić
Kragujevac

Član broj: 214959
Poruke: 670



+116 Profil

icon Re: Django 1.5, virtualenv18.04.2013. u 06:35 - pre 84 meseci
Bilo je juce pisano nesto o tome.

Virtualenv je Python aplikacija za kreiranje izolovanih Python okruzenja u koja mozes da instaliras pakete bez mesanja istih sa sistemskim ili drugim drugim izolovanim virtuelnim Python okruzenjima.
Na primer, ako ti je za neki projekat potreban Django verzije 1.5 a za drugi verzije 1.3, ne mozes obe verzije da instaliras u sistemskom site-packages direktorijumu. Tu na scenu stupa virtualenv sa kojim mozes lako da kreiras dva izolovana okruzenja i u njima instaliras Django verzije koja ti je potrebna.

Sto se tice instalacije, imas na zvanicnom sajtu detaljno uputstvo. Ili, jednostavno Google.
 
Odgovor na temu

disko

Član broj: 550
Poruke: 164
*.180.255.221.targo.rs.

ICQ: 84032332


+3 Profil

icon Re: Django 1.5, virtualenv18.04.2013. u 18:21 - pre 84 meseci
Pogledao sam tutorijal na linku koji imas u avataru, stavite za Python3 neki tutorijal.
 
Odgovor na temu

vukasin0
Vukasin Nikodijevic
Beograd

Član broj: 15203
Poruke: 94
95.180.46.*



+1 Profil

icon Re: Django 1.5, virtualenv23.06.2013. u 10:32 - pre 82 meseci
Sa njihovog sajta:

"Django 1.5 is the first version of Django to support Python 3. The same code runs both on Python 2 (≥ 2.6.5) and Python 3 (≥ 3.2), thanks to the six compatibility layer."

Iskusno bih sacekao sledeci release, recimo 1.6 obicno su prve verzije buggy :)

Kod virtual env i kod interpretera koji ces koristiti je zachkoljica u tome da imas kompajliram python 3.0 i da ti bude dostupan an PATH-u. Recimo:

/usr/bin/python3

Ovo je direktiva koju trebas da koristis prilikom kreiranja virtuelnog okruzenja:

virtualenv --help

-p PYTHON_EXE, --python=PYTHON_EXE
The Python interpreter to use, e.g.,
--python=python2.5 will use the python2.5 interpreter
to create the new environment. The default is the
interpreter that virtualenv was installed with
(/usr/bin/python)

samo umesto python2.5, stavi python3.

Django posle dolazi kroz pip ili easy_install - zavisi sta koristis.

Ja sam ovo radio na mom CentOS server-u jer mi je trebao Python 2.7 a CentOS 6 dolazi sa Python 2.6.

Posto YUM koristi taj 2.6 onda su virtualenv + virtualenvwrapper dosli kao 1 na 10 ;)

Mislim da sam koristio ovaj link:

http://toomuchdata.com/2012/06...ll-python-2-7-3-on-centos-6-2/


Pozz
 
Odgovor na temu

[es] :: Python :: Django 1.5, virtualenv

[ Pregleda: 2527 | Odgovora: 3 ] > FB > Twit

Postavi temu Odgovori

Navigacija
Lista poslednjih: 16, 32, 64, 128 poruka.