Navigacija
Lista poslednjih: 16, 32, 64, 128 poruka.

PHP komapjliranje sa Apache 2.0.39

[es] :: Linux/UNIX serveri i servisi :: PHP komapjliranje sa Apache 2.0.39

[ Pregleda: 2970 | Odgovora: 6 ] > FB > Twit

Postavi temu Odgovori

Autor

Pretraga teme: Traži
Markiranje Štampanje RSS

Riste Pejov
Team Leader/Senior Software Developer @
Ein-Sof ltd Skopje
Skopje, Macedonia

Član broj: 128
Poruke: 571
212.110.78.*

Jabber: richie@bagra.net.mk
ICQ: 154236769
Sajt: riste.softver.org.mk


Profil

icon PHP komapjliranje sa Apache 2.0.3914.07.2002. u 02:05 - pre 241 meseci
Neznam u cemu je fora, ali kad skinem zadnje verzije
php-a (4.2.1) kao DSO(apxs) i Apache web servera (2.0.39) PHP nece da se iskompajlira,
javlja gresku u php_functions.c
jer se nekome ovo desavalo ?
People who think they know everything tend to irritate those of us who do.
 
Odgovor na temu

caboom
Igor Bogicevic
bgd

Član broj: 255
Poruke: 1503
*.verat.net

ICQ: 60630914


+1 Profil

icon Re: PHP komapjliranje sa Apache 2.0.3914.07.2002. u 04:14 - pre 241 meseci
--with-apxs2, a ne --with-apxs...
$ ./configure --help
posto se API podosta izmenio, ako to ne pomogne, onda je nesto neobicnije u pitanju :)
 
Odgovor na temu

Predrag Damnjanovic
Predrag Damnjanovic
Nis, Srbija

Član broj: 141
Poruke: 1305
*.bankerinter.net

Sajt: www.mycity.rs


+1 Profil

icon Re: PHP komapjliranje sa Apache 2.0.3914.07.2002. u 13:48 - pre 241 meseci
Meni PHP uopste nije dao da ga ukompajliram u apache 2.x.
Bukvalno nije hteo, nije ni doslo do greske, kao nije pravljen da se ukompajlira u apache 2.x...
 
Odgovor na temu

caboom
Igor Bogicevic
bgd

Član broj: 255
Poruke: 1503
*.verat.net

ICQ: 60630914


+1 Profil

icon Re: PHP komapjliranje sa Apache 2.0.3914.07.2002. u 15:25 - pre 241 meseci
pre svega je i navedeno da je apache 2.x.x eksperimentalni httpd koji ti ne garantuje apsolutno nista osim da ce ti zauzimati prostor na disku, a sa php-om se taj rizik (prostor) povecava. apache 2.x.x ima obicaj da menja odredjne delove api-a iz verzije u verziju (srecom ne toliko cesto) i niko ti ne garantuje da ce to raditi ok sa php-om kao modulom. treba obratiti paznju na to da ako kompaliras php preko apxs-a da koristis --with-apxs2=/path/to/apxs, ako vec koristis apache 2.x.x (./configure --help).
ovo je jos jedan nauk da se ne treba paliti na najnoviju verziju, vec procitati release notes kao i iskustva drugih. apache 2.x.x nikako ne treba koristiti na produkcionim masinama vec samo na "kucnim" masinama, a i neces dobiti nesto znacajno na performansama ukoliko nemas viseprocesorsku masinu, pogotovo na linux-u, a opet, ako ti trebaju bolje performanse, znaci da imas veoma opterecen server na koji stavljati nestabilini httpd mozemo izjednaciti sa pucanjem u glavu i cekanjem da iskrvaris i tako dolazimo do catch 22 situacije... u prevodu, treba sacekati jos 6 meseci do godinu-dve da apache 2.x.x postane zaista upotrebljiv u produkcionim uslovima. ovo je mala digresija kako bih vas upozorio na ono sto moze da vam se desi, kao odredjenom broju mojih drugara koji su se popalili na stable release apache-a 2.x.x-a i nakon nedelju dana i silnog nerviranja vratili na apache 1.3.x.
 
Odgovor na temu

Riste Pejov
Team Leader/Senior Software Developer @
Ein-Sof ltd Skopje
Skopje, Macedonia

Član broj: 128
Poruke: 571
62.162.102.*

Jabber: richie@bagra.net.mk
ICQ: 154236769
Sajt: riste.softver.org.mk


Profil

icon Re: PHP komapjliranje sa Apache 2.0.3915.07.2002. u 10:12 - pre 241 meseci
tako i sam uradio sa --with-apxs2=/usr/local/apache2/bin/apxs

ali ipak nece PHP uopste da se iskompajlira, pri make javlja neku gresku :P
People who think they know everything tend to irritate those of us who do.
 
Odgovor na temu

B o j a n
eCTRL
EU

Član broj: 1178
Poruke: 2925
*.yubc.net

Jabber: bc@default.co.yu
Sajt: default.co.yu/~bc


+1 Profil

icon Re: PHP komapjliranje sa Apache 2.0.3915.07.2002. u 13:09 - pre 241 meseci
Ja bejah namestih php 4.malkomatori i apache 2.istomator, ali ne preko apx2-a, samo što sam dodao php modul u compile time-u ( --activate-module ), a ne preko rapsalog apx-a. Stvarno se ne sećam tačnih verzija.


"It's okay, I'm just admiring to the shape of your skull!" -- Dr. Gonzo
 
Odgovor na temu

Riste Pejov
Team Leader/Senior Software Developer @
Ein-Sof ltd Skopje
Skopje, Macedonia

Član broj: 128
Poruke: 571
62.162.102.*

Jabber: richie@bagra.net.mk
ICQ: 154236769
Sajt: riste.softver.org.mk


Profil

icon Re: PHP komapjliranje sa Apache 2.0.3917.07.2002. u 09:23 - pre 241 meseci
Covece to sigurno nije bio apache 2.x,
posto php jos pri ./configure --with-apache javlja da nece da se kompajlira staticki sa apache 2.x, nego mora samo 1.x
People who think they know everything tend to irritate those of us who do.
 
Odgovor na temu

[es] :: Linux/UNIX serveri i servisi :: PHP komapjliranje sa Apache 2.0.39

[ Pregleda: 2970 | Odgovora: 6 ] > FB > Twit

Postavi temu Odgovori

Navigacija
Lista poslednjih: 16, 32, 64, 128 poruka.