Navigacija
Lista poslednjih: 16, 32, 64, 128 poruka.

PHP/MySQL prebacivanje na server ISP-a

[es] :: PHP :: PHP/MySQL prebacivanje na server ISP-a

[ Pregleda: 1906 | Odgovora: 3 ] > FB > Twit

Postavi temu Odgovori

Autor

Pretraga teme: Traži
Markiranje Štampanje RSS

sasas
Saša Slavnić
radim za neke švabe

Član broj: 35478
Poruke: 617
*.zaslon-telecom.si.



Profil

icon PHP/MySQL prebacivanje na server ISP-a22.10.2004. u 08:11 - pre 213 meseci
Trebam poceti rad na jednom web siteu, koristim PHP/MySQL kombinaciju (nisam ranije koristio ni jedno od njih). Imam dva pitanja (za pocetak ):

1. Kod mene rade stranice i sa win-1250 i sa utf-8 kodnim rasporedom, vidim sva nasa slova, php lepo sve upisuje/cita u bazu (planiram da koristim utf-8 ). Da li ce tako i ostati kad prebacim sve na server na kom ce se sajt hostovati? Vazno mi je da znam jer se dosta podataka upisuje u bazu pre nego sto se sajt postavi kod provajdera.

2. Koristim MySQL 4.0.29 i php5. Da li cu imati problema sa kompatibilnoscu, ako provajder na serverima ima php 3.xx/4.xx ili neku stariju verziju baze? Da li mi je pametnije da ja na svom compu 'spustim' verzije, da bih osigurao vecu kompatibilnost? (npr. da koristim php4, za koji vidim da ga vecima provajdera podrzava). Koliko je pitanje verzija PHP/MySQL uopste bitno?

ss.
When something is hard to do, then it's not worth doing.
 
Odgovor na temu

broker

Član broj: 2415
Poruke: 8514
212.62.59.*



+11 Profil

icon Re: PHP/MySQL prebacivanje na server ISP-a22.10.2004. u 10:27 - pre 213 meseci
1. Trebalo bi da nema problema.

2. Nikad nemoj koristiti najnovije verzije MySQL-a i PHP-a. Najbolje je da vidis sta imas na raspolaganju kod provajdera i onda da korstis priblizno istu verziju. Kod promene verzije (narocito celog brroja) obicno idu i neke radikalnije izmene koje umeju da budu nekompatibilne sa ranijim verzijama i onda skriptovi ne rade a mnogo je teze naci problem jer si naucio i navikao na ono sto si procitao u uputsvu i ne znas da to ne vazi za neku drugu verziju.

Takodje, izbegavaj da mnogo prilagodjavas svoje servere. Sereri pruzaju dosta prostora za prilagodjavanje, medjutim, takva podesavanja ne mozes da izvedes na sereru provajdera. Najbolje je da sa provajderom vidis da ti dostave informaciju kako je server konfigurisan i da na isti nacin podesis i server na kome razvijas apliakciju.

U tvom slucaju, stavi na lokalni server PHP 4 i proveri skriptove da li rade na njemu. Vrlo je verovatno da skriptovi pisani za PGP 5 nece raditi na PHP 4.
 
Odgovor na temu

sasas
Saša Slavnić
radim za neke švabe

Član broj: 35478
Poruke: 617
*.zaslon-telecom.si.



Profil

icon Re: PHP/MySQL prebacivanje na server ISP-a22.10.2004. u 10:55 - pre 213 meseci
Citat:
broker
2. Nikad nemoj koristiti najnovije verzije MySQL-a i PHP-a. Najbolje je da vidis sta imas na raspolaganju kod provajdera i onda da korstis priblizno istu verziju.


Da li mozes biti malo konkretniji oko verzija? Stvar je u tome da jos nisam izabrao provajdera, pa me zanima da li postoje neke verzije koje su opste prihvacene, tj. koje se najcesce srecu kod provajdera.

I hvala na odgovoru, tacno te informacije su mi trebale.

lp, ss.


When something is hard to do, then it's not worth doing.
 
Odgovor na temu

broker

Član broj: 2415
Poruke: 8514
212.62.59.*



+11 Profil

icon Re: PHP/MySQL prebacivanje na server ISP-a22.10.2004. u 19:58 - pre 213 meseci
Najbolje je da pitas provajdera koje verzije servera korsiti. Mislim da su sada najcesce php 4.x i Mysq 3.x. Onda pogledas u changelog za oba servera kakvih je sve izmena bilo unazad koliko da ti ne promakne nesto bitno...

 
Odgovor na temu

[es] :: PHP :: PHP/MySQL prebacivanje na server ISP-a

[ Pregleda: 1906 | Odgovora: 3 ] > FB > Twit

Postavi temu Odgovori

Navigacija
Lista poslednjih: 16, 32, 64, 128 poruka.