Navigacija
Lista poslednjih: 16, 32, 64, 128 poruka.

ADSL preko EUnet-a, IPTV telekoma i Cisco 877 dzumbus

[es] :: ISP :: ADSL :: ADSL preko EUnet-a, IPTV telekoma i Cisco 877 dzumbus
(TOP topic, by djricky)

[ Pregleda: 5260 | Odgovora: 7 ] > FB > Twit

Postavi temu Odgovori

Autor

Pretraga teme: Traži
Markiranje Å tampanje RSS

vuckovic
Dusan Vuckovic
Sef IT
Elektronski fakultet u Nisu
Nis

Član broj: 13953
Poruke: 53

Sajt: https://rs.linkedin.com/i..


+1 Profil

icon ADSL preko EUnet-a, IPTV telekoma i Cisco 877 dzumbus02.08.2015. u 22:32 - pre 87 meseci
Pozdrav,
procitah sve zivo o podesavanju Cisca za ADSL i to mi je ok , radi. Na korak sam do podesavanja i IPTV-a , ali sam zaglavio. Nesto od parametara mi ne valja. Kod startovanja STB-a dobije Code: 12 Waiting for network servers , mala pauza, prodje dalje, login screen, prodjem PIN kod, i onda crni ekran: Error during videoSetSink. Ubija me u pojam. Probao sam promenu razlicitih parametara ATM0.2 ali to nije pomoglo. Ima li nekog ko poznaje nekog u Telekomu - da je ovo radio ? Tech support obe firme, i EUnet-a i Telekoma me je 'ladno otkacio bez trunke kolegijalnosti. Ali to nije nista novo. Nezadrzivo srljamo u progres. Evo i konfiguracije :

Code:

Current configuration : 5008 bytes
!
! Last configuration change at 21:04:32 UTC Sun Aug 2 2015 by
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname cisco
!
boot-start-marker
boot-end-marker
!
enable secret 5 XXXXXXX
enable password 7 XXXXXXXX
no aaa new-model
!
dot11 ssid WWWWW
   vlan 1
   authentication open 
   authentication key-management wpa
   guest-mode
   wpa-psk ascii 7 XXXXXXXXX
!
ip cef
!
crypto pki trustpoint TP-self-signed-3115437063
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-3115437063
 revocation-check none
 rsakeypair TP-self-signed-3115437063
!
!

username yyyy privilege 15 secret 5 XXXXXXXXXX
username zzzz password 7 CCCCCCCCCC
!

!
bridge irb
!
!
!
interface BRI0
 no ip address
 encapsulation hdlc
!
interface ATM0
 no ip address
 no ip mroute-cache
 no atm ilmi-keepalive
 dsl operating-mode adsl2+ 
 dsl enable-training-log 
!
interface ATM0.1 point-to-point
 description ATM for internet
 no snmp trap link-status
 pvc 8/35 
  encapsulation aal5snap
  pppoe-client dial-pool-number 1
 !
!
interface ATM0.2 point-to-point
 description IPTV-VC
 no snmp trap link-status
 atm pvc 2 8 37 aal5snap 680 480
 bridge-group 2
 bridge-group 2 spanning-disabled
!
interface FastEthernet0
 no cdp enable
!
interface FastEthernet1
 description IPTV telekom 
 switchport access vlan 2
!
interface FastEthernet2
 switchport access vlan 2
!
interface FastEthernet3
!
interface Dot11Radio0
 no ip address
 !
 encryption vlan 1 mode ciphers aes-ccm 
 !
 broadcast-key vlan 1 change 45
 !
 !
 ssid WWWWWW
 !
 speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
 power local cck 10
 power local ofdm 10
 power client 17
 channel 2462
 station-role root
 rts threshold 2312
 world-mode dot11d country JP indoor
 no cdp enable
!
interface Dot11Radio0.1
 encapsulation dot1Q 1 native
 ip virtual-reassembly
 no cdp enable
 bridge-group 1
 bridge-group 1 subscriber-loop-control
 bridge-group 1 spanning-disabled
 bridge-group 1 block-unknown-source
 no bridge-group 1 source-learning
 no bridge-group 1 unicast-flooding
!
interface Vlan1
 no ip address
 ip virtual-reassembly
 bridge-group 1
!
interface Vlan2
 no ip address
 bridge-group 2
 bridge-group 2 spanning-disabled
!
interface Dialer0
 description WAN
 ip address negotiated
 no ip redirects
 no ip unreachables
 ip mtu 1492
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 dialer pool 1
 no cdp enable
 ppp pap sent-username [email protected] password 7 XXXXXXXXXX
 ppp ipcp dns request
!
interface BVI1
 ip address 192.168.10.55 255.255.255.0
 ip nat inside
 ip virtual-reassembly
!
interface BVI2
 no ip address
 ip virtual-reassembly
!
ip route 0.0.0.0 0.0.0.0 Dialer0
!
ip http server
ip http authentication local
ip http secure-server
ip nat inside source list 1 interface Dialer0 overload
!
access-list 1 permit 192.168.10.0 0.0.0.255
access-list 1 remark LAN
!
!
!
control-plane
!
bridge 1 protocol ieee
bridge 1 route ip
!
line con 0
 exec-timeout 0 0
 password 7 XXXXX
 no modem enable
line aux 0
line vty 0 4
 session-timeout 60 
 access-class 13 in
 exec-timeout 60 0
 privilege level 15
 login local
!
scheduler max-task-time 5000
ntp clock-period 17175091
ntp server 147.91.8.77
ntp server 31.19.179.249
ntp server 10.10.192.11
ntp server 212.200.82.130
end


A evo i outputa komandi :
Code:

sh int atm 0  
ATM0 is up, line protocol is up 
  Hardware is MPC ATMSAR (with Alcatel ADSL Module)
  MTU 4470 bytes, sub MTU 4470, BW 884 Kbit, DLY 410 usec, 
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ATM, loopback not set
  Encapsulation(s): AAL5  AAL2, PVC mode
  10 maximum active VCs, 1024 VCs per VP, 2 current VCCs
  VC Auto Creation Disabled.
  VC idle disconnect time: 300 seconds
  Last input 00:00:03, output 00:00:05, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: Per VC Queueing
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     1434 packets input, 695837 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     1037 packets output, 111611 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 output buffer failures, 0 output buffers swapped out
------------
ATM0.1 is up, line protocol is up 
  Hardware is MPC ATMSAR (with Alcatel ADSL Module)
  Description: ATM for internet
  MTU 4470 bytes, BW 884 Kbit, DLY 410 usec, 
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ATM
     456 packets input, 36290 bytes
     514 packets output, 41022 bytes 
     0 OAM cells input, 0 OAM cells output
  AAL5 CRC errors : 0
  AAL5 SAR Timeouts : 0
  AAL5 Oversized SDUs : 0
--------------
ATM0.2 is up, line protocol is up 
  Hardware is MPC ATMSAR (with Alcatel ADSL Module)
  Description: IPTV-VC
  MTU 4470 bytes, BW 884 Kbit, DLY 410 usec, 
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ATM
     987 packets input, 672892 bytes
     528 packets output, 70959 bytes 
     0 OAM cells input, 0 OAM cells output
  AAL5 CRC errors : 0
  AAL5 SAR Timeouts : 0
  AAL5 Oversized SDUs : 0


Hvala
 
Odgovor na temu

djricky
Network Engineer
Supernova
Beograd

SuperModerator
Član broj: 1046
Poruke: 4038
*.sbb.rs.

Sajt: https://v6.rs


+224 Profil

icon Re: ADSL preko EUnet-a, IPTV telekoma i Cisco 877 dzumbus05.08.2015. u 12:19 - pre 87 meseci
preleteo sam na brzaka, cini se da je dobro podeseno...

koliko se ja secam treba da bridge-ujes PVC (VPI/VCI 8/37, CBR sa PCR od 680 cell/sec) na neki ethernet interface...
“Choose a job you like, and you will never have to work a day of your life”
“Looking at small advantages prevents great affairs from being accomplished”

"Great power comes with great electricity bills"
"The fact that there's a highway to Hell but only a stairway to Heaven says a lot about anticipated traffic volume"
"Fate: protects fools, little children, and ships named NCC-1701"
 
Odgovor na temu

vuckovic
Dusan Vuckovic
Sef IT
Elektronski fakultet u Nisu
Nis

Član broj: 13953
Poruke: 53

Sajt: https://rs.linkedin.com/i..


+1 Profil

icon Re: ADSL preko EUnet-a, IPTV telekoma i Cisco 877 dzumbus06.08.2015. u 11:06 - pre 87 meseci
Hvala djricky,
jeste ok i jeste port bridge napravljen (Port 2 -> Bridge group 2 -> Vlan2 -> ATM0.2 )
Ja i dobijem login screen na televizoru, ukucam pin, sve to prodje, jedino stream ne vidim . Neki parametar veze na PVC-u 8/37 nedostaje. Juce sam zamenio Planet za Kendu, i kenda daje malo vise informacija o parametrima veze, pa cu da probam da prepisem .
Ako neko jos nesto zna, sada neka kaze ili cuti zauvek :D

Hvala
 
Odgovor na temu

vuckovic
Dusan Vuckovic
Sef IT
Elektronski fakultet u Nisu
Nis

Član broj: 13953
Poruke: 53

Sajt: https://rs.linkedin.com/i..


+1 Profil

icon Re: ADSL preko EUnet-a, IPTV telekoma i Cisco 877 dzumbus10.08.2015. u 22:55 - pre 87 meseci
Nece i nece.
Sve sam probao
 
Odgovor na temu

optix
CH

SuperModerator
Član broj: 7009
Poruke: 1866
*.mediaworksit.net.



+100 Profil

icon Re: ADSL preko EUnet-a, IPTV telekoma i Cisco 877 dzumbus21.08.2015. u 10:06 - pre 86 meseci
Relevantna konfiguracija:

Code:


!
no ip igmp snooping vlan 2
(neophodno, posto necemo da cisco radi bilo kakav IGMP snooping u vlan-u za IPTV, ili potpuno ugasiti za sve vlan-ove sa - no ip igmp snooping)
!
interface ATM0.2 point-to-point
 description IPTV
 bridge-group 2
 pvc 8/37
  encapsulation aal5snap
 !
!
interface Vlan2
 no ip address
 bridge-group 2
!
interface BVI2
 no ip address
!
interface FastEthernet1
 switchport access vlan 2
 spanning-tree portfast
!
bridge 2 protocol ieee (takodje, neophodno)


"99% of your thought process is protecting your self-conceptions,
and 98% of that is wrong."
 
Odgovor na temu

vuckovic
Dusan Vuckovic
Sef IT
Elektronski fakultet u Nisu
Nis

Član broj: 13953
Poruke: 53

Sajt: https://rs.linkedin.com/i..


+1 Profil

icon Re: ADSL preko EUnet-a, IPTV telekoma i Cisco 877 dzumbus21.08.2015. u 11:57 - pre 86 meseci
Probam, probam
HVALA !
 
Odgovor na temu

vuckovic
Dusan Vuckovic
Sef IT
Elektronski fakultet u Nisu
Nis

Član broj: 13953
Poruke: 53

Sajt: https://rs.linkedin.com/i..


+1 Profil

icon Re: ADSL preko EUnet-a, IPTV telekoma i Cisco 877 dzumbus21.08.2015. u 18:51 - pre 86 meseci
KRALJUUUUUUUUUU

znao sam da je neka sitna stvar i zato nisam dirao konfiguraciju . Samo je no igrp snoop bio problem . Radi ko zmaj. Cak mi se cini i malo brze menja stream-ove . Evo preciscenog koda, ako neko zaglavi kao ja. Dakle, internet, IPTV i WiFi podesen . Obratite paznju da ja ne koristim DHCP, pa to morate sami da dodate.

Plavom bojom su u kodu obelezena podesavanja vezana iskljucivo za IPTV .


version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname prvi
!
boot-start-marker
boot-end-marker
!
enable secret 5 <redacted>
enable password 7 <redacted>
!
no aaa new-model
!
dot11 ssid mile.voli.cisco
vlan 1
authentication open
authentication key-management wpa
guest-mode
wpa-psk ascii 7 <redacted>
!
ip cef
!
####### NAJVAZNIJE ZA IPTV
no ip igmp snooping
!

!
username <redacted> privilege 15 secret 5 <redacted>
!
!
!
bridge irb
!
!

interface BRI0
no ip address
encapsulation hdlc
!
interface ATM0
no ip address
no ip mroute-cache
no atm ilmi-keepalive
dsl operating-mode auto
dsl enable-training-log
!
interface ATM0.1 point-to-point
description ATM za internet
no snmp trap link-status
pvc 8/35
encapsulation aal5snap
pppoe-client dial-pool-number 1
!
!
interface ATM0.2 point-to-point
description IPTV
ip igmp static-group *
no snmp trap link-status
pvc 8/37
encapsulation aal5snap
!
bridge-group 2

!
interface FastEthernet0
description Internet1
no cdp enable
!
interface FastEthernet1
description IPTVport
switchport access vlan 2
spanning-tree portfast

!
interface FastEthernet2
!
interface FastEthernet3
!
interface Dot11Radio0
no ip address
!
encryption vlan 1 mode ciphers aes-ccm
!
broadcast-key vlan 1 change 45
!
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
power local cck 10
power local ofdm 10
power client 17
channel 2462
station-role root
rts threshold 2312
world-mode dot11d country JP indoor
no cdp enable
!
interface Dot11Radio0.1
encapsulation dot1Q 1 native
ip virtual-reassembly
no cdp enable
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 spanning-disabled
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
!
interface Vlan1
no ip address
ip virtual-reassembly
bridge-group 1
!
interface Vlan2
no ip address
bridge-group 2

!
interface Dialer0
description WAN
ip address negotiated
no ip redirects
no ip unreachables
ip mtu 1492
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
no cdp enable
ppp pap sent-username adsl.<redacted>@eunet password 7 <redacted>
ppp ipcp dns request
!
interface BVI1
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!
interface BVI2
no ip address
!

ip route 0.0.0.0 0.0.0.0 Dialer0
!
ip http server
ip http authentication local
ip http secure-server
ip nat inside source list 1 interface Dialer0 overload
!
access-list 1 permit 192.168.1.0 0.0.0.255
access-list 1 remark LAN
!
######## Meni nije ukljucen DHCP jer imam drugi na mrezi. Ako vam treba ne zaboravite da dodate
!
control-plane
!
bridge 1 protocol ieee
bridge 1 route ip
bridge 2 protocol ieee
!
line con 0
exec-timeout 0 0
password 7 <redacted>
no modem enable
line aux 0
line vty 0 4
session-timeout 60
access-class 13 in
exec-timeout 60 0
privilege level 15
login local
!
scheduler max-task-time 5000
ntp clock-period 17175085
ntp server 147.91.8.77
ntp server 31.19.179.249
ntp server 10.10.192.11
ntp server 212.200.82.130
end



I JOS JEDNOM HVALA OPTIX
 
Odgovor na temu

optix
CH

SuperModerator
Član broj: 7009
Poruke: 1866
*.mediaworksit.net.



+100 Profil

icon Re: ADSL preko EUnet-a, IPTV telekoma i Cisco 877 dzumbus21.08.2015. u 22:57 - pre 86 meseci
Pretpostavih da ti igmp snooping pravi problem jer nisi bio u stanju da promenis kanal, tj. pukne ti cim predjes sa ekrana za kucanje PIN-a na TV program. Tada se salje IGMP join poruka za stream koji zelis (prvi kanal po redu...), ili kad menjas kanale - leave/join.. i tu stvari puknu ako cisco radi IGMP snooping.

Brzina menjanja kanala je funkcija latencije (za igmp leave/join poruke) mreze, brzine dobijanja tzv "I" frame-a u stream-u za sinhronizaciju (ostali frame-ovi se discard-uju dok se kompletno ne primi ovaj frame) i brzine dekodiranja STB-a, ali to je neka druga prica..


Uzdravlje
"99% of your thought process is protecting your self-conceptions,
and 98% of that is wrong."
 
Odgovor na temu

[es] :: ISP :: ADSL :: ADSL preko EUnet-a, IPTV telekoma i Cisco 877 dzumbus
(TOP topic, by djricky)

[ Pregleda: 5260 | Odgovora: 7 ] > FB > Twit

Postavi temu Odgovori

Navigacija
Lista poslednjih: 16, 32, 64, 128 poruka.