Navigacija
Lista poslednjih: 16, 32, 64, 128 poruka.

3750 VLAN routing problem i Access Point 1131 AG multiple SSID?

[es] :: Enterprise Networking :: 3750 VLAN routing problem i Access Point 1131 AG multiple SSID?

[ Pregleda: 3408 | Odgovora: 6 ] > FB > Twit

Postavi temu Odgovori

Autor

Pretraga teme: Traži
Markiranje Štampanje RSS

zverko

Član broj: 9463
Poruke: 13
*.3.nat.stcable.net.



+1 Profil

icon 3750 VLAN routing problem i Access Point 1131 AG multiple SSID?02.05.2010. u 12:48 - pre 146 meseci
PROBLEM 1:
Imamo dva 3750 stekovana svica koji su vezani za vise 2960 preko redudantnih veza.L3 je VTP server i propagira vlanove ka 2960 VTP klijentima, ima kreirane vlanove sa odgovarajucim adresama, omoguceno je ip rutiranje, za neke vlanove je i dhcp server. Interfejsi su u trunk modu i propustaju sve vlanove. ASA 5530 firewall ce u dogledno vreme stici, ali do tada mi treba vlan rutiranje koje bi trebalo da radi 3750, ali se to ne desava iz ne znam kog razloga. Access liste cemo tek kreirati. Dole je deo konfiguracije. 2960 svicevi imaju interfejse u trunk modu i propustaju sve vlanove, a ostali portovi su u access modu sa dodeljenim nekim od vlanova.
Sve kao radi dobro: VTP propagira vlanove, dhcp na 3750 dodeljuje adrese (jos nema DNS-a), ali vlan rutiranje ne radi. Npr. sa pc-a koji je u vlanu 101 ne mogu da prodjem access pointu koji je u vlanu 103 ili da pingujem bilo koga u drugim vlanovima. Sa L3 pingujem bilo koga ali recimo sa 2960 na kome je PC nemam pristup drugim vlanovima na nekom drugom 2960 iako su svuda propusteni svi vlanovi. STP svuda globalno omogucen.
Dakle pitanje je zasto rutiranje izmedju vlanova ne funkcionise?

Cisco 3750 L3 switch:
- vlanovi sa odgovarajucim adresama i maskom
- VTP Server propagira VLANove ostalim 2960
- DHCP server za neke vlanove
- STP pvst globalno ikljucen zbog redudantnih linkova
- ip routing enabled i na show ip route all Vlans are (C) directly connected
- Interfaces u trunk mode allowed all VLANs

ip routing
ip dhcp pool AccessPool
network 10.1.103.0 255.255.255.0
default-router 10.1.103.1
ip dhcp pool Computers
network 10.1.101.0 255.255.255.0
default-router 10.1.101.1
spanning-tree mode pvst
interface GigabitEthernet1/0/1
switchport trunk encapsulation dot1q
switchport mode trunk
interface Vlan101
description Computers
ip address 10.1.101.1 255.255.255.0
interface Vlan102
description Cameras
ip address 10.1.102.1 255.255.255.0
interface Vlan103
description AccessPoints
ip address 10.1.103.1 255.255.255.0
ip classless

Cisco 2960 switch:
- VTP client
- STP omogucen
- Dva porta u trunk mode propustaju sve vlanove
interface FastEthernet0/2
switchport access vlan 101
switchport mode access
interface FastEthernet0/13
switchport access vlan 103
switchport mode access
interface GigabitEthernet0/1
switchport mode trunk


PROBLEM 2:
Na L2 svicu na access port je prikljucen 1131 Cisco Access Point (vlan 103 i 107-dhcp server je na L3 svicu). Kako da podesim AP da emituje dva SSID-a, tj da oba budu vidljiva i da svaki SSID pripada odredjenom vlanu koji ima dhcp na L3 svicu. Da li na L2 svicu port gde je zakacen AP treba staviti u trunk mod da propusta samo ova dva vlana.
 
Odgovor na temu

optix
CH

SuperModerator
Član broj: 7009
Poruke: 1866
*.optix.in.rs.



+100 Profil

icon Re: 3750 VLAN routing problem i Access Point 1131 AG multiple SSID?02.05.2010. u 15:40 - pre 146 meseci
2:

Npr konfiguracija kod mene, 'optix' ssid sa wpa2, 'test' open:
Code:

dot11 ssid optix
   vlan 100
   authentication open
   authentication key-management wpa
   guest-mode
   mbssid guest-mode
   wpa-psk ascii 7 *
!
dot11 ssid test
   vlan 150
   authentication open
   mbssid guest-mode
   information-element ssidl advertisement
!
interface Dot11Radio0
 encryption vlan 100 mode ciphers aes-ccm
 !
 broadcast-key vlan 100 change 30 membership-termination capability-change
 !
 ssid optix
 !
 ssid test
 !
 mbssid
!


Odgovarajuci interfejsi (dodaj za svaki vlan):
Code:

!
interface Dot11Radio0.100
 encapsulation dot1Q 100
 no ip route-cache
 no cdp enable
 bridge-group 100
 bridge-group 100 block-unknown-source
 no bridge-group 100 source-learning
 no bridge-group 100 unicast-flooding
 bridge-group 100 spanning-disabled
!
!
interface FastEthernet0.100
 encapsulation dot1Q 100
 no ip route-cache
 no cdp enable
 bridge-group 100
 no bridge-group 100 source-learning
 bridge-group 100 spanning-disabled
!


Management interfejs (netagovan vlan1)
Code:

!
interface Dot11Radio0.1
 encapsulation dot1Q 1 native
 no ip route-cache
 no cdp enable
 bridge-group 1
 bridge-group 1 block-unknown-source
 no bridge-group 1 source-learning
 no bridge-group 1 unicast-flooding
 bridge-group 1 spanning-disabled
!
interface FastEthernet0.1
 encapsulation dot1Q 1 native
 no ip route-cache
 no cdp enable
 bridge-group 1
 no bridge-group 1 source-learning
 bridge-group 1 spanning-disabled
!
interface BVI1
 ip address 10.10.10.200 255.255.255.0
 no ip route-cache
!

Na switch-u:
Code:

!
interface FastEthernet0/7
 description trunk ka ap1120
 switchport mode trunk 
 switchport trunk native vlan 1
 switchport trunk allowed vlan add 100,150
 switchport nonegotiate
 spanning-tree portfast trunk
 spanning-tree bpdufilter enable
!


Nije neophodno da budu konfigurisani iskljucivo vlan-ovi koji su na ap-u, mozes, ako hoces, da propustis i sve...


c2950-24#sh int fa0/7 trunk

Port Mode Encapsulation Status Native vlan
Fa0/7 on 802.1q trunking 1

Port Vlans allowed on trunk
Fa0/7 1,100,150

Port Vlans allowed and active in management domain
Fa0/7 1,100,150

Port Vlans in spanning tree forwarding state and not pruned
Fa0/7 1,100,150



1:

Mozes li da posaljes output-e 'sh vlan' i 'sh int trunk' sa switcheva?



"99% of your thought process is protecting your self-conceptions,
and 98% of that is wrong."
 
Odgovor na temu

DejanMilicevic
Novi Sad

Član broj: 238602
Poruke: 15
*.dynamic.sbb.rs.



Profil

icon Re: 3750 VLAN routing problem i Access Point 1131 AG multiple SSID?02.05.2010. u 21:30 - pre 146 meseci
Kao prvo hvala na pomoci, probacu ovo ali tek posle praznika nazalost pa cu imati i show za vlanove, trunk,...
AP-ove nisam konfigurisao preko CLI-a, ali vidim da se i to svuda tako radi kao i na ostalim Cisco uredjajima. Cujemo cim budem ovo probao.
 
Odgovor na temu

optix
CH

SuperModerator
Član broj: 7009
Poruke: 1866
*.optix.in.rs.



+100 Profil

icon Re: 3750 VLAN routing problem i Access Point 1131 AG multiple SSID?02.05.2010. u 23:12 - pre 146 meseci
Mislim da je jednostavnije, iz onog gui-a nisam nikad uspeo nista da konfigurisem, sav je nekako zbudzen...

Zbog cega dva nick-a?


"99% of your thought process is protecting your self-conceptions,
and 98% of that is wrong."
 
Odgovor na temu

DejanMilicevic
Novi Sad

Član broj: 238602
Poruke: 15
*.dynamic.sbb.rs.



Profil

icon Re: 3750 VLAN routing problem i Access Point 1131 AG multiple SSID?04.05.2010. u 22:06 - pre 146 meseci
Na slici je deo mreze i primer kako su vezani neki uredjaji. Ono sto sam dodao, a zaboravio na svim L2 svicevima je default gateway ka L3 (10.1.100.1). Ako port na svicu gde je AP vezan stavim u access mod vlan103 i definisem pripadnost SSID-a tom vlanu, onda AP-u mogu prici iz recimo vlana 101. E sad ako taj isti port stavim u trunk mod da propusta vlanove 1,103 i 107 ili cak sve onda nema prilaza-da li je potrebni da SVI adresa AP-a bude iz vlana 1 koji je za management ili moze ostati iz subneta vlana 103.
Da li bi se u ovakvom scenariju kao na slici mogli medjusobno videti recimo vlanovi 101 i 102. Dva SSID-a sada funkcionisu na AP-ovima i vidljiva su.
Prikačeni fajlovi
 
Odgovor na temu

jogurt
Zoran Milenković
nettverkskonsulent
Norway

Član broj: 13800
Poruke: 472
..1-166-240.customer.lyse.net.

Jabber: jogurt@elitesecurity.org
ICQ: 309530264


+8 Profil

icon Re: 3750 VLAN routing problem i Access Point 1131 AG multiple SSID?04.05.2010. u 22:39 - pre 146 meseci
Zdravo,

Ovde imas zajedno interVLAN routing, VTP, DHCP, trunking, WiFi, STP. Bas nista od ovih tehnologija nije nista posebno, a opet ti sve zajedno ne radi

Da sam na tvom mestu, razbio bih problem na proste cinioce, a onda bih probao da zakljucim gde me i sta me tacno zeza.

Na primer, na samom 3750 svicu proveri da li ti radi interVLAN routing izmedju access portova samog 3750 svica. Uveri se da to radi. Zatim otkaci redundantne linkove izmedju 3750 i 2960. Sve to mora da radi i sa po jednim linkom, a STP ces skloniti kao moguci problem. Redundansu dodaj na kraju. Probaj racunarima da zadas adrese, maske i default.gw. staticki. DHCP takodje ostavi za kasnije. Zatim, iskljuci i VTP. Ionako nemas bas puno sviceva. Wireless takodje posmatraj posebno. Polako, ali sigurno, trebalo bi da vidis sta te muci.

Srecno
Z
 
Odgovor na temu

dareezy
Niš

Član broj: 175511
Poruke: 22
194.99.236.*



+2 Profil

icon Re: 3750 VLAN routing problem i Access Point 1131 AG multiple SSID?05.05.2010. u 14:32 - pre 146 meseci
Mozda pomogne, inter vlan. Meni jeste.
Pozdrav
Say what?
 
Odgovor na temu

[es] :: Enterprise Networking :: 3750 VLAN routing problem i Access Point 1131 AG multiple SSID?

[ Pregleda: 3408 | Odgovora: 6 ] > FB > Twit

Postavi temu Odgovori

Navigacija
Lista poslednjih: 16, 32, 64, 128 poruka.